aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-08 13:10:39 +0800
committeredwin <edwin@FreeBSD.org>2007-09-08 13:10:39 +0800
commit1a39a954d98e30e35cdd8a97655b7e90ed74c146 (patch)
tree312e6d1553bfc9b1df37db23ffbc5b13f9f3cecc /sysutils
parent69646241dfdfc03e22b0e13b8a25933ccab2cece (diff)
downloadfreebsd-ports-gnome-1a39a954d98e30e35cdd8a97655b7e90ed74c146.tar.gz
freebsd-ports-gnome-1a39a954d98e30e35cdd8a97655b7e90ed74c146.tar.zst
freebsd-ports-gnome-1a39a954d98e30e35cdd8a97655b7e90ed74c146.zip
New port: sysutils/mtpfs MTP device filesystem
MTPFS is a FUSE filesystem that supports reading aand writing from any MTP device (as supported by libmtp) WWW: http://www.adebenham.com/mtpfs/
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mtpfs/Makefile25
-rw-r--r--sysutils/mtpfs/Makefile.bak24
-rw-r--r--sysutils/mtpfs/distinfo3
-rw-r--r--sysutils/mtpfs/files/patch-Makefile.in11
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.c11
-rw-r--r--sysutils/mtpfs/files/patch-mtpfs.h22
-rw-r--r--sysutils/mtpfs/pkg-descr4
8 files changed, 101 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index fd0850d6ab68..11d50f03cf0e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -411,6 +411,7 @@
SUBDIR += mountsmb2
SUBDIR += mpiexec
SUBDIR += msyslog
+ SUBDIR += mtpfs
SUBDIR += mtxorbd
SUBDIR += multitail
SUBDIR += munin-main
diff --git a/sysutils/mtpfs/Makefile b/sysutils/mtpfs/Makefile
new file mode 100644
index 000000000000..65b141950cd1
--- /dev/null
+++ b/sysutils/mtpfs/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mtpfs
+# Date created: 1 July 2007
+# Whom: John Hixson <john@divinix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtpfs
+PORTVERSION= 0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.adebenham.com/mtpfs/
+
+MAINTAINER= john@pcbsd.org
+COMMENT= MTP device filesystem
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+LIB_DEPENDS= mtp:${PORTSDIR}/audio/libmtp \
+ fuse:${PORTSDIR}/sysutils/fusefs-libs \
+ id3-3.8:${PORTSDIR}/audio/id3lib \
+ id3tag.0:${PORTSDIR}/audio/libid3tag
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/mtpfs
+
+.include <bsd.port.mk>
diff --git a/sysutils/mtpfs/Makefile.bak b/sysutils/mtpfs/Makefile.bak
new file mode 100644
index 000000000000..345ee2bf2af2
--- /dev/null
+++ b/sysutils/mtpfs/Makefile.bak
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mtpfs
+# Date created: 1 July 2007
+# Whom: John Hixson <john@divinix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtpfs
+PORTVERSION= 0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.adebenham.com/mtpfs/
+
+MAINTAINER= john@pcbsd.org
+COMMENT= MTP device filesystem
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+LIB_DEPENDS= mtp:${PORTSDIR}/audio/libmtp \
+ fuse:${PORTSDIR}/sysutils/fusefs-libs \
+ id3-3.8:${PORTSDIR}/audio/id3lib
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/mtpfs
+
+.include <bsd.port.mk>
diff --git a/sysutils/mtpfs/distinfo b/sysutils/mtpfs/distinfo
new file mode 100644
index 000000000000..6e088e7104a0
--- /dev/null
+++ b/sysutils/mtpfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (mtpfs-0.6.tar.gz) = d81202b04b621334952d42527ee1c8e7
+SHA256 (mtpfs-0.6.tar.gz) = be5245d779aaa8dbec6844ae3f62dfa236957c3444607f7387528ad5125a61a3
+SIZE (mtpfs-0.6.tar.gz) = 91014
diff --git a/sysutils/mtpfs/files/patch-Makefile.in b/sysutils/mtpfs/files/patch-Makefile.in
new file mode 100644
index 000000000000..ffcbcc12d024
--- /dev/null
+++ b/sysutils/mtpfs/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jul 1 11:45:44 2007
++++ Makefile.in Sun Jul 1 11:46:00 2007
+@@ -157,7 +157,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ mtpfs_SOURCES = id3read.c mtpfs.c mtpfs.h id3read.h
+-mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=22 $(FUSE_CFLAGS)
++mtpfs_CPPFLAGS = -DFUSE_USE_VERSION=25 $(FUSE_CFLAGS)
+ mtpfs_LDADD = $(FUSE_LIBS)
+ all: all-am
+
diff --git a/sysutils/mtpfs/files/patch-mtpfs.c b/sysutils/mtpfs/files/patch-mtpfs.c
new file mode 100644
index 000000000000..10420708ddef
--- /dev/null
+++ b/sysutils/mtpfs/files/patch-mtpfs.c
@@ -0,0 +1,11 @@
+--- mtpfs.c.orig Sun Jul 1 11:45:55 2007
++++ mtpfs.c Sun Jul 1 11:46:30 2007
+@@ -921,7 +921,7 @@
+ */
+
+ static int
+-mtpfs_statfs (const char *path, struct statfs *stbuf)
++mtpfs_statfs (const char *path, struct statvfs *stbuf)
+ {
+ if (DEBUG) g_debug ("mtpfs_statfs");
+ stbuf->f_bsize=1024;
diff --git a/sysutils/mtpfs/files/patch-mtpfs.h b/sysutils/mtpfs/files/patch-mtpfs.h
new file mode 100644
index 000000000000..e70bdacce00d
--- /dev/null
+++ b/sysutils/mtpfs/files/patch-mtpfs.h
@@ -0,0 +1,22 @@
+--- mtpfs.h.orig Sun Jul 1 11:45:49 2007
++++ mtpfs.h Sun Jul 1 11:46:22 2007
+@@ -18,7 +18,9 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <errno.h>
+-#include <sys/statfs.h>
++#include <sys/param.h>
++#include <sys/mount.h>
++#include <sys/statvfs.h>
+
+ #include <libmtp.h>
+ #include <glib.h>
+@@ -48,7 +50,7 @@
+ static int mtpfs_unlink (const gchar * path);
+ static int mtpfs_mkdir (const char *path, mode_t mode);
+ static int mtpfs_rmdir (const char *path);
+-static int mtpfs_statfs (const char *path, struct statfs *stbuf);
++static int mtpfs_statfs (const char *path, struct statvfs *stbuf);
+
+
+ static LIBMTP_mtpdevice_t *device;
diff --git a/sysutils/mtpfs/pkg-descr b/sysutils/mtpfs/pkg-descr
new file mode 100644
index 000000000000..7a021c63dcc6
--- /dev/null
+++ b/sysutils/mtpfs/pkg-descr
@@ -0,0 +1,4 @@
+MTPFS is a FUSE filesystem that supports reading aand writing from any
+MTP device (as supported by libmtp)
+
+WWW: http://www.adebenham.com/mtpfs/