aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-01-25 04:02:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-01-25 04:02:45 +0800
commit1e4084811248333e192b8dd34044d08c779bec68 (patch)
treec01f8404056e95504a5603f4169c43a43051b685 /sysutils
parent71c6bad5172690f60089876daadc02aba081dce3 (diff)
downloadfreebsd-ports-gnome-1e4084811248333e192b8dd34044d08c779bec68.tar.gz
freebsd-ports-gnome-1e4084811248333e192b8dd34044d08c779bec68.tar.zst
freebsd-ports-gnome-1e4084811248333e192b8dd34044d08c779bec68.zip
- Clarify LICENSE
- Add LICENSE_FILE - Add NO_ARCH - Use NO_BUILD instead of empty do-build target - Switch to options helpers
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/password-store/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/sysutils/password-store/Makefile b/sysutils/password-store/Makefile
index 10adcc052ccb..5f6337125030 100644
--- a/sysutils/password-store/Makefile
+++ b/sysutils/password-store/Makefile
@@ -9,7 +9,8 @@ MASTER_SITES= http://git.zx2c4.com/password-store/snapshot/
MAINTAINER= ports@FreeBSD.org
COMMENT= Stores, retrieves, generates, and synchronizes passwords securely
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
getopt>=0:${PORTSDIR}/misc/getopt \
@@ -17,23 +18,21 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
pwgen>=0:${PORTSDIR}/sysutils/pwgen \
tree>=1.7:${PORTSDIR}/sysutils/tree
+NO_ARCH= yes
+NO_BUILD= yes
+
OPTIONS_DEFINE= GIT XCLIP CONTRIB DOCS EXAMPLES
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
GIT_DESC= Enable git storage
XCLIP_DESC= Enable xclip feature
-CONTRIB_DESC= Include shell completions, import scripts, related projects
-
-.include <bsd.port.options.mk>
+CONTRIB_DESC= Include shell completions, import scripts, related projects
-.if ${PORT_OPTIONS:MGIT}
-RUN_DEPENDS+= git>=0:${PORTSDIR}/devel/git
-.endif
+GIT_RUN_DEPENDS= git>=0:${PORTSDIR}/devel/git
+XCLIP_RUN_DEPENDS= base64>=0:${PORTSDIR}/converters/base64 \
+ xclip>=0:${PORTSDIR}/x11/xclip
-.if ${PORT_OPTIONS:MXCLIP}
-RUN_DEPENDS+= base64>=0:${PORTSDIR}/converters/base64 \
- xclip>=0:${PORTSDIR}/x11/xclip
-.endif
+.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MGIT} && ! ${PORT_OPTIONS:MXCLIP}
EXTRA_PATCHES= ${PATCHDIR}/git+xclip.patch:-p1
@@ -47,21 +46,18 @@ post-patch:
@${REINPLACE_CMD} -Ee 's|GETOPT="getopt"|GETOPT="${LOCALBASE}/bin/getopt"|' ${WRKSRC}/src/password-store.sh
@${REINPLACE_CMD} -Ee 's|SHRED="shred -f -z"|SHRED="rm -P -f"|' ${WRKSRC}/src/password-store.sh
-# empty to skip make
-do-build:
-
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/src/password-store.sh ${STAGEDIR}${PREFIX}/libexec/pass
@${LN} -s ${PREFIX}/libexec/pass ${STAGEDIR}${PREFIX}/bin/pass
-.if ${PORT_OPTIONS:MCONTRIB}
+do-install-CONTRIB-on:
@${MKDIR} ${STAGEDIR}${DATADIR}
@(cd ${WRKSRC}/contrib && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
@(cd ${WRKSRC}/src/completion && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
-.endif
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_MAN} ${WRKSRC}/man/example-filter.sh ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_MAN} ${WRKSRC}/man/pass.1 ${STAGEDIR}${MANPREFIX}/man/man1/pass.1
+ ${INSTALL_SCRIPT} ${WRKSRC}/man/example-filter.sh ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/man/pass.1 ${STAGEDIR}${MANPREFIX}/man/man1/pass.1
.include <bsd.port.mk>