aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-30 00:48:54 +0800
committerpi <pi@FreeBSD.org>2016-05-30 00:48:54 +0800
commit219dd4360aed1e982e21aad43ac478050a822b56 (patch)
tree01916c3d63e30b682299bac53fed4903ce37c474 /sysutils
parentb08d6914a1def69a9e99dc9aee6a420d4876a82b (diff)
downloadfreebsd-ports-gnome-219dd4360aed1e982e21aad43ac478050a822b56.tar.gz
freebsd-ports-gnome-219dd4360aed1e982e21aad43ac478050a822b56.tar.zst
freebsd-ports-gnome-219dd4360aed1e982e21aad43ac478050a822b56.zip
sysutils/qtpass: improve port
- install the icon for qtpass - install qtpass-desktop file - drop buildtools and linguisttools from the runtime dependencies - instead of defining a do-install target, fix qtpass.pro to work with the ports system [that change is probably up for debate...]. PR: 204122 Submitted by: Tobias C.Berner <tcberner@gmail.com> (kde)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/qtpass/Makefile28
1 files changed, 22 insertions, 6 deletions
diff --git a/sysutils/qtpass/Makefile b/sysutils/qtpass/Makefile
index bdbffe46b7f2..ca176f7aa8c7 100644
--- a/sysutils/qtpass/Makefile
+++ b/sysutils/qtpass/Makefile
@@ -3,7 +3,8 @@
PORTNAME= qtpass
PORTVERSION= 1.1.1
DISTVERSIONPREFIX=v
-CATEGORIES=sysutils
+PORTREVISION= 1
+CATEGORIES= sysutils
MAINTAINER= brouwer@annejan.com
COMMENT= Qt GUI for pass, the standard unix password manager
@@ -12,14 +13,29 @@ LICENSE= GPLv3
RUN_DEPENDS= pass:sysutils/password-store
-USES= qmake
+USES= qmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= IJhack
-USE_QT5= buildtools core gui linguisttools network widgets
+USE_QT5= buildtools_build core gui linguisttools_build network widgets
USE_GL= gl
-PLIST_FILES= bin/qtpass
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/qtpass ${STAGEDIR}${PREFIX}/bin
+PLIST_FILES= bin/qtpass \
+ share/pixmaps/qtpass.png
+
+# Create a desktop entry for the port.
+DESKTOP_ENTRIES= "QtPass" "" \
+ "${PREFIX}/share/pixmaps/qtpass.png" \
+ "${PREFIX}/bin/qtpass" \
+ "Security;Utility;" true
+
+post-patch:
+# The project file assumes PREFIX is the bin-dir. We pass PREFIX=${LOCALBASE}
+# so we have to append bin to target.path.
+ ${REINPLACE_CMD} -e '/target.path/s,$$,bin,' ${WRKSRC}/qtpass.pro
+
+# Install the icon of the port.
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/artwork/icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/qtpass.png
.include <bsd.port.mk>