aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-26 04:16:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-26 04:16:28 +0800
commit228df6ac3919c4f4d6db3ab57d6a8ba92a92eb4e (patch)
tree888768975667253f2fbcd19b89b8fce4b173bfa2 /sysutils
parentc9d36bb9fd6636ea8572b09d3eadaf31c94f269c (diff)
downloadfreebsd-ports-gnome-228df6ac3919c4f4d6db3ab57d6a8ba92a92eb4e.tar.gz
freebsd-ports-gnome-228df6ac3919c4f4d6db3ab57d6a8ba92a92eb4e.tar.zst
freebsd-ports-gnome-228df6ac3919c4f4d6db3ab57d6a8ba92a92eb4e.zip
- Update to 1.7.3
- While I'm here: - Convert to new options framework - Convert to new options helper - Update USE_PYDISTUTILS - Support STAGEDIR Changes: https://github.com/nicolargo/glances/blob/master/NEWS PR: ports/ Submitted by: Gasol Wu <gasol.wu@gmail.com> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-glances/Makefile39
-rw-r--r--sysutils/py-glances/distinfo4
-rw-r--r--sysutils/py-glances/files/patch-setup.py26
3 files changed, 29 insertions, 40 deletions
diff --git a/sysutils/py-glances/Makefile b/sysutils/py-glances/Makefile
index cb5f05ebb2e3..35c8ce9e811c 100644
--- a/sysutils/py-glances/Makefile
+++ b/sysutils/py-glances/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= glances
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.3
CATEGORIES= sysutils python
MASTER_SITES= https://github.com/nicolargo/glances/archive/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,41 +14,34 @@ COMMENT= CLI curses based monitoring tool for GNU/Linux and BSD OS
LICENSE= LGPL3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.0.0:${PORTSDIR}/devel/py-Jinja2 \
- ${PYTHON_PKGNAMEPREFIX}psutil>=0.4.1:${PORTSDIR}/sysutils/py-psutil
+ ${PYTHON_PKGNAMEPREFIX}psutil>=1.2.1:${PORTSDIR}/sysutils/py-psutil
+
+OPTIONS_DEFINE= MANPAGES NLS
+OPTIONS_SUB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
FETCH_ARGS= -pRr
USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
+USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= Glances
+#NO_STAGE= yes
-OPTIONS_DEFINE= NLS
-
-.if !defined(NO_INSTALL_MANPAGES)
-MAN1= glances.1
-.endif
+MANPAGES_MAN1= glances.1
+NLS_TRANSLATIONS= es fr it pt_BR zh_CN
+NLS_USES= gettext
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-TRANSLATIONS= es fr it pt_BR zh_CN
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
-
post-install:
- @${MKDIR} ${PREFIX}/etc/glances
- ${INSTALL_DATA} ${WRKSRC}/glances/conf/glances.conf ${PREFIX}/etc/glances/glances.conf.sample
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/docs/man/glances.1 ${MANPREFIX}/man/man1/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/glances
+ ${INSTALL_DATA} ${WRKSRC}/conf/glances.conf ${STAGEDIR}${PREFIX}/etc/glances/glances.conf.sample
+.if ${PORT_OPTIONS:MMANPAGES}
+ ${INSTALL_MAN} ${WRKSRC}/man/glances.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.endif
.if ${PORT_OPTIONS:MNLS}
-.for lang in ${TRANSLATIONS}
+.for lang in ${NLS_TRANSLATIONS}
${INSTALL_DATA} ${WRKSRC}/i18n/${lang}/LC_MESSAGES/glances.mo \
- ${PREFIX}/share/locale/${lang}/LC_MESSAGES/
+ ${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES/
.endfor
.endif
diff --git a/sysutils/py-glances/distinfo b/sysutils/py-glances/distinfo
index 3c49730aa056..ab0c73fdad7e 100644
--- a/sysutils/py-glances/distinfo
+++ b/sysutils/py-glances/distinfo
@@ -1,2 +1,2 @@
-SHA256 (v1.7.2.tar.gz) = 9bf0b615d546b7ad11d0588cf3e675472612d448fa3acd3ad28f6e1cae20bdf0
-SIZE (v1.7.2.tar.gz) = 1431489
+SHA256 (v1.7.3.tar.gz) = 03a5c8193fd3c91b8249c2501bc612008fa81861c14f82464a10b45d08c4ca4f
+SIZE (v1.7.3.tar.gz) = 1431225
diff --git a/sysutils/py-glances/files/patch-setup.py b/sysutils/py-glances/files/patch-setup.py
index 0d6b9210364b..48087c42028c 100644
--- a/sysutils/py-glances/files/patch-setup.py
+++ b/sysutils/py-glances/files/patch-setup.py
@@ -1,24 +1,20 @@
---- ./setup.py.orig 2013-11-01 17:12:25.000000000 +0800
-+++ ./setup.py 2013-11-08 14:42:57.000000000 +0800
-@@ -11,10 +11,9 @@
- 'docs/glances-doc.html',
- 'glances/conf/glances.conf']),
- ('share/doc/glances/images', glob.glob('docs/images/*.png')),
-- ('share/glances/css', glob.glob('glances/data/css/*.css')),
-- ('share/glances/html', glob.glob('glances/data/html/*.html')),
-- ('share/glances/img', glob.glob('glances/data/img/*.png')),
-- ('share/man/man1', ['docs/man/glances.1'])
-+ ('glances/data/css', glob.glob('glances/data/css/*.css')),
-+ ('glances/data/html', glob.glob('glances/data/html/*.html')),
-+ ('glances/data/img', glob.glob('glances/data/img/*.png')),
+--- ./setup.py.orig 2013-12-15 17:23:06.000000000 +0800
++++ ./setup.py 2013-12-16 21:45:25.000000000 +0800
+@@ -9,8 +9,7 @@
+ data_files = [
+ ('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
+ 'conf/glances.conf', 'docs/glances-doc.html']),
+- ('share/doc/glances/images', glob.glob('docs/images/*.png')),
+- ('share/man/man1', ['man/glances.1'])
++ ('share/doc/glances/images', glob.glob('docs/images/*.png'))
]
if hasattr(sys, 'real_prefix') or 'bsd' in sys.platform:
-@@ -25,10 +24,6 @@
+@@ -21,10 +20,6 @@
conf_path = os.path.join('/usr/local', 'etc', 'glances')
elif 'win32' in sys.platform:
conf_path = os.path.join(os.environ.get('APPDATA'), 'glances')
--data_files.append((conf_path, ['glances/conf/glances.conf']))
+-data_files.append((conf_path, ['conf/glances.conf']))
-
-for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
- data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))