aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-14 22:36:57 +0800
committergarga <garga@FreeBSD.org>2005-10-14 22:36:57 +0800
commit29a5a742ff3af23ef43ec7e7d7c382e5645f314e (patch)
tree3f9babc1409bd76ba14b2f6f48af312a36bd15cf /sysutils
parent11e062d97228beb891bbeef5ba8d48ff8430289a (diff)
downloadfreebsd-ports-gnome-29a5a742ff3af23ef43ec7e7d7c382e5645f314e.tar.gz
freebsd-ports-gnome-29a5a742ff3af23ef43ec7e7d7c382e5645f314e.tar.zst
freebsd-ports-gnome-29a5a742ff3af23ef43ec7e7d7c382e5645f314e.zip
GdMap is a tool which allows to visualize disk space.
Ever wondered why your hard disk is full or what directory and files take up most of the space? With GdMap these questions can be answered quickly. To display directory structures cushion treemaps are used which visualize a complete folder or even the whole hard drive with one picture. Cushion treemaps display directories and files in rectangular areas. The larger a file is the larger is the rectangle which represents it. All files in one directory are painted within the rectangle of that directory. WWW: http://gdmap.sourceforge.net/ PR: ports/87399 Submitted by: Rodrigo Graeff <delphus@gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/gdmap/Makefile37
-rw-r--r--sysutils/gdmap/distinfo2
-rw-r--r--sysutils/gdmap/pkg-descr12
-rw-r--r--sysutils/gdmap/pkg-plist6
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5b79c1c84bf8..8fc7f4851314 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -176,6 +176,7 @@
SUBDIR += gcombust
SUBDIR += gconf-editor
SUBDIR += gdesklets-multitail
+ SUBDIR += gdmap
SUBDIR += gfslicer
SUBDIR += gkfreq
SUBDIR += gkleds2
diff --git a/sysutils/gdmap/Makefile b/sysutils/gdmap/Makefile
new file mode 100644
index 000000000000..7b938c507b96
--- /dev/null
+++ b/sysutils/gdmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gdmap
+# Date created: 13 Oct 2005
+# Whom: Rodrigo Graeff <delphus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdmap
+PORTVERSION= 0.5.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gdmap
+
+MAINTAINER= delphus@gmail.com
+COMMENT= Graphical disk map Utility
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gtk20
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= gdmap.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Doesn't build on FreeBSD < 5.x"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,<sys/vfs.h>,<sys/statvfs.h>,'
+ ${WRKSRC}/src/gui_main.c
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/gdmap/distinfo b/sysutils/gdmap/distinfo
new file mode 100644
index 000000000000..bbde12b4c393
--- /dev/null
+++ b/sysutils/gdmap/distinfo
@@ -0,0 +1,2 @@
+MD5 (gdmap-0.5.0.tar.gz) = 3630f8de748c5f3b2f0a957eddfb76a6
+SIZE (gdmap-0.5.0.tar.gz) = 155508
diff --git a/sysutils/gdmap/pkg-descr b/sysutils/gdmap/pkg-descr
new file mode 100644
index 000000000000..89d8fe997cbe
--- /dev/null
+++ b/sysutils/gdmap/pkg-descr
@@ -0,0 +1,12 @@
+GdMap is a tool which allows to visualize disk space.
+Ever wondered why your hard disk is full or what directory and
+files take up most of the space? With GdMap these questions can
+be answered quickly. To display directory structures cushion
+treemaps are used which visualize a complete folder or even the
+whole hard drive with one picture.
+
+Cushion treemaps display directories and files in rectangular areas.
+The larger a file is the larger is the rectangle which represents it.
+All files in one directory are painted within the rectangle of that directory.
+
+WWW: http://gdmap.sourceforge.net/
diff --git a/sysutils/gdmap/pkg-plist b/sysutils/gdmap/pkg-plist
new file mode 100644
index 000000000000..d3ccb3fd8cef
--- /dev/null
+++ b/sysutils/gdmap/pkg-plist
@@ -0,0 +1,6 @@
+bin/gdmap
+share/gnome/applications/gdmap.desktop
+share/gnome/pixmaps/gdmap_icon.png
+share/gnome/gdmap/pixmaps/gdmap_icon.png
+@dirrm share/gnome/gdmap/pixmaps
+@dirrm share/gnome/gdmap