aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2013-11-18 22:08:08 +0800
committerjadawin <jadawin@FreeBSD.org>2013-11-18 22:08:08 +0800
commit32987d2445790fbae05cdd7aa14eddc4b9715015 (patch)
treee1c0e9051aac1584c86d952ff0e956af357d8709 /sysutils
parentc225a7f40f72f7af7bc30432772720ccfe214443 (diff)
downloadfreebsd-ports-gnome-32987d2445790fbae05cdd7aa14eddc4b9715015.tar.gz
freebsd-ports-gnome-32987d2445790fbae05cdd7aa14eddc4b9715015.tar.zst
freebsd-ports-gnome-32987d2445790fbae05cdd7aa14eddc4b9715015.zip
BackupPC::XS implements various BackupPC functions in a perl-callable module.
This module is required for BackupPC V4+. WWW: http://backuppc.sourceforge.net PR: ports/182403 Submitted by: Alexander Moisseev <moiseev@mezonplus.ru>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-BackupPC-XS/Makefile21
-rw-r--r--sysutils/p5-BackupPC-XS/distinfo2
-rw-r--r--sysutils/p5-BackupPC-XS/files/patch-Makefile.PL31
-rw-r--r--sysutils/p5-BackupPC-XS/pkg-descr4
-rw-r--r--sysutils/p5-BackupPC-XS/pkg-plist8
6 files changed, 67 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0efe11b66a0d..bc435f7b54d2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -576,6 +576,7 @@
SUBDIR += p5-BSD-Jail-Object
SUBDIR += p5-BSD-Process
SUBDIR += p5-BSD-Sysctl
+ SUBDIR += p5-BackupPC-XS
SUBDIR += p5-Brackup
SUBDIR += p5-Dir-Purge
SUBDIR += p5-File-DirCompare
diff --git a/sysutils/p5-BackupPC-XS/Makefile b/sysutils/p5-BackupPC-XS/Makefile
new file mode 100644
index 000000000000..94291089e027
--- /dev/null
+++ b/sysutils/p5-BackupPC-XS/Makefile
@@ -0,0 +1,21 @@
+# Created by: Alexander Moisseev <moiseev@mezonplus.ru>
+# $FreeBSD$
+
+PORTNAME= BackupPC-XS
+PORTVERSION= 0.20
+CATEGORIES= sysutils perl5
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= backuppc/backuppc-beta/4.0.0alpha2
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= moiseev@mezonplus.ru
+COMMENT= Perl extension for BackupPC libraries
+
+LICENSE= GPLv3
+
+USES= perl5
+USE_PERL5= configure
+
+MAKE_JOBS_UNSAFE=yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-BackupPC-XS/distinfo b/sysutils/p5-BackupPC-XS/distinfo
new file mode 100644
index 000000000000..ce9e615f4800
--- /dev/null
+++ b/sysutils/p5-BackupPC-XS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (BackupPC-XS-0.20.tar.gz) = b80745bac2a0d8c3d8e4c0be72d68e2d4450926f065d8b9af62cbee555d83f87
+SIZE (BackupPC-XS-0.20.tar.gz) = 281081
diff --git a/sysutils/p5-BackupPC-XS/files/patch-Makefile.PL b/sysutils/p5-BackupPC-XS/files/patch-Makefile.PL
new file mode 100644
index 000000000000..670c22c851b9
--- /dev/null
+++ b/sysutils/p5-BackupPC-XS/files/patch-Makefile.PL
@@ -0,0 +1,31 @@
+--- Makefile.PL.orig 2013-05-26 11:32:01.000000000 +0400
++++ Makefile.PL 2013-09-26 09:38:14.000000000 +0400
+@@ -14,10 +14,6 @@
+ bpc_refCount$(OBJ_EXT)
+ ];
+ $object =~ s/[\n\r\s]+/ /g;
+-my $ldfrom = $object;
+-$ldfrom =~ s{(\w+)/}{}g;
+-$ldfrom .= ' zlib/libzlib$(LIB_EXT)';
+-$ldfrom .= ' md5/libmd5$(LIB_EXT)';
+
+ WriteMakefile(
+ NAME => 'BackupPC::XS',
+@@ -28,7 +24,7 @@
+ DEFINE => '', # e.g., '-DHAVE_SOMETHING'
+ INC => '-I.', # e.g., '-I. -I/usr/include/other'
+ OBJECT => $object,
+- LDFROM => $ldfrom,
++ MYEXTLIB => 'zlib/libzlib$(LIB_EXT) md5/libmd5$(LIB_EXT)',
+ DIR => ['md5', 'zlib'],
+ depend => { 'BackupPC_XS.o' => 'config.h' },
+ clean => { FILES => "config.log config.status config.h" },
+@@ -38,7 +34,7 @@
+ return <<'EOF';
+
+ zlib/libzlib$(LIB_EXT): zlib/Makefile config.h
+- cd md5 && $(MAKE) $(PASSTHRU)
++ cd zlib && $(MAKE) $(PASSTHRU)
+
+ md5/libmd5$(LIB_EXT): md5/Makefile config.h
+ cd md5 && $(MAKE) $(PASSTHRU)
diff --git a/sysutils/p5-BackupPC-XS/pkg-descr b/sysutils/p5-BackupPC-XS/pkg-descr
new file mode 100644
index 000000000000..fbdf45bfcffd
--- /dev/null
+++ b/sysutils/p5-BackupPC-XS/pkg-descr
@@ -0,0 +1,4 @@
+BackupPC::XS implements various BackupPC functions in a perl-callable module.
+This module is required for BackupPC V4+.
+
+WWW: http://backuppc.sourceforge.net
diff --git a/sysutils/p5-BackupPC-XS/pkg-plist b/sysutils/p5-BackupPC-XS/pkg-plist
new file mode 100644
index 000000000000..2ee6e9a4ddd2
--- /dev/null
+++ b/sysutils/p5-BackupPC-XS/pkg-plist
@@ -0,0 +1,8 @@
+%%PERL5_MAN3%%/BackupPC::XS.3.gz
+%%SITE_PERL%%/mach/BackupPC/XS.pm
+%%SITE_PERL%%/mach/auto/BackupPC/XS/.packlist
+%%SITE_PERL%%/mach/auto/BackupPC/XS/XS.bs
+%%SITE_PERL%%/mach/auto/BackupPC/XS/XS.so
+@dirrm %%SITE_PERL%%/mach/auto/BackupPC/XS
+@dirrm %%SITE_PERL%%/mach/auto/BackupPC
+@dirrmtry %%SITE_PERL%%/mach/BackupPC