aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2012-02-13 21:24:13 +0800
committerolgeni <olgeni@FreeBSD.org>2012-02-13 21:24:13 +0800
commit3fcecd055d59c1caed43d8631e35833f3138ce3c (patch)
tree3f86e04748ef46c4d9d687136760c9d0eee451ea /sysutils
parent4013e52354c4943b8270c9a791224410df63086a (diff)
downloadfreebsd-ports-gnome-3fcecd055d59c1caed43d8631e35833f3138ce3c.tar.gz
freebsd-ports-gnome-3fcecd055d59c1caed43d8631e35833f3138ce3c.tar.zst
freebsd-ports-gnome-3fcecd055d59c1caed43d8631e35833f3138ce3c.zip
Upgrade to version 1.580.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile11
-rw-r--r--sysutils/webmin/distinfo4
-rw-r--r--sysutils/webmin/files/patch-aa11
-rw-r--r--sysutils/webmin/files/patch-ajaxterm_ajaxterm_ajaxterm.py14
4 files changed, 32 insertions, 8 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 06f855cc236e..bc2d1e11da88 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webmin
-PORTVERSION= 1.570
+PORTVERSION= 1.580
CATEGORIES= sysutils
MASTER_SITES= http://download.webmin.com/updates/:up \
SF/webadmin/${PORTNAME}/${PORTVERSION}:sf \
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net
${SITE_PERL}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-Authen-PAM
USE_PERL5= yes
+USE_PYTHON= yes
USE_RC_SUBR= webmin.sh
SUB_LIST= PERL5=${PERL}
SUB_FILES= pkg-message
@@ -55,6 +56,7 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
@${FIND} ${WRKSRC} -name "*.bak" -delete
+ @${FIND} ${WRKSRC} -name "*.pyc" -delete
do-build:
@${CC} ${CFLAGS} -o ${WRKSRC}/mount/freebsd-mounts-7 ${WRKSRC}/mount/freebsd-mounts-7.c
@@ -64,8 +66,15 @@ do-install:
@${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin
post-install:
+ @${PYTHON_CMD} -O -mcompileall ${PREFIX}/lib/webmin/ajaxterm/ajaxterm/
+ @${PYTHON_CMD} -mcompileall ${PREFIX}/lib/webmin/ajaxterm/ajaxterm/
+
@cd ${WRKSRC} ; ${FIND} * -type f -o -type l | ${SORT} | ${AWK} \
'{ print "lib/webmin/" $$1 }' > ${WRKDIR}/PLIST.lib-webmin
+ @cd ${WRKSRC} ; ${FIND} * -type f -name "*.py" | ${SED} -e "s/\\.py/.pyc/" | ${SORT} | ${AWK} \
+ '{ print "lib/webmin/" $$1 }' >> ${WRKDIR}/PLIST.lib-webmin
+ @cd ${WRKSRC} ; ${FIND} * -type f -name "*.py" | ${SED} -e "s/\\.py/.pyo/" | ${SORT} | ${AWK} \
+ '{ print "lib/webmin/" $$1 }' >> ${WRKDIR}/PLIST.lib-webmin
@cd ${WRKSRC} ; ${FIND} * -type d -empty | ${SORT} -r | ${AWK} \
'{ print "lib/webmin/" $$1 }' | ${SED} -e 's#^#@exec mkdir -p %D/#g' \
>> ${WRKDIR}/PLIST.lib-webmin
diff --git a/sysutils/webmin/distinfo b/sysutils/webmin/distinfo
index 828cabffa597..9d477640aa31 100644
--- a/sysutils/webmin/distinfo
+++ b/sysutils/webmin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webmin-1.570.tar.gz) = 3b8ad51dee0e61e330c8137b3d8cff91a00cf31d710b68e272fe02db25baaf54
-SIZE (webmin-1.570.tar.gz) = 15200156
+SHA256 (webmin-1.580.tar.gz) = 4f767c7e66defb4d1f102692a70752c558c8bf289e4e9980d82b1af86bd764e4
+SIZE (webmin-1.580.tar.gz) = 16081299
diff --git a/sysutils/webmin/files/patch-aa b/sysutils/webmin/files/patch-aa
index b719a99c88d5..92d5509242cb 100644
--- a/sysutils/webmin/files/patch-aa
+++ b/sysutils/webmin/files/patch-aa
@@ -69,7 +69,7 @@ $FreeBSD$
perldef=/usr/bin/perl
elif [ -x /usr/local/bin/perl ]; then
perldef=/usr/local/bin/perl
-@@ -439,21 +421,6 @@
+@@ -439,22 +421,6 @@
fi
fi
@@ -82,6 +82,7 @@ $FreeBSD$
- read atbootyn
- if [ "$atbootyn" = "y" -o "$atbootyn" = "Y" ]; then
- atboot=1
+- makeboot=1
- fi
- else
- echo "Webmin does not support being started at boot time on your system."
@@ -91,7 +92,7 @@ $FreeBSD$
# Copy files to target directory
echo "***********************************************************************"
if [ "$wadir" != "$srcdir" ]; then
-@@ -575,6 +542,7 @@
+@@ -576,6 +542,7 @@
fi
fi
@@ -99,7 +100,7 @@ $FreeBSD$
if [ "$noperlpath" = "" ]; then
echo "Inserting path to perl into scripts.."
(find "$wadir" -name '*.cgi' -print ; find "$wadir" -name '*.pl' -print) | $perl "$wadir/perlpath.pl" $perl -
-@@ -585,7 +553,6 @@
+@@ -586,7 +553,6 @@
echo "Creating start and stop scripts.."
rm -f $config_dir/stop $config_dir/start $config_dir/restart $config_dir/reload
echo "#!/bin/sh" >>$config_dir/start
@@ -107,7 +108,7 @@ $FreeBSD$
echo "trap '' 1" >>$config_dir/start
echo "LANG=" >>$config_dir/start
echo "export LANG" >>$config_dir/start
-@@ -733,6 +700,7 @@
+@@ -734,6 +700,7 @@
echo passdelay=1 >> $config_dir/miniserv.conf
fi
@@ -115,7 +116,7 @@ $FreeBSD$
if [ "$nouninstall" = "" ]; then
echo "Creating uninstall script $config_dir/uninstall.sh .."
cat >$config_dir/uninstall.sh <<EOF
-@@ -822,6 +790,7 @@
+@@ -823,6 +790,7 @@
. "$srcdir/setup-post.sh"
fi
diff --git a/sysutils/webmin/files/patch-ajaxterm_ajaxterm_ajaxterm.py b/sysutils/webmin/files/patch-ajaxterm_ajaxterm_ajaxterm.py
new file mode 100644
index 000000000000..28b17c91ee07
--- /dev/null
+++ b/sysutils/webmin/files/patch-ajaxterm_ajaxterm_ajaxterm.py
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ajaxterm/ajaxterm/ajaxterm.py.orig
++++ ajaxterm/ajaxterm/ajaxterm.py
+@@ -394,7 +394,7 @@
+ if self.cmd:
+ cmd=['/bin/sh','-c',self.cmd]
+ elif os.getuid()==0:
+- cmd=['/bin/login']
++ cmd=['/usr/bin/login']
+ else:
+ sys.stdout.write("Login: ")
+ login=sys.stdin.readline().strip()