aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-11 04:24:59 +0800
committerbapt <bapt@FreeBSD.org>2015-04-11 04:24:59 +0800
commit48b40be26b4eec701ba8ddbc6cb867203dbda652 (patch)
tree304481668c7d8fa95d11727f559012ba74492d80 /sysutils
parent5bfd013586e68c073e6de5cb610054fd67c8677c (diff)
downloadfreebsd-ports-gnome-48b40be26b4eec701ba8ddbc6cb867203dbda652.tar.gz
freebsd-ports-gnome-48b40be26b4eec701ba8ddbc6cb867203dbda652.tar.zst
freebsd-ports-gnome-48b40be26b4eec701ba8ddbc6cb867203dbda652.zip
Build xen-tools with qemu so that dom0 is usable
Reported by: Michael Dexter Pointyhat to: bapt
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xen-tools/Makefile18
-rw-r--r--sysutils/xen-tools/pkg-plist503
2 files changed, 302 insertions, 219 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index 54ec5d7b640d..4c51cdb7249f 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
PORTVERSION= 4.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils emulators
MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/ \
http://code.coreboot.org/p/seabios/downloads/get/:seabios
@@ -17,27 +17,26 @@ LICENSE_COMB= multi
OPTIONS_DEFINE= DOCS
LIB_DEPENDS= libyajl.so:${PORTSDIR}/devel/yajl \
- liblzo2.so:${PORTSDIR}/archivers/lzo2
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+ liblzo2.so:${PORTSDIR}/archivers/lzo2 \
+ libpixman-1.so:${PORTSDIR}/x11/pixman
+BUILD_DEPENDS= dev86>0:${PORTSDIR}/devel/dev86
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64, i386"
-CONFIGURE_ARGS= --disable-xen
-
SEABIOSVERSION= 1.8.1
DISTFILES+= ${PORTNAME}-${PORTVERSION}.tar.gz \
seabios-${SEABIOSVERSION}.tar.gz:seabios
WRKSRC= ${WRKDIR}/xen-${PORTVERSION}
-USES= gmake perl5 python shebangfix
+USES= gmake perl5 python shebangfix libtool pkgconfig
+USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ENV= HOSTCC="${CC}" CC="${CC}" \
ac_cv_path_BASH=${TRUE} \
- ac_cv_path_XGETTEXT=${TRUE} \
- glib_CFLAGS=" " glib_LIBS=" "
-MAKE_ARGS= HOSTCC="${CC}" CC="${CC}"
+ ac_cv_path_XGETTEXT=${TRUE}
+MAKE_ARGS= HOSTCC="${CC}" CC="${CC}" GCC="${GCC}" cc="${GCC}"
SHEBANG_FILES= tools/misc/xencov_split \
tools/misc/xen-ringwatch
USE_GCC= yes
@@ -54,6 +53,7 @@ post-extract:
${MV} ${WRKDIR}/seabios-${SEABIOSVERSION} ${WRKSRC}/tools/firmware/seabios-dir
post-patch:
+ @${REINPLACE_CMD} "s,x86_64,amd64,g" ${WRKSRC}/tools/configure
@${REINPLACE_CMD} -e "s,/var/lib,/var/db,g" \
${WRKSRC}/tools/Makefile \
${WRKSRC}/tools/libxc/include/xenguest.h \
diff --git a/sysutils/xen-tools/pkg-plist b/sysutils/xen-tools/pkg-plist
index 2d8766e3ded0..2dc7adce4da8 100644
--- a/sysutils/xen-tools/pkg-plist
+++ b/sysutils/xen-tools/pkg-plist
@@ -1,213 +1,3 @@
-bin/pygrub
-bin/xen-detect
-bin/xencons
-bin/xencov_split
-bin/xenstore
-bin/xenstore-chmod
-bin/xenstore-control
-bin/xenstore-exists
-bin/xenstore-list
-bin/xenstore-ls
-bin/xenstore-read
-bin/xenstore-rm
-bin/xenstore-watch
-bin/xenstore-write
-bin/xentrace
-bin/xentrace_format
-bin/xentrace_setsize
-etc/bash_completion.d/xl.sh
-etc/rc.d/xencommons
-etc/xen/README
-etc/xen/README.incompatibilities
-etc/xen/cpupool
-etc/xen/scripts/hotplugpath.sh
-etc/xen/scripts/vif-bridge
-etc/xen/xl.conf
-etc/xen/xlexample.hvm
-etc/xen/xlexample.pvlinux
-include/_libxl_list.h
-include/_libxl_types.h
-include/_libxl_types_json.h
-include/fsimage.h
-include/fsimage_grub.h
-include/fsimage_plugin.h
-include/libxl.h
-include/libxl_event.h
-include/libxl_json.h
-include/libxl_utils.h
-include/libxl_uuid.h
-include/xen/COPYING
-include/xen/arch-arm.h
-include/xen/arch-arm/hvm/save.h
-include/xen/arch-x86/cpuid.h
-include/xen/arch-x86/hvm/save.h
-include/xen/arch-x86/xen-mca.h
-include/xen/arch-x86/xen-x86_32.h
-include/xen/arch-x86/xen-x86_64.h
-include/xen/arch-x86/xen.h
-include/xen/arch-x86_32.h
-include/xen/arch-x86_64.h
-include/xen/callback.h
-include/xen/dom0_ops.h
-include/xen/domctl.h
-include/xen/elfnote.h
-include/xen/event_channel.h
-include/xen/features.h
-include/xen/foreign/arm32.h
-include/xen/foreign/arm64.h
-include/xen/foreign/x86_32.h
-include/xen/foreign/x86_64.h
-include/xen/gcov.h
-include/xen/grant_table.h
-include/xen/hvm/e820.h
-include/xen/hvm/hvm_info_table.h
-include/xen/hvm/hvm_op.h
-include/xen/hvm/hvm_xs_strings.h
-include/xen/hvm/ioreq.h
-include/xen/hvm/params.h
-include/xen/hvm/pvdrivers.h
-include/xen/hvm/save.h
-include/xen/io/blkif.h
-include/xen/io/console.h
-include/xen/io/fbif.h
-include/xen/io/fsif.h
-include/xen/io/kbdif.h
-include/xen/io/libxenvchan.h
-include/xen/io/netif.h
-include/xen/io/pciif.h
-include/xen/io/protocols.h
-include/xen/io/ring.h
-include/xen/io/tpmif.h
-include/xen/io/usbif.h
-include/xen/io/vscsiif.h
-include/xen/io/xenbus.h
-include/xen/io/xs_wire.h
-include/xen/kexec.h
-include/xen/mem_event.h
-include/xen/memory.h
-include/xen/nmi.h
-include/xen/physdev.h
-include/xen/platform.h
-include/xen/sched.h
-include/xen/sys/evtchn.h
-include/xen/sys/privcmd.h
-include/xen/sysctl.h
-include/xen/tmem.h
-include/xen/trace.h
-include/xen/vcpu.h
-include/xen/version.h
-include/xen/xen-compat.h
-include/xen/xen.h
-include/xen/xencomm.h
-include/xen/xenoprof.h
-include/xen/xsm/flask_op.h
-include/xenctrl.h
-include/xenctrlosdep.h
-include/xenguest.h
-include/xenstat.h
-include/xenstore-compat/xs.h
-include/xenstore-compat/xs_lib.h
-include/xenstore.h
-include/xenstore_lib.h
-include/xentoollog.h
-include/xs.h
-include/xs_lib.h
-lib/fs/ext2fs/fsimage.so
-lib/fs/fat/fsimage.so
-lib/fs/iso9660/fsimage.so
-lib/fs/reiserfs/fsimage.so
-lib/fs/ufs/fsimage.so
-lib/fs/xfs/fsimage.so
-lib/fs/zfs/fsimage.so
-lib/libfsimage.so
-lib/libfsimage.so.1.0
-lib/libfsimage.so.1.0.0
-lib/libxenctrl.a
-lib/libxenctrl.so
-lib/libxenctrl.so.4.5
-lib/libxenctrl.so.4.5.0
-lib/libxenguest.a
-lib/libxenguest.so
-lib/libxenguest.so.4.5
-lib/libxenguest.so.4.5.0
-lib/libxenlight.a
-lib/libxenlight.so
-lib/libxenlight.so.4.5
-lib/libxenlight.so.4.5.0
-lib/libxenstat.a
-lib/libxenstat.so
-lib/libxenstat.so.0
-lib/libxenstat.so.0.0
-lib/libxenstore.a
-lib/libxenstore.so
-lib/libxenstore.so.3.0
-lib/libxenstore.so.3.0.3
-lib/libxlutil.a
-lib/libxlutil.so
-lib/libxlutil.so.4.3
-lib/libxlutil.so.4.3.0
-%%PYTHON_SITELIBDIR%%/fsimage.so
-%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
-%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
-%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
-%%PYTHON_SITELIBDIR%%/grub/GrubConf.pyc
-%%PYTHON_SITELIBDIR%%/grub/LiloConf.py
-%%PYTHON_SITELIBDIR%%/grub/LiloConf.pyc
-%%PYTHON_SITELIBDIR%%/grub/__init__.py
-%%PYTHON_SITELIBDIR%%/grub/__init__.pyc
-%%PYTHON_SITELIBDIR%%/pygrub-0.3-py%%PYTHON_VER%%.egg-info
-%%PYTHON_SITELIBDIR%%/xen-3.0-py%%PYTHON_VER%%.egg-info
-%%PYTHON_SITELIBDIR%%/xen/__init__.py
-%%PYTHON_SITELIBDIR%%/xen/__init__.pyc
-%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.py
-%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.pyc
-%%PYTHON_SITELIBDIR%%/xen/lowlevel/xc.so
-%%PYTHON_SITELIBDIR%%/xen/lowlevel/xs.so
-lib/xen/bin/libxl-save-helper
-lib/xen/bin/lsevtchn
-lib/xen/bin/pygrub
-lib/xen/bin/readnotes
-lib/xen/bin/xen-init-dom0
-lib/xen/bin/xenconsole
-lib/xen/bin/xenctx
-lib/xen/bin/xenpaging
-lib/xen/bin/xenpvnetboot
-lib/xen/boot/hvmloader
-man/man1/xenstore-chmod.1.gz
-man/man1/xenstore-ls.1.gz
-man/man1/xenstore.1.gz
-man/man1/xentop.1.gz
-man/man1/xentrace_format.1.gz
-man/man1/xl.1.gz
-man/man5/xl.cfg.5.gz
-man/man5/xl.conf.5.gz
-man/man5/xlcpupool.cfg.5.gz
-man/man8/xentrace.8.gz
-sbin/gdbsx
-sbin/gtracestat
-sbin/gtraceview
-sbin/kdd
-sbin/xen-bugtool
-sbin/xen-hptool
-sbin/xen-hvmcrash
-sbin/xen-hvmctx
-sbin/xen-lowmemd
-sbin/xen-mfndump
-sbin/xen-ringwatch
-sbin/xen-tmem-list-parse
-sbin/xenbaked
-sbin/xenconsoled
-sbin/xencov
-sbin/xenlockprof
-sbin/xenmon.py
-sbin/xenperf
-sbin/xenpm
-sbin/xenpmd
-sbin/xenstored
-sbin/xentop
-sbin/xentrace_setmask
-sbin/xenwatchdogd
-sbin/xl
%%PORTDOCS%%share/doc/xen/README.xenmon
%%PORTDOCS%%share/doc/xen/html/hypercall/arm/.deps
%%PORTDOCS%%share/doc/xen/html/hypercall/arm/include,public,arch-arm,hvm,save.h.html
@@ -412,6 +202,299 @@ sbin/xl
%%PORTDOCS%%share/doc/xen/html/misc/xenstore.txt
%%PORTDOCS%%share/doc/xen/html/misc/xl-disk-configuration.txt
%%PORTDOCS%%share/doc/xen/html/misc/xsm-flask.txt
+%%PYTHON_SITELIBDIR%%/fsimage.so
+%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
+%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
+%%PYTHON_SITELIBDIR%%/grub/GrubConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/LiloConf.py
+%%PYTHON_SITELIBDIR%%/grub/LiloConf.pyc
+%%PYTHON_SITELIBDIR%%/grub/__init__.py
+%%PYTHON_SITELIBDIR%%/grub/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pygrub-0.3-py%%PYTHON_VER%%.egg-info
+%%PYTHON_SITELIBDIR%%/xen-3.0-py%%PYTHON_VER%%.egg-info
+%%PYTHON_SITELIBDIR%%/xen/__init__.py
+%%PYTHON_SITELIBDIR%%/xen/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.py
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/xc.so
+%%PYTHON_SITELIBDIR%%/xen/lowlevel/xs.so
+bin/pygrub
+bin/xen-detect
+bin/xencons
+bin/xencov_split
+bin/xenstore
+bin/xenstore-chmod
+bin/xenstore-control
+bin/xenstore-exists
+bin/xenstore-list
+bin/xenstore-ls
+bin/xenstore-read
+bin/xenstore-rm
+bin/xenstore-watch
+bin/xenstore-write
+bin/xentrace
+bin/xentrace_format
+bin/xentrace_setsize
+etc/bash_completion.d/xl.sh
+etc/rc.d/xencommons
+etc/xen/README
+etc/xen/README.incompatibilities
+etc/xen/cpupool
+etc/xen/scripts/hotplugpath.sh
+etc/xen/scripts/vif-bridge
+etc/xen/xl.conf
+etc/xen/xlexample.hvm
+etc/xen/xlexample.pvlinux
+include/_libxl_list.h
+include/_libxl_types.h
+include/_libxl_types_json.h
+include/fsimage.h
+include/fsimage_grub.h
+include/fsimage_plugin.h
+include/libxl.h
+include/libxl_event.h
+include/libxl_json.h
+include/libxl_utils.h
+include/libxl_uuid.h
+include/xen/COPYING
+include/xen/arch-arm.h
+include/xen/arch-arm/hvm/save.h
+include/xen/arch-x86/cpuid.h
+include/xen/arch-x86/hvm/save.h
+include/xen/arch-x86/xen-mca.h
+include/xen/arch-x86/xen-x86_32.h
+include/xen/arch-x86/xen-x86_64.h
+include/xen/arch-x86/xen.h
+include/xen/arch-x86_32.h
+include/xen/arch-x86_64.h
+include/xen/callback.h
+include/xen/dom0_ops.h
+include/xen/domctl.h
+include/xen/elfnote.h
+include/xen/event_channel.h
+include/xen/features.h
+include/xen/foreign/arm32.h
+include/xen/foreign/arm64.h
+include/xen/foreign/x86_32.h
+include/xen/foreign/x86_64.h
+include/xen/gcov.h
+include/xen/grant_table.h
+include/xen/hvm/e820.h
+include/xen/hvm/hvm_info_table.h
+include/xen/hvm/hvm_op.h
+include/xen/hvm/hvm_xs_strings.h
+include/xen/hvm/ioreq.h
+include/xen/hvm/params.h
+include/xen/hvm/pvdrivers.h
+include/xen/hvm/save.h
+include/xen/io/blkif.h
+include/xen/io/console.h
+include/xen/io/fbif.h
+include/xen/io/fsif.h
+include/xen/io/kbdif.h
+include/xen/io/libxenvchan.h
+include/xen/io/netif.h
+include/xen/io/pciif.h
+include/xen/io/protocols.h
+include/xen/io/ring.h
+include/xen/io/tpmif.h
+include/xen/io/usbif.h
+include/xen/io/vscsiif.h
+include/xen/io/xenbus.h
+include/xen/io/xs_wire.h
+include/xen/kexec.h
+include/xen/mem_event.h
+include/xen/memory.h
+include/xen/nmi.h
+include/xen/physdev.h
+include/xen/platform.h
+include/xen/sched.h
+include/xen/sys/evtchn.h
+include/xen/sys/privcmd.h
+include/xen/sysctl.h
+include/xen/tmem.h
+include/xen/trace.h
+include/xen/vcpu.h
+include/xen/version.h
+include/xen/xen-compat.h
+include/xen/xen.h
+include/xen/xencomm.h
+include/xen/xenoprof.h
+include/xen/xsm/flask_op.h
+include/xenctrl.h
+include/xenctrlosdep.h
+include/xenguest.h
+include/xenstat.h
+include/xenstore-compat/xs.h
+include/xenstore-compat/xs_lib.h
+include/xenstore.h
+include/xenstore_lib.h
+include/xentoollog.h
+include/xs.h
+include/xs_lib.h
+lib/fs/ext2fs/fsimage.so
+lib/fs/fat/fsimage.so
+lib/fs/iso9660/fsimage.so
+lib/fs/reiserfs/fsimage.so
+lib/fs/ufs/fsimage.so
+lib/fs/xfs/fsimage.so
+lib/fs/zfs/fsimage.so
+lib/libfsimage.so
+lib/libfsimage.so.1.0
+lib/libfsimage.so.1.0.0
+lib/libxenctrl.a
+lib/libxenctrl.so
+lib/libxenctrl.so.4.5
+lib/libxenctrl.so.4.5.0
+lib/libxenguest.a
+lib/libxenguest.so
+lib/libxenguest.so.4.5
+lib/libxenguest.so.4.5.0
+lib/libxenlight.a
+lib/libxenlight.so
+lib/libxenlight.so.4.5
+lib/libxenlight.so.4.5.0
+lib/libxenstat.a
+lib/libxenstat.so
+lib/libxenstat.so.0
+lib/libxenstat.so.0.0
+lib/libxenstore.a
+lib/libxenstore.so
+lib/libxenstore.so.3.0
+lib/libxenstore.so.3.0.3
+lib/libxlutil.a
+lib/libxlutil.so
+lib/libxlutil.so.4.3
+lib/libxlutil.so.4.3.0
+lib/xen/bin/libxl-save-helper
+lib/xen/bin/lsevtchn
+lib/xen/bin/pygrub
+lib/xen/bin/qemu-img
+lib/xen/bin/qemu-io
+lib/xen/bin/qemu-nbd
+lib/xen/bin/qemu-system-i386
+lib/xen/bin/readnotes
+lib/xen/bin/xen-init-dom0
+lib/xen/bin/xenconsole
+lib/xen/bin/xenctx
+lib/xen/bin/xenpaging
+lib/xen/bin/xenpvnetboot
+lib/xen/boot/hvmloader
+lib/xen/etc/qemu/target-x86_64.conf
+man/man1/xenstore-chmod.1.gz
+man/man1/xenstore-ls.1.gz
+man/man1/xenstore.1.gz
+man/man1/xentop.1.gz
+man/man1/xentrace_format.1.gz
+man/man1/xl.1.gz
+man/man5/xl.cfg.5.gz
+man/man5/xl.conf.5.gz
+man/man5/xlcpupool.cfg.5.gz
+man/man8/xentrace.8.gz
+sbin/gdbsx
+sbin/gtracestat
+sbin/gtraceview
+sbin/kdd
+sbin/xen-bugtool
+sbin/xen-hptool
+sbin/xen-hvmcrash
+sbin/xen-hvmctx
+sbin/xen-lowmemd
+sbin/xen-mfndump
+sbin/xen-ringwatch
+sbin/xen-tmem-list-parse
+sbin/xenbaked
+sbin/xenconsoled
+sbin/xencov
+sbin/xenlockprof
+sbin/xenmon.py
+sbin/xenperf
+sbin/xenpm
+sbin/xenpmd
+sbin/xenstored
+sbin/xentop
+sbin/xentrace_setmask
+sbin/xenwatchdogd
+sbin/xl
+share/qemu-xen/qemu/QEMU,cgthree.bin
+share/qemu-xen/qemu/QEMU,tcx.bin
+share/qemu-xen/qemu/acpi-dsdt.aml
+share/qemu-xen/qemu/bamboo.dtb
+share/qemu-xen/qemu/bios-256k.bin
+share/qemu-xen/qemu/bios.bin
+share/qemu-xen/qemu/efi-e1000.rom
+share/qemu-xen/qemu/efi-eepro100.rom
+share/qemu-xen/qemu/efi-ne2k_pci.rom
+share/qemu-xen/qemu/efi-pcnet.rom
+share/qemu-xen/qemu/efi-rtl8139.rom
+share/qemu-xen/qemu/efi-virtio.rom
+share/qemu-xen/qemu/keymaps/ar
+share/qemu-xen/qemu/keymaps/bepo
+share/qemu-xen/qemu/keymaps/common
+share/qemu-xen/qemu/keymaps/cz
+share/qemu-xen/qemu/keymaps/da
+share/qemu-xen/qemu/keymaps/de
+share/qemu-xen/qemu/keymaps/de-ch
+share/qemu-xen/qemu/keymaps/en-gb
+share/qemu-xen/qemu/keymaps/en-us
+share/qemu-xen/qemu/keymaps/es
+share/qemu-xen/qemu/keymaps/et
+share/qemu-xen/qemu/keymaps/fi
+share/qemu-xen/qemu/keymaps/fo
+share/qemu-xen/qemu/keymaps/fr
+share/qemu-xen/qemu/keymaps/fr-be
+share/qemu-xen/qemu/keymaps/fr-ca
+share/qemu-xen/qemu/keymaps/fr-ch
+share/qemu-xen/qemu/keymaps/hr
+share/qemu-xen/qemu/keymaps/hu
+share/qemu-xen/qemu/keymaps/is
+share/qemu-xen/qemu/keymaps/it
+share/qemu-xen/qemu/keymaps/ja
+share/qemu-xen/qemu/keymaps/lt
+share/qemu-xen/qemu/keymaps/lv
+share/qemu-xen/qemu/keymaps/mk
+share/qemu-xen/qemu/keymaps/modifiers
+share/qemu-xen/qemu/keymaps/nl
+share/qemu-xen/qemu/keymaps/nl-be
+share/qemu-xen/qemu/keymaps/no
+share/qemu-xen/qemu/keymaps/pl
+share/qemu-xen/qemu/keymaps/pt
+share/qemu-xen/qemu/keymaps/pt-br
+share/qemu-xen/qemu/keymaps/ru
+share/qemu-xen/qemu/keymaps/sl
+share/qemu-xen/qemu/keymaps/sv
+share/qemu-xen/qemu/keymaps/th
+share/qemu-xen/qemu/keymaps/tr
+share/qemu-xen/qemu/kvmvapic.bin
+share/qemu-xen/qemu/linuxboot.bin
+share/qemu-xen/qemu/multiboot.bin
+share/qemu-xen/qemu/openbios-ppc
+share/qemu-xen/qemu/openbios-sparc32
+share/qemu-xen/qemu/openbios-sparc64
+share/qemu-xen/qemu/palcode-clipper
+share/qemu-xen/qemu/petalogix-ml605.dtb
+share/qemu-xen/qemu/petalogix-s3adsp1800.dtb
+share/qemu-xen/qemu/ppc_rom.bin
+share/qemu-xen/qemu/pxe-e1000.rom
+share/qemu-xen/qemu/pxe-eepro100.rom
+share/qemu-xen/qemu/pxe-ne2k_pci.rom
+share/qemu-xen/qemu/pxe-pcnet.rom
+share/qemu-xen/qemu/pxe-rtl8139.rom
+share/qemu-xen/qemu/pxe-virtio.rom
+share/qemu-xen/qemu/q35-acpi-dsdt.aml
+share/qemu-xen/qemu/qemu-icon.bmp
+share/qemu-xen/qemu/qemu_logo_no_text.svg
+share/qemu-xen/qemu/s390-ccw.img
+share/qemu-xen/qemu/s390-zipl.rom
+share/qemu-xen/qemu/sgabios.bin
+share/qemu-xen/qemu/slof.bin
+share/qemu-xen/qemu/spapr-rtas.bin
+share/qemu-xen/qemu/vgabios-cirrus.bin
+share/qemu-xen/qemu/vgabios-qxl.bin
+share/qemu-xen/qemu/vgabios-stdvga.bin
+share/qemu-xen/qemu/vgabios-vmware.bin
+share/qemu-xen/qemu/vgabios.bin
@dir etc/xen/auto
@dir /var/db/xen/xenpaging
@dir /var/db/xen