aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-19 22:36:36 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-19 22:36:36 +0800
commit4d88aba88752d74a42bd06f5d9b6b773977c6a81 (patch)
treefb609e95549a62c7728424ce59928013f0dc3ffe /sysutils
parent687234c91fe7e21ccff1ca1878c71fc30ba76062 (diff)
downloadfreebsd-ports-gnome-4d88aba88752d74a42bd06f5d9b6b773977c6a81.tar.gz
freebsd-ports-gnome-4d88aba88752d74a42bd06f5d9b6b773977c6a81.tar.zst
freebsd-ports-gnome-4d88aba88752d74a42bd06f5d9b6b773977c6a81.zip
- Fix build on amd64 (while not breaking build on i386)
Since time_t size is unspecified, the only way to print it correctly is by using %ld while casting the value to long This is what upstream does for a long time: https://github.com/facebook/watchman/commit/f2ec20fb2d98bfc9f54df43431564317de60429c Approved by: portmgr blanket MFH: 2015Q2
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/watchman/Makefile1
-rw-r--r--sysutils/watchman/files/patch-root.c11
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/watchman/Makefile b/sysutils/watchman/Makefile
index c09c2f86d574..9453d80d83b1 100644
--- a/sysutils/watchman/Makefile
+++ b/sysutils/watchman/Makefile
@@ -32,6 +32,5 @@ PORTDOCS= README.markdown
post-patch:
@${REINPLACE_CMD} -e '/^docdir = /d' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e '/timestamp=/s,%ld,%d,' ${WRKSRC}/root.c
.include <bsd.port.mk>
diff --git a/sysutils/watchman/files/patch-root.c b/sysutils/watchman/files/patch-root.c
new file mode 100644
index 000000000000..472e33a4a22c
--- /dev/null
+++ b/sysutils/watchman/files/patch-root.c
@@ -0,0 +1,11 @@
+--- root.c.orig 2014-11-03 21:24:12 UTC
++++ root.c
+@@ -1092,7 +1092,7 @@ void set_poison_state(w_root_t *root, st
+ "All requests will continue to fail with this message until you resolve\n"
+ "the underlying problem. You will find more information on fixing this at\n"
+ "https://facebook.github.io/watchman/docs/troubleshooting.html#poison-%s\n",
+- now.tv_sec,
++ (long)now.tv_sec,
+ syscall,
+ dir->path->len,
+ dir->path->buf,