aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-23 21:50:11 +0800
committertobik <tobik@FreeBSD.org>2018-09-23 21:50:11 +0800
commit51336e673e01b83aa894d294f8535f3be3462e37 (patch)
treec3ae52f9e7b80aae606d371eef1cf4b6ef3654f4 /sysutils
parentf3d85a2560c3ac4ede34e43f498396e4f80b2040 (diff)
downloadfreebsd-ports-gnome-51336e673e01b83aa894d294f8535f3be3462e37.tar.gz
freebsd-ports-gnome-51336e673e01b83aa894d294f8535f3be3462e37.tar.zst
freebsd-ports-gnome-51336e673e01b83aa894d294f8535f3be3462e37.zip
New port: sysutils/bfs
bfs is a breadth-first version of the UNIX find(1) command. It supports almost every feature from every major find(1) implementation, so your existing command lines should work as-is. It also adds some features of its own, such as a more forgiving command line parser and some additional options. WWW: https://github.com/tavianator/bfs
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bfs/Makefile30
-rw-r--r--sysutils/bfs/distinfo3
-rw-r--r--sysutils/bfs/pkg-descr8
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index bcabfe4b281c..f6800b8080c9 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -106,6 +106,7 @@
SUBDIR += beadm
SUBDIR += beadm-devel
SUBDIR += beats
+ SUBDIR += bfs
SUBDIR += bhyve-firmware
SUBDIR += bhyve-rc
SUBDIR += biosfont
diff --git a/sysutils/bfs/Makefile b/sysutils/bfs/Makefile
new file mode 100644
index 000000000000..6df5f3b69d41
--- /dev/null
+++ b/sysutils/bfs/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= bfs
+DISTVERSION= 1.2.3
+CATEGORIES= sysutils
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Breadth-first version of the UNIX find command
+
+LICENSE= BSD0CLAUSE
+LICENSE_NAME= BSD Zero Clause License
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+TEST_DEPENDS= bash:shells/bash
+
+USES= gmake shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= tavianator
+
+SHEBANG_FILES= tests.sh
+PLIST_FILES= bin/bfs \
+ man/man1/bfs.1.gz
+TEST_TARGET= check
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bfs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bfs.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/bfs/distinfo b/sysutils/bfs/distinfo
new file mode 100644
index 000000000000..0a766cbd95c1
--- /dev/null
+++ b/sysutils/bfs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537658096
+SHA256 (tavianator-bfs-1.2.3_GH0.tar.gz) = 8ce9e47367db50aeb0bf3c5707080a853993ed98059d577daa45c681f07e2fcd
+SIZE (tavianator-bfs-1.2.3_GH0.tar.gz) = 80044
diff --git a/sysutils/bfs/pkg-descr b/sysutils/bfs/pkg-descr
new file mode 100644
index 000000000000..4895b3198a41
--- /dev/null
+++ b/sysutils/bfs/pkg-descr
@@ -0,0 +1,8 @@
+bfs(1) is a breadth-first version of the UNIX find(1) command.
+
+It supports almost every feature from every major find(1)
+implementation, so your existing command lines should work as-is.
+It also adds some features of its own, such as a more forgiving
+command line parser and some additional options.
+
+WWW: https://github.com/tavianator/bfs