aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2018-08-20 03:24:39 +0800
committerdanilo <danilo@FreeBSD.org>2018-08-20 03:24:39 +0800
commit547ad8b9a52543f22cc57b4649e60ba1548b863c (patch)
treefa725b120f1fc5fb045d03d9526fbda0fa388fad /sysutils
parentf3f32427373e0db0ce181ce4370e6656d3fa4da7 (diff)
downloadfreebsd-ports-gnome-547ad8b9a52543f22cc57b4649e60ba1548b863c.tar.gz
freebsd-ports-gnome-547ad8b9a52543f22cc57b4649e60ba1548b863c.tar.zst
freebsd-ports-gnome-547ad8b9a52543f22cc57b4649e60ba1548b863c.zip
- New port: sysutils/istio
Istio is an open platform for providing a uniform way to integrate microservices, manage traffic flow across microservices, enforce policies and aggregate telemetry data. Istio's control plane provides an abstraction layer over the underlying cluster management platform, such as Kubernetes, Mesos, etc.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/istio/Makefile46
-rw-r--r--sysutils/istio/distinfo3
-rw-r--r--sysutils/istio/pkg-descr7
-rw-r--r--sysutils/istio/pkg-plist216
5 files changed, 273 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2d38bc603576..29135f19d5f5 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -533,6 +533,7 @@
SUBDIR += isomaster
SUBDIR += isomd5sum
SUBDIR += istatserver
+ SUBDIR += istio
SUBDIR += jadm
SUBDIR += jail-primer
SUBDIR += jailadmin
diff --git a/sysutils/istio/Makefile b/sysutils/istio/Makefile
new file mode 100644
index 000000000000..7b99b34cdbcc
--- /dev/null
+++ b/sysutils/istio/Makefile
@@ -0,0 +1,46 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= istio
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= Open platform to connect, manage, and secure microservices
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= kubectl:sysutils/kubectl
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= istio
+
+post-patch:
+ ${LN} -s ${WRKSRC}/vendor ${WRKSRC}/src
+ ${MKDIR} ${WRKSRC}/src/istio.io/istio/istioctl
+ ${LN} -s ${WRKSRC}/istioctl/cmd ${WRKSRC}/src/istio.io/istio/istioctl/cmd
+ ${LN} -s ${WRKSRC}/istioctl/pkg ${WRKSRC}/src/istio.io/istio/istioctl/pkg
+ ${LN} -s ${WRKSRC}/mixer ${WRKSRC}/src/istio.io/istio/mixer
+ ${LN} -s ${WRKSRC}/pilot ${WRKSRC}/src/istio.io/istio/pilot
+ ${LN} -s ${WRKSRC}/pkg ${WRKSRC}/src/istio.io/istio/pkg
+
+do-build:
+ cd ${WRKSRC} && \
+ GOPATH=${WRKSRC} go build -o ${WRKSRC}/bin/istioctl \
+ -ldflags="-X istio.io/istio/pkg/version.buildVersion=${PORTVERSION} \
+ -X istio.io/istio/pkg/version.buildGitRevision=unknown \
+ -X istio.io/istio/pkg/version.buildDockerHub=docker.io/istio" \
+ ./istioctl/cmd/istioctl/
+
+do-install:
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/bin/istioctl \
+ ${STAGEDIR}${PREFIX}/bin/istioctl
+.for data in consul gcp kubernetes
+ (cd ${WRKSRC}/install \
+ && ${COPYTREE_SHARE} ${data} ${STAGEDIR}${DATADIR})
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/istio/distinfo b/sysutils/istio/distinfo
new file mode 100644
index 000000000000..42884e23339e
--- /dev/null
+++ b/sysutils/istio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534610881
+SHA256 (istio-istio-1.0.0_GH0.tar.gz) = 219fa2a48ef273c186ae92f6341358de0c1a5d3f0855d5812d28c706774e4320
+SIZE (istio-istio-1.0.0_GH0.tar.gz) = 18803200
diff --git a/sysutils/istio/pkg-descr b/sysutils/istio/pkg-descr
new file mode 100644
index 000000000000..f1f0105dfc81
--- /dev/null
+++ b/sysutils/istio/pkg-descr
@@ -0,0 +1,7 @@
+Istio is an open platform for providing a uniform way to integrate
+microservices, manage traffic flow across microservices, enforce
+policies and aggregate telemetry data. Istio's control plane provides
+an abstraction layer over the underlying cluster management platform,
+such as Kubernetes, Mesos, etc.
+
+WWW: https://istio.io
diff --git a/sysutils/istio/pkg-plist b/sysutils/istio/pkg-plist
new file mode 100644
index 000000000000..b219ad591bd8
--- /dev/null
+++ b/sysutils/istio/pkg-plist
@@ -0,0 +1,216 @@
+bin/istioctl
+%%DATADIR%%/consul/README.md
+%%DATADIR%%/consul/kubeconfig
+%%DATADIR%%/consul/templates/istio.yaml.tmpl
+%%DATADIR%%/gcp/README.md
+%%DATADIR%%/gcp/deployment_manager/README.md
+%%DATADIR%%/gcp/deployment_manager/istio-cluster.jinja
+%%DATADIR%%/gcp/deployment_manager/istio-cluster.jinja.display
+%%DATADIR%%/gcp/deployment_manager/istio-cluster.jinja.schema
+%%DATADIR%%/gcp/deployment_manager/istio-cluster.yaml
+%%DATADIR%%/kubernetes/README.md
+%%DATADIR%%/kubernetes/addons/zipkin.yaml.tmpl
+%%DATADIR%%/kubernetes/ansible/README.md
+%%DATADIR%%/kubernetes/ansible/ansible.cfg
+%%DATADIR%%/kubernetes/ansible/istio/defaults/main.yml
+%%DATADIR%%/kubernetes/ansible/istio/meta/main.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/add_to_path.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/assert_oc_admin.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/bookinfo_cmd.j2
+%%DATADIR%%/kubernetes/ansible/istio/tasks/change_scc.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/create_namespace_free_definition_file.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/delete_resources.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/install_addons.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/install_on_cluster.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/install_sample.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/install_samples.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/main.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/safely_create_namespace.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/set_appropriate_cmd_path.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/set_istio_distro_vars.yml
+%%DATADIR%%/kubernetes/ansible/istio/tasks/simple_sample_cmd.j2
+%%DATADIR%%/kubernetes/ansible/istio/vars/main.yml
+%%DATADIR%%/kubernetes/ansible/main.yml
+%%DATADIR%%/kubernetes/citadel_extras/istio-citadel-plugin-certs.yaml.tmpl
+%%DATADIR%%/kubernetes/citadel_extras/istio-citadel-standalone.yaml.tmpl
+%%DATADIR%%/kubernetes/citadel_extras/istio-citadel-with-health-check.yaml.tmpl
+%%DATADIR%%/kubernetes/helm/README.md
+%%DATADIR%%/kubernetes/helm/helm-service-account.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/LICENSE
+%%DATADIR%%/kubernetes/helm/istio-remote/README.md
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/cleanup-secrets.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/create-custom-resources-job.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/enable-mesh-mtls.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/security/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/OWNERS
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/mutatingwebhook.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/charts/sidecarInjectorWebhook/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/requirements.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/NOTES.txt
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/_affinity.tpl
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/endpoints.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/install-custom-resources.sh.tpl
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/templates/sidecar-injector-configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio-remote/values.yaml
+%%DATADIR%%/kubernetes/helm/istio/.helmignore
+%%DATADIR%%/kubernetes/helm/istio/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/LICENSE
+%%DATADIR%%/kubernetes/helm/istio/README.md
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/NOTES.txt
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/crds.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/issuer.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/rbac.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/certmanager/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/OWNERS
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/galley/templates/validatingwehookconfiguration.yaml.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/autoscale.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/clusterrolebindings.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/gateways/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/create-custom-resources-job.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/grafana-ports-mtls.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/secret.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/grafana/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/autoscale.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/ingress/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/ingress.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/secrets.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/kiali/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/autoscale.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/config.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/mixer/templates/statsdtoprom.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/autoscale.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/gateway.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/meshexpansion.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/pilot/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/clusterrolebindings.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/prometheus/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/cleanup-secrets.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/create-custom-resources-job.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/enable-mesh-mtls.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/meshexpansion.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/security/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/.helmignore
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/templates/NOTES.txt
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/templates/ingress.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/servicegraph/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/OWNERS
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/clusterrole.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/clusterrolebinding.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/mutatingwebhook.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/sidecarInjectorWebhook/templates/serviceaccount.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/telemetry-gateway/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/telemetry-gateway/templates/gateway.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/.helmignore
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/Chart.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/NOTES.txt
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/deployment.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/ingress-jaeger.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/ingress.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/service-jaeger.yaml
+%%DATADIR%%/kubernetes/helm/istio/charts/tracing/templates/service.yaml
+%%DATADIR%%/kubernetes/helm/istio/requirements.yaml
+%%DATADIR%%/kubernetes/helm/istio/templates/NOTES.txt
+%%DATADIR%%/kubernetes/helm/istio/templates/_affinity.tpl
+%%DATADIR%%/kubernetes/helm/istio/templates/_helpers.tpl
+%%DATADIR%%/kubernetes/helm/istio/templates/configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/templates/crds.yaml
+%%DATADIR%%/kubernetes/helm/istio/templates/install-custom-resources.sh.tpl
+%%DATADIR%%/kubernetes/helm/istio/templates/sidecar-injector-configmap.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-auth-galley.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-auth-multicluster.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-auth.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-demo-auth.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-demo.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-galley.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-gateways.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-multicluster.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-one-namespace-auth.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio-one-namespace.yaml
+%%DATADIR%%/kubernetes/helm/istio/values-istio.yaml
+%%DATADIR%%/kubernetes/helm/istio/values.yaml
+%%DATADIR%%/kubernetes/mesh-expansion.yaml
+%%DATADIR%%/kubernetes/namespace.yaml