aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-09 21:28:40 +0800
committerkwm <kwm@FreeBSD.org>2015-08-09 21:28:40 +0800
commit6057d06e0e16478d69e3c00627c46e034bdc7a86 (patch)
tree1b584074491da07795995fb5af7f537fea488d3d /sysutils
parentd2e066b989355077d75e851eaae27ee36fb38af6 (diff)
downloadfreebsd-ports-gnome-6057d06e0e16478d69e3c00627c46e034bdc7a86.tar.gz
freebsd-ports-gnome-6057d06e0e16478d69e3c00627c46e034bdc7a86.tar.zst
freebsd-ports-gnome-6057d06e0e16478d69e3c00627c46e034bdc7a86.zip
Update polkit to 0.113. [1]
- Add LICENSE blob - Adjust dependencies - Reorganize options helper - Update description file PR: 201362 [1], 194789 Submitted by: olivierd@ [1] Tested by: olivierd@, Tobias Berner <tcberner@gmail.com>, and myself
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/polkit/Makefile60
-rw-r--r--sysutils/polkit/distinfo4
-rw-r--r--sysutils/polkit/files/patch-Makefile.in22
-rw-r--r--sysutils/polkit/files/patch-data_Makefile.in11
-rw-r--r--sysutils/polkit/files/patch-docs_man_polkit.xml89
-rw-r--r--sysutils/polkit/files/patch-src_polkitagent_polkitagenthelperprivate.c12
-rw-r--r--sysutils/polkit/files/patch-src_polkitbackend_Makefile.in23
-rw-r--r--sysutils/polkit/files/patch-src_polkitbackend_polkitbackendinteractiveauthority.c11
-rw-r--r--sysutils/polkit/files/patch-src_polkitbackend_polkitbackendlocalauthority.c23
-rw-r--r--sysutils/polkit/files/patch-src_polkitd_gposixsignal.c40
-rw-r--r--sysutils/polkit/pkg-descr4
-rw-r--r--sysutils/polkit/pkg-plist50
12 files changed, 146 insertions, 203 deletions
diff --git a/sysutils/polkit/Makefile b/sysutils/polkit/Makefile
index c8e41d81444a..b6a734eb9d29 100644
--- a/sysutils/polkit/Makefile
+++ b/sysutils/polkit/Makefile
@@ -2,59 +2,63 @@
# $FreeBSD$
PORTNAME= polkit
-PORTVERSION= 0.105
-PORTREVISION= 7
+PORTVERSION= 0.113
CATEGORIES= sysutils gnome
MASTER_SITES= http://www.freedesktop.org/software/polkit/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Framework for controlling access to system-wide components
-LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libmozjs-17.0.so:${PORTSDIR}/lang/spidermonkey170
RUN_DEPENDS= dbus-launch:${PORTSDIR}/devel/dbus
-USE_GNOME= glib20 intlhack introspection
-USES= gettext gmake libtool pathfix pkgconfig
+USERS= polkitd
+GROUPS= polkitd
+
+USE_GNOME= glib20 intlhack introspection:build
+USES= gettext gmake libtool pathfix pkgconfig shebangfix
+SHEBANG_FILES= ${WRKSRC}/src/polkitbackend/toarray.pl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-gtk-doc \
+CONFIGURE_ARGS= --disable-gtk-doc-html \
+ --without-html-dir \
--with-authfw=pam \
--with-pam-include=system \
--with-os-type=freebsd \
- --disable-systemd \
- --enable-introspection \
+ --with-polkitd-user=${USERS} \
+ --disable-static \
+ --disable-examples \
+ --with-mozjs=mozjs-17.0 \
+ --disable-libsystemd-login \
+ --disable-test \
+ --enable-introspection=yes \
--localstatedir=/var
-MAKE_JOBS_UNSAFE=yes
-CONFIGURE_ENV= GTKDOC="false"
+#MAKE_JOBS_UNSAFE=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= MANPAGES
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMANPAGES}
-BUILD_DEPENDS+= docbook-sgml>0:${PORTSDIR}/textproc/docbook-sgml \
- ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
-
-USE_GNOME+= libxslt:build
-PLIST_SUB+= MANPAGES=""
-.else
-CONFIGURE_ARGS+=--disable-man-pages
-PLIST_SUB+= MANPAGES="@comment "
-.endif
+MANPAGES_BUILD_DEPENDS= docbook-sgml>=4.5:${PORTSDIR}/textproc/docbook-sgml \
+ docbook-xsl>=1.76:${PORTSDIR}/textproc/docbook-xsl
+MANPAGES_USE= gnome=libxslt:build
+MANPAGES_CONFIGURE_ENABLE= man-pages
+OPTIONS_SUB= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/|${PREFIX}/bin/|g' \
${WRKSRC}/docs/man/pkexec.xml \
${WRKSRC}/src/examples/org.freedesktop.policykit.examples.pkexec.policy.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/docs/man/polkit.xml
post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/dbus-1/system.d/
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/polkit-1/rules.d/
+ @${MKDIR} ${STAGEDIR}/var/lib/polkit-1
${INSTALL_DATA} ${WRKSRC}/data/org.freedesktop.PolicyKit1.conf \
- ${STAGEDIR}${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.dist
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/polkit-1/extensions/lib*.so
+ ${STAGEDIR}${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.sample
.include <bsd.port.mk>
diff --git a/sysutils/polkit/distinfo b/sysutils/polkit/distinfo
index bd125cce13d9..99e4b7d4902c 100644
--- a/sysutils/polkit/distinfo
+++ b/sysutils/polkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (polkit-0.105.tar.gz) = 8fdc7cc8ba4750fcce1a4db9daa759c12afebc7901237e1c993c38f08985e1df
-SIZE (polkit-0.105.tar.gz) = 1431080
+SHA256 (polkit-0.113.tar.gz) = e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81
+SIZE (polkit-0.113.tar.gz) = 1448865
diff --git a/sysutils/polkit/files/patch-Makefile.in b/sysutils/polkit/files/patch-Makefile.in
index 665c13c7d361..7df528e3a301 100644
--- a/sysutils/polkit/files/patch-Makefile.in
+++ b/sysutils/polkit/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2012-05-15 22:09:33.000000000 +0200
-+++ Makefile.in 2012-05-15 22:10:16.000000000 +0200
-@@ -292,7 +292,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = actions data src docs po test
-+SUBDIRS = actions data src docs po
- NULL =
- EXTRA_DIST = \
- HACKING \
+--- Makefile.in.orig 2015-06-19 20:31:12 UTC
++++ Makefile.in
+@@ -157,7 +157,7 @@ am__define_uniq_tagged_files = \
+ ETAGS = etags
+ CTAGS = ctags
+ CSCOPE = cscope
+-DIST_SUBDIRS = actions data src docs po test
++DIST_SUBDIRS = actions data src docs po
+ am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in AUTHORS \
+ COPYING ChangeLog INSTALL NEWS README compile config.guess \
+ config.sub depcomp install-sh ltmain.sh missing
diff --git a/sysutils/polkit/files/patch-data_Makefile.in b/sysutils/polkit/files/patch-data_Makefile.in
deleted file mode 100644
index c2895461f523..000000000000
--- a/sysutils/polkit/files/patch-data_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- data/Makefile.in.orig 2009-08-01 16:02:38.000000000 +0200
-+++ data/Makefile.in 2009-08-01 16:05:13.000000000 +0200
-@@ -471,7 +471,7 @@
-
- info-am:
-
--install-data-am: install-dbusconfDATA install-pamDATA \
-+install-data-am: install-pamDATA \
- install-pkgconfigDATA install-serviceDATA
-
- install-dvi: install-dvi-am
diff --git a/sysutils/polkit/files/patch-docs_man_polkit.xml b/sysutils/polkit/files/patch-docs_man_polkit.xml
new file mode 100644
index 000000000000..f765af1219ab
--- /dev/null
+++ b/sysutils/polkit/files/patch-docs_man_polkit.xml
@@ -0,0 +1,89 @@
+--- docs/man/polkit.xml.orig 2013-05-06 18:28:21 UTC
++++ docs/man/polkit.xml
+@@ -100,17 +100,17 @@ System Context |
+ | polkitd(8) |
+ +------------------+
+ | org.freedesktop. |
+-| PolicyKit1 |<---------+
+-+------------------+ |
+- ^ |
+- | +--------------------------------------+
+- | | /usr/share/polkit-1/actions/*.policy |
+- | +--------------------------------------+
++| PolicyKit1 |<------+
+++------------------+ |
++ ^ |
++ | +--------------------------------------------+
++ | | /usr/local/share/polkit-1/actions/*.policy |
++ | +--------------------------------------------+
+ |
+- +--------------------------------------+
+- | /etc/polkit-1/rules.d/*.rules |
+- | /usr/share/polkit-1/rules.d/*.rules |
+- +--------------------------------------+
++ +------------------------------------------------+
++ | /usr/local/etc/polkit-1/rules.d/*.rules |
++ | /usr/local/share/polkit-1/rules.d/*.rules |
++ +------------------------------------------------+
+ ]]></programlisting>
+ </textobject>
+ </mediaobject>
+@@ -217,7 +217,7 @@ System Context |
+ order to use polkit. Actions correspond to operations that
+ clients can request the mechanism to carry out and are defined
+ in XML files that the mechanism installs into the <filename
+- class='directory'>/usr/share/polkit-1/actions</filename>
++ class='directory'>/usr/local/share/polkit-1/actions</filename>
+ directory.
+ </para>
+
+@@ -473,21 +473,21 @@ System Context |
+ <para>
+ <command>polkitd</command> reads
+ <filename class='extension'>.rules</filename> files from the
+- <filename class='directory'>/etc/polkit-1/rules.d</filename> and
+- <filename class='directory'>/usr/share/polkit-1/rules.d</filename>
++ <filename class='directory'>/usr/local/etc/polkit-1/rules.d</filename> and
++ <filename class='directory'>/usr/local/share/polkit-1/rules.d</filename>
+ directories by sorting the files in lexical order based on the
+ basename on each file (if there's a tie, files in
+- <filename class='directory'>/etc</filename>
++ <filename class='directory'>/usr/local/etc</filename>
+ are processed before files in
+- <filename class='directory'>/usr</filename>).
++ <filename class='directory'>/usr/local/share</filename>).
+ For example, for the following four
+ files, the order is
+ </para>
+ <itemizedlist mark='opencircle' spacing='compact'>
+- <listitem><para><filename>/etc/polkit-1/rules.d/10-auth.rules</filename></para></listitem>
+- <listitem><para><filename>/usr/share/polkit-1/rules.d/10-auth.rules</filename></para></listitem>
+- <listitem><para><filename>/etc/polkit-1/rules.d/15-auth.rules</filename></para></listitem>
+- <listitem><para><filename>/usr/share/polkit-1/rules.d/20-auth.rules</filename></para></listitem>
++ <listitem><para><filename>/usr/local/etc/polkit-1/rules.d/10-auth.rules</filename></para></listitem>
++ <listitem><para><filename>/usr/local/share/polkit-1/rules.d/10-auth.rules</filename></para></listitem>
++ <listitem><para><filename>/usr/local/etc/polkit-1/rules.d/15-auth.rules</filename></para></listitem>
++ <listitem><para><filename>/usr/local/share/polkit-1/rules.d/20-auth.rules</filename></para></listitem>
+ </itemizedlist>
+ <para>
+ Both directories are monitored so if a rules file is changed,
+@@ -683,8 +683,8 @@ polkit.addRule(function(action, subject)
+ will produce the following when the user runs 'pkexec -u bateman bash -i' from a shell:
+ </para>
+ <programlisting><![CDATA[
+-May 24 14:28:50 thinkpad polkitd[32217]: /etc/polkit-1/rules.d/10-test.rules:3: action=[Action id='org.freedesktop.policykit.exec' command_line='/usr/bin/bash -i' program='/usr/bin/bash' user='bateman' user.gecos='Patrick Bateman' user.display='Patrick Bateman (bateman)']
+-May 24 14:28:50 thinkpad polkitd[32217]: /etc/polkit-1/rules.d/10-test.rules:4: subject=[Subject pid=1352 user='davidz' groups=davidz,wheel, seat='seat0' session='1' local=true active=true]
++May 24 14:28:50 thinkpad polkitd[32217]: /usr/local/etc/polkit-1/rules.d/10-test.rules:3: action=[Action id='org.freedesktop.policykit.exec' command_line='/usr/local/bin/bash -i' program='/usr/local/bin/bash' user='bateman' user.gecos='Patrick Bateman' user.display='Patrick Bateman (bateman)']
++May 24 14:28:50 thinkpad polkitd[32217]: /usr/local/etc/polkit-1/rules.d/10-test.rules:4: subject=[Subject pid=1352 user='davidz' groups=davidz,wheel, seat='seat0' session='1' local=true active=true]
+ ]]></programlisting>
+
+ </refsect2>
+@@ -916,7 +916,7 @@ polkit.addRule(function(action, subject)
+ <programlisting><![CDATA[
+ polkit.addRule(function(action, subject) {
+ if (action.id == "org.freedesktop.policykit.exec" &&
+- action.lookup("program") == "/usr/bin/cat") {
++ action.lookup("program") == "/bin/cat") {
+ return polkit.Result.AUTH_ADMIN;
+ }
+ });
diff --git a/sysutils/polkit/files/patch-src_polkitagent_polkitagenthelperprivate.c b/sysutils/polkit/files/patch-src_polkitagent_polkitagenthelperprivate.c
deleted file mode 100644
index c5c5bd8dade8..000000000000
--- a/sysutils/polkit/files/patch-src_polkitagent_polkitagenthelperprivate.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/polkitagent/polkitagenthelperprivate.c.orig 2011-02-23 18:18:11.000000000 +0000
-+++ src/polkitagent/polkitagenthelperprivate.c 2011-02-23 18:18:41.000000000 +0000
-@@ -103,7 +103,7 @@ flush_and_wait ()
- {
- fflush (stdout);
- fflush (stderr);
-- fdatasync (fileno(stdout));
-- fdatasync (fileno(stderr));
-+ fsync (fileno(stdout));
-+ fsync (fileno(stderr));
- usleep (100 * 1000);
- }
diff --git a/sysutils/polkit/files/patch-src_polkitbackend_Makefile.in b/sysutils/polkit/files/patch-src_polkitbackend_Makefile.in
deleted file mode 100644
index 08db0ab02876..000000000000
--- a/sysutils/polkit/files/patch-src_polkitbackend_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/polkitbackend/Makefile.in.orig 2010-01-18 02:50:30.000000000 -0500
-+++ src/polkitbackend/Makefile.in 2010-01-18 14:18:36.000000000 -0500
-@@ -899,10 +899,18 @@ clean-local :
-
- install-exec-hook:
- mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1
-- mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/{10-vendor.d,20-org.d,30-site.d,50-local.d,90-mandatory.d}
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/10-vendor.d
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/20-org.d
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/30-site.d
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/50-local.d
-+ mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1/localauthority/90-mandatory.d
- -chmod 700 $(DESTDIR)$(localstatedir)/lib/polkit-1
- mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1
-- mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/{10-vendor.d,20-org.d,30-site.d,50-local.d,90-mandatory.d}
-+ mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/10-vendor.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/20-org.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/30-site.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/50-local.d
-+ mkdir -p $(DESTDIR)$(sysconfdir)/polkit-1/localauthority/90-mandatory.d
- -chmod 700 $(DESTDIR)$(sysconfdir)/polkit-1/localauthority
- mkdir -p $(DESTDIR)$(libdir)/polkit-1/extensions
-
diff --git a/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendinteractiveauthority.c b/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendinteractiveauthority.c
deleted file mode 100644
index 76a08f711bcc..000000000000
--- a/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendinteractiveauthority.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/polkitbackend/polkitbackendinteractiveauthority.c.orig 2012-05-15 21:52:38.000000000 +0200
-+++ src/polkitbackend/polkitbackendinteractiveauthority.c 2012-05-15 21:52:49.000000000 +0200
-@@ -279,7 +279,7 @@
- static volatile GQuark domain = 0;
-
- /* Force registering error domain */
-- domain = POLKIT_ERROR; domain;
-+ domain = POLKIT_ERROR;
-
- priv = POLKIT_BACKEND_INTERACTIVE_AUTHORITY_GET_PRIVATE (authority);
-
diff --git a/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendlocalauthority.c b/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendlocalauthority.c
deleted file mode 100644
index f4a57022e5f9..000000000000
--- a/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendlocalauthority.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/polkitbackend/polkitbackendlocalauthority.c.orig 2012-05-15 21:52:35.000000000 +0200
-+++ src/polkitbackend/polkitbackendlocalauthority.c 2012-05-15 21:53:07.000000000 +0200
-@@ -700,11 +700,7 @@
- ret = NULL;
- name = polkit_unix_netgroup_get_name (POLKIT_UNIX_NETGROUP (group));
-
-- if (setnetgrent (name) == 0)
-- {
-- g_warning ("Error looking up net group with name %s: %s", name, g_strerror (errno));
-- goto out;
-- }
-+ setnetgrent (name);
-
- for (;;)
- {
-@@ -737,7 +733,6 @@
-
- ret = g_list_reverse (ret);
-
-- out:
- endnetgrent ();
- return ret;
- }
diff --git a/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c b/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c
deleted file mode 100644
index 4fb366f4f2de..000000000000
--- a/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/polkitd/gposixsignal.c.orig 2010-08-29 20:05:07.000000000 -0400
-+++ src/polkitd/gposixsignal.c 2010-08-29 20:13:20.000000000 -0400
-@@ -23,7 +23,13 @@
- #include "config.h"
-
- #include <unistd.h>
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <sys/event.h>
-+#include <sys/time.h>
-+#else
- #include <sys/signalfd.h>
-+#endif
- #include <signal.h>
-
- #include "gposixsignal.h"
-@@ -83,6 +89,9 @@ _g_posix_signal_source_new (gint signum)
- gint fd;
- GSource *_source;
- _GPosixSignalSource *source;
-+#ifdef __FreeBSD__
-+ struct kevent ev;
-+#endif
-
- _source = NULL;
-
-@@ -92,7 +101,13 @@ _g_posix_signal_source_new (gint signum)
- if (sigprocmask (SIG_BLOCK, &sigset, NULL) == -1)
- g_assert_not_reached ();
-
-+#ifdef __FreeBSD__
-+ fd = kqueue ();
-+ EV_SET (&ev, signum, EVFILT_SIGNAL, EV_ADD, 0, 0, NULL);
-+ kevent (fd, &ev, 1, NULL, 0, NULL);
-+#else
- fd = signalfd (-1, &sigset, SFD_NONBLOCK | SFD_CLOEXEC);
-+#endif
-
- _source = g_source_new (&_g_posix_signal_source_funcs, sizeof (_GPosixSignalSource));
- source = (_GPosixSignalSource *) _source;
diff --git a/sysutils/polkit/pkg-descr b/sysutils/polkit/pkg-descr
index 4f0b6a299e16..d6878555d7e3 100644
--- a/sysutils/polkit/pkg-descr
+++ b/sysutils/polkit/pkg-descr
@@ -1,4 +1,4 @@
-PolicyKit is a framework for defining policy for system-wide components and
-for desktop pieces to configure it. It is used by HAL.
+Polkit is a toolkit for defining and handling authorizations. It is used
+for allowing unprivileged processes to speak to privileged processes.
WWW: http://www.freedesktop.org/wiki/Software/polkit
diff --git a/sysutils/polkit/pkg-plist b/sysutils/polkit/pkg-plist
index 801210c4f6dc..78a75d8c2b99 100644
--- a/sysutils/polkit/pkg-plist
+++ b/sysutils/polkit/pkg-plist
@@ -1,18 +1,14 @@
-bin/pk-example-frobnicate
bin/pkaction
bin/pkcheck
-bin/pkexec
+@(root,,4755) bin/pkexec
bin/pkttyagent
-@unexec if cmp -s %D/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf %D/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.dist; then rm -f %D/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf ; fi
-etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.dist
-@exec [ -f %B/org.freedesktop.PolicyKit1.conf ] || cp %B/%f %B/org.freedesktop.PolicyKit1.conf
+@sample etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.sample
etc/pam.d/polkit-1
-etc/polkit-1/localauthority.conf.d/50-localauthority.conf
-etc/polkit-1/nullbackend.conf.d/50-nullbackend.conf
+etc/polkit-1/rules.d/50-default.rules
include/polkit-1/polkit/polkit.h
include/polkit-1/polkit/polkitactiondescription.h
-include/polkit-1/polkit/polkitauthorityfeatures.h
include/polkit-1/polkit/polkitauthority.h
+include/polkit-1/polkit/polkitauthorityfeatures.h
include/polkit-1/polkit/polkitauthorizationresult.h
include/polkit-1/polkit/polkitcheckauthorizationflags.h
include/polkit-1/polkit/polkitdetails.h
@@ -35,59 +31,33 @@ include/polkit-1/polkitagent/polkitagent.h
include/polkit-1/polkitagent/polkitagentenumtypes.h
include/polkit-1/polkitagent/polkitagentlistener.h
include/polkit-1/polkitagent/polkitagentsession.h
-include/polkit-1/polkitagent/polkitagenttypes.h
include/polkit-1/polkitagent/polkitagenttextlistener.h
-include/polkit-1/polkitbackend/polkitbackend.h
-include/polkit-1/polkitbackend/polkitbackendactionlookup.h
-include/polkit-1/polkitbackend/polkitbackendauthority.h
-include/polkit-1/polkitbackend/polkitbackendinteractiveauthority.h
-include/polkit-1/polkitbackend/polkitbackendlocalauthority.h
-include/polkit-1/polkitbackend/polkitbackendtypes.h
+include/polkit-1/polkitagent/polkitagenttypes.h
lib/girepository-1.0/Polkit-1.0.typelib
lib/girepository-1.0/PolkitAgent-1.0.typelib
-lib/libpolkit-agent-1.a
lib/libpolkit-agent-1.so
lib/libpolkit-agent-1.so.0
lib/libpolkit-agent-1.so.0.0.0
-lib/libpolkit-backend-1.a
-lib/libpolkit-backend-1.so
-lib/libpolkit-backend-1.so.0
-lib/libpolkit-backend-1.so.0.0.0
-lib/libpolkit-gobject-1.a
lib/libpolkit-gobject-1.so
lib/libpolkit-gobject-1.so.0
lib/libpolkit-gobject-1.so.0.0.0
-lib/polkit-1/extensions/libnullbackend.a
-lib/polkit-1/extensions/libnullbackend.so
+@(root,,4755) lib/polkit-1/polkit-agent-helper-1
+lib/polkit-1/polkitd
libdata/pkgconfig/polkit-agent-1.pc
-libdata/pkgconfig/polkit-backend-1.pc
libdata/pkgconfig/polkit-gobject-1.pc
-libexec/polkit-agent-helper-1
-libexec/polkitd
%%MANPAGES%%man/man1/pkaction.1.gz
%%MANPAGES%%man/man1/pkcheck.1.gz
%%MANPAGES%%man/man1/pkexec.1.gz
%%MANPAGES%%man/man1/pkttyagent.1.gz
-%%MANPAGES%%man/man8/pklocalauthority.8.gz
%%MANPAGES%%man/man8/polkit.8.gz
%%MANPAGES%%man/man8/polkitd.8.gz
share/dbus-1/system-services/org.freedesktop.PolicyKit1.service
share/gir-1.0/Polkit-1.0.gir
share/gir-1.0/PolkitAgent-1.0.gir
+share/locale/cs/LC_MESSAGES/polkit-1.mo
share/locale/da/LC_MESSAGES/polkit-1.mo
-share/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
share/polkit-1/actions/org.freedesktop.policykit.policy
-@dir share/polkit-1/rules.d
-@dir etc/polkit-1/localauthority/90-mandatory.d
-@dir etc/polkit-1/localauthority/50-local.d
-@dir etc/polkit-1/localauthority/30-site.d
-@dir etc/polkit-1/localauthority/20-org.d
-@dir etc/polkit-1/localauthority/10-vendor.d
-@dir /var/lib/polkit-1/localauthority/90-mandatory.d
-@dir /var/lib/polkit-1/localauthority/50-local.d
-@dir /var/lib/polkit-1/localauthority/30-site.d
-@dir /var/lib/polkit-1/localauthority/20-org.d
-@dir /var/lib/polkit-1/localauthority/10-vendor.d
-@dir /var/lib/polkit-1/localauthority
+@dir(polkitd,,700) etc/polkit-1/rules.d
+@dir(polkitd,,700) share/polkit-1/rules.d
@dir /var/lib/polkit-1
@dir /var/lib