aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2015-06-17 17:01:03 +0800
committergahr <gahr@FreeBSD.org>2015-06-17 17:01:03 +0800
commit7a0f00b7aa2f8defcc8cb60dc4d7fee504dd6317 (patch)
treecbf08c209a3b44becb2a9a58624beb14e0359d51 /sysutils
parent1dd7f02348907c2eb735cc804399e12c8788a990 (diff)
downloadfreebsd-ports-gnome-7a0f00b7aa2f8defcc8cb60dc4d7fee504dd6317.tar.gz
freebsd-ports-gnome-7a0f00b7aa2f8defcc8cb60dc4d7fee504dd6317.tar.zst
freebsd-ports-gnome-7a0f00b7aa2f8defcc8cb60dc4d7fee504dd6317.zip
- Take back port, I'm actively working on it
- While at it, makepatch-ify files and add LICENSE
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pwsafe/Makefile4
-rw-r--r--sysutils/pwsafe/files/patch-pwsafe.cpp8
2 files changed, 7 insertions, 5 deletions
diff --git a/sysutils/pwsafe/Makefile b/sysutils/pwsafe/Makefile
index b8efb2981461..4879904da684 100644
--- a/sysutils/pwsafe/Makefile
+++ b/sysutils/pwsafe/Makefile
@@ -7,9 +7,11 @@ PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://nsd.dyndns.org/pwsafe/releases/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Cmdline program that manages encrypted password databases
+LICENSE= GPLv2
+
OPTIONS_DEFINE= SETUID X11
SETUID_DESC= Install setuid pwsafe binary
diff --git a/sysutils/pwsafe/files/patch-pwsafe.cpp b/sysutils/pwsafe/files/patch-pwsafe.cpp
index 0892e0a44999..6fd4bcb765a4 100644
--- a/sysutils/pwsafe/files/patch-pwsafe.cpp
+++ b/sysutils/pwsafe/files/patch-pwsafe.cpp
@@ -1,6 +1,6 @@
---- pwsafe.cpp.orig 2005-09-30 12:30:56.000000000 +0200
-+++ pwsafe.cpp 2014-09-17 15:44:48.000000000 +0200
-@@ -1019,7 +1019,12 @@
+--- pwsafe.cpp.orig 2005-09-30 10:30:56 UTC
++++ pwsafe.cpp
+@@ -1019,7 +1019,12 @@ int main(int argc, char **argv) {
// seed the random number generator
char rng_filename[1024];
if (RAND_file_name(rng_filename,sizeof(rng_filename))) {
@@ -14,7 +14,7 @@
if (rc) {
if (arg_verbose > 0) printf("rng seeded with %d bytes from %s\n", rc, rng_filename);
} else {
-@@ -2111,7 +2116,7 @@
+@@ -2111,7 +2116,7 @@ static secstring xmlescape(const secstri
case '"': out += "&quot;"; break;
case '&': out += "&amp;"; break;
case '<': out += "&lt;"; break;