aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2011-05-23 23:35:07 +0800
committerfjoe <fjoe@FreeBSD.org>2011-05-23 23:35:07 +0800
commit8347b87ad273a765a083afa1006bb9458d26e575 (patch)
tree013d93e7963ce4beed79dd1f4f1777769b3214b6 /sysutils
parent7b9ae87c921d4e535f29d5a88e649ac3b0a15d01 (diff)
downloadfreebsd-ports-gnome-8347b87ad273a765a083afa1006bb9458d26e575.tar.gz
freebsd-ports-gnome-8347b87ad273a765a083afa1006bb9458d26e575.tar.zst
freebsd-ports-gnome-8347b87ad273a765a083afa1006bb9458d26e575.zip
There is no /proc/self/fd/0 on FreeBSD: use /dev/fd/0 instead.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/brasero/Makefile2
-rw-r--r--sysutils/brasero/files/patch-plugins-growisofs-burn-growisofs.c24
2 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index 43fc31288a68..c8f2546bbdb0 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -7,6 +7,7 @@
PORTNAME= brasero
PORTVERSION= 2.32.1
+PORTREVISION= 1
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -70,5 +71,6 @@ post-patch:
${WRKSRC}/libbrasero-burn/burn-process.c
@${REINPLACE_CMD} -e 's|" == "|" = "|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/proc/self/fd/0|/dev/fd/0|g' ${WRKSRC}/po/*.po
.include <bsd.port.post.mk>
diff --git a/sysutils/brasero/files/patch-plugins-growisofs-burn-growisofs.c b/sysutils/brasero/files/patch-plugins-growisofs-burn-growisofs.c
new file mode 100644
index 000000000000..f7ae2b9e67d6
--- /dev/null
+++ b/sysutils/brasero/files/patch-plugins-growisofs-burn-growisofs.c
@@ -0,0 +1,24 @@
+--- plugins/growisofs/burn-growisofs.c.orig 2011-05-23 20:22:46.000000000 +0700
++++ plugins/growisofs/burn-growisofs.c 2011-05-23 20:23:15.000000000 +0700
+@@ -502,18 +502,18 @@
+ /* FIXME: is it right to mess with it ?
+ g_ptr_array_add (argv, g_strdup_printf ("-use-the-force-luke=bufsize:%im", 32)); */
+
+- if (!g_file_test ("/proc/self/fd/0", G_FILE_TEST_EXISTS)) {
++ if (!g_file_test ("/dev/fd/0", G_FILE_TEST_EXISTS)) {
+ g_set_error (error,
+ BRASERO_BURN_ERROR,
+ BRASERO_BURN_ERROR_FILE_NOT_FOUND,
+ _("\"%s\" could not be found"),
+- "/proc/self/fd/0");
++ "/dev/fd/0");
+ return BRASERO_BURN_ERR;
+ }
+
+ /* FIXME: should we use DAO ? */
+ g_ptr_array_add (argv, g_strdup ("-Z"));
+- g_ptr_array_add (argv, g_strdup_printf ("%s=/proc/self/fd/0", device));
++ g_ptr_array_add (argv, g_strdup_printf ("%s=/dev/fd/0", device));
+ g_free (device);
+ }
+ else if (BRASERO_IS_TRACK_IMAGE (current)) {