aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2015-06-23 13:25:17 +0800
committerkevlo <kevlo@FreeBSD.org>2015-06-23 13:25:17 +0800
commit8f5b929dc03805dbedfb65f61227e9402ce81ee5 (patch)
tree40b8cb0371e619abaab74507dca10b7e233ffc4d /sysutils
parent87e318c0abed803141f6632f6a1c28f73e640693 (diff)
downloadfreebsd-ports-gnome-8f5b929dc03805dbedfb65f61227e9402ce81ee5.tar.gz
freebsd-ports-gnome-8f5b929dc03805dbedfb65f61227e9402ce81ee5.tar.zst
freebsd-ports-gnome-8f5b929dc03805dbedfb65f61227e9402ce81ee5.zip
Update to 1.4.1
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/zbackup/Makefile10
-rw-r--r--sysutils/zbackup/distinfo4
-rw-r--r--sysutils/zbackup/files/patch-compression.cc11
-rw-r--r--sysutils/zbackup/files/patch-dir.cc11
-rw-r--r--sysutils/zbackup/files/patch-file.cc21
5 files changed, 52 insertions, 5 deletions
diff --git a/sysutils/zbackup/Makefile b/sysutils/zbackup/Makefile
index 2237f7fa22c8..c9821aabbfc9 100644
--- a/sysutils/zbackup/Makefile
+++ b/sysutils/zbackup/Makefile
@@ -1,18 +1,22 @@
# $FreeBSD$
PORTNAME= zbackup
-PORTVERSION= 1.3
+PORTVERSION= 1.4.1
CATEGORIES= sysutils
+MASTER_SITES= https://github.com/zbackup/zbackup/archive/
+DISTNAME= ${PORTVERSION}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Versatile deduplicating backup tool
LICENSE= GPLv2
-LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf \
+ liblzo2.so:${PORTSDIR}/archivers/lzo2
USES= cmake
-USE_GITHUB= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DOCS
diff --git a/sysutils/zbackup/distinfo b/sysutils/zbackup/distinfo
index 492b9233821d..e7ca77d2b72f 100644
--- a/sysutils/zbackup/distinfo
+++ b/sysutils/zbackup/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zbackup-zbackup-1.3_GH0.tar.gz) = 0c85232918295984fccb35804dbaeaa38df13c923814640524a8d9de2c6db1ee
-SIZE (zbackup-zbackup-1.3_GH0.tar.gz) = 72268
+SHA256 (1.4.1.tar.gz) = a76d4cec6e027462c680ef1bbd143ad4c7d55a160a1474928d8caa792b13fac9
+SIZE (1.4.1.tar.gz) = 86570
diff --git a/sysutils/zbackup/files/patch-compression.cc b/sysutils/zbackup/files/patch-compression.cc
new file mode 100644
index 000000000000..c54882139083
--- /dev/null
+++ b/sysutils/zbackup/files/patch-compression.cc
@@ -0,0 +1,11 @@
+--- compression.cc.orig 2015-06-23 12:18:26.923826000 +0800
++++ compression.cc 2015-06-23 12:19:37.282685000 +0800
+@@ -292,7 +292,7 @@
+ }
+ };
+
+-#include <endian.h>
++#include <machine/endian.h>
+
+ // like NoStreamEnDecoder, but also adds the uncompressed size before the stream
+ //NOTE You should make sure that the compression function doesn't overwrite any
diff --git a/sysutils/zbackup/files/patch-dir.cc b/sysutils/zbackup/files/patch-dir.cc
new file mode 100644
index 000000000000..71aa0a0c2f5d
--- /dev/null
+++ b/sysutils/zbackup/files/patch-dir.cc
@@ -0,0 +1,11 @@
+--- dir.cc.orig 2015-06-23 12:16:14.909394000 +0800
++++ dir.cc 2015-06-23 12:16:22.284741000 +0800
+@@ -103,7 +103,7 @@
+ if ( !entryPtr )
+ return false;
+
+-#ifndef __APPLE__
++#if !defined(__APPLE__) && !defined(__FreeBSD__)
+ if ( fstatat( dirfd( dir ), entry.d_name, &entryStats,
+ AT_SYMLINK_NOFOLLOW ) != 0 )
+ #else
diff --git a/sysutils/zbackup/files/patch-file.cc b/sysutils/zbackup/files/patch-file.cc
new file mode 100644
index 000000000000..81e6d8928588
--- /dev/null
+++ b/sysutils/zbackup/files/patch-file.cc
@@ -0,0 +1,21 @@
+--- file.cc.orig 2014-12-16 20:32:29.000000000 +0800
++++ file.cc 2015-06-23 13:16:37.741129000 +0800
+@@ -6,7 +6,7 @@
+ #include <unistd.h>
+ #include <cerrno>
+ #include <cstring>
+-#ifdef __APPLE__
++#if defined(__APPLE_) || defined(__FreeBSD__)
+ #include <sys/socket.h>
+ #else
+ #include <sys/sendfile.h>
+@@ -67,6 +67,9 @@
+ #ifdef __APPLE__
+ if ( -1 == sendfile(write_fd, read_fd, offset, &stat_buf.st_size, NULL, 0) )
+ throw exCantRename( from + " to " + to );
++ #elif defined(__FreeBSD__)
++ if ( -1 == sendfile(write_fd, read_fd, offset, stat_buf.st_size, NULL, NULL, 0) )
++ throw exCantRename( from + " to " + to );
+ #else
+ if ( -1 == sendfile(write_fd, read_fd, &offset, stat_buf.st_size) )
+ throw exCantRename( from + " to " + to );