aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorian <ian@FreeBSD.org>2015-08-09 09:38:55 +0800
committerian <ian@FreeBSD.org>2015-08-09 09:38:55 +0800
commit995be3ecba62d0597df6ceaf64c073e095951a0c (patch)
tree81e141b2866f65e4ca57f6afd838b3375a02ab22 /sysutils
parent50db10ceb31ac9be9263b3e767fbe156faaea8a5 (diff)
downloadfreebsd-ports-gnome-995be3ecba62d0597df6ceaf64c073e095951a0c.tar.gz
freebsd-ports-gnome-995be3ecba62d0597df6ceaf64c073e095951a0c.tar.zst
freebsd-ports-gnome-995be3ecba62d0597df6ceaf64c073e095951a0c.zip
Use gcc 4.9.2 to cross-compile u-boot for rpi.
Approved by: rpaulo
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-rpi/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/u-boot-rpi/Makefile b/sysutils/u-boot-rpi/Makefile
index 76ca36161303..7809e727f15d 100644
--- a/sysutils/u-boot-rpi/Makefile
+++ b/sysutils/u-boot-rpi/Makefile
@@ -14,9 +14,11 @@ COMMENT= Cross-build U-Boot loader for Raspberry Pi
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc \
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492 \
gsed:${PORTSDIR}/textproc/gsed
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
+
USE_GITHUB= yes
GH_ACCOUNT= gonzoua
GH_PROJECT= u-boot-pi
@@ -43,6 +45,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
MAKE_ARGS+= ARCH=arm \
CROSS_COMPILE=arm-none-eabi- \
HOSTCC=cc \
+ CC=${CROSS_GCC} \
SED=gsed
do-configure: