aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-30 21:41:01 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-30 21:41:01 +0800
commit9a22a31348a8889591997709614bc46675a06f98 (patch)
tree0764c106cb9c02feedd641e411787751d141f0fb /sysutils
parent1642019d219dcb1a19c5cb1c35aff6df95aac81c (diff)
downloadfreebsd-ports-gnome-9a22a31348a8889591997709614bc46675a06f98.tar.gz
freebsd-ports-gnome-9a22a31348a8889591997709614bc46675a06f98.tar.zst
freebsd-ports-gnome-9a22a31348a8889591997709614bc46675a06f98.zip
1: Stagify.
2: add LICENSE. 3: use options helper. Approved by: portmgr@ (blanket approval)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/userneu-devel/Makefile38
-rw-r--r--sysutils/userneu-devel/pkg-plist2
2 files changed, 21 insertions, 19 deletions
diff --git a/sysutils/userneu-devel/Makefile b/sysutils/userneu-devel/Makefile
index 76b3ec8748c0..10a0216ccd5e 100644
--- a/sysutils/userneu-devel/Makefile
+++ b/sysutils/userneu-devel/Makefile
@@ -14,38 +14,38 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}b
MAINTAINER= fehlner@gmx.de
COMMENT= Account management and creation tool
-RUN_DEPENDS= \
- p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- p5-Crypt-RandPasswd>=0:${PORTSDIR}/security/p5-Crypt-RandPasswd
+LICENSE= GPLv2
-USES= perl5
+RUN_DEPENDS= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-RandPasswd>=0:${PORTSDIR}/security/p5-Crypt-RandPasswd
+
+USES= perl5 shebangfix
+SHEBANG_FILES= userneu.pl smbrepair.pl
USE_PERL5= run
NO_BUILD= yes
CONFLICTS= userneu-1.*
SCRIPTS= userneu.pl smbrepair.pl
-MAN5= userneu.conf.5
-MAN8= userneu.8
LDOCS1= BUGS CHANGES CREDITS REQUIREMENTS TODO
LDOCS2= README INSTALL userneu.pod userneu.conf.pod
PORTDOCS= ${LDOCS1} ${LDOCS2}
EXAMPLES= userlist userneu.conf.example
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-install:
- cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN8} ${MANPREFIX}/man/man8
- cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN5} ${MANPREFIX}/man/man5
- cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/sbin
- ${LN} ${PREFIX}/sbin/userneu.pl ${PREFIX}/sbin/userquick
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${LDOCS1} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${LDOCS2} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} userneu.8 ${STAGEDIR}${MANPREFIX}/man/man8
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} userneu.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${PREFIX}/sbin
+ ${LN} -sf userneu.pl ${STAGEDIR}${PREFIX}/sbin/userquick
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${LDOCS1} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${LDOCS2} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/userneu-devel/pkg-plist b/sysutils/userneu-devel/pkg-plist
index 71877e2b4af9..e0efda023ffb 100644
--- a/sysutils/userneu-devel/pkg-plist
+++ b/sysutils/userneu-devel/pkg-plist
@@ -1,3 +1,5 @@
+man/man5/userneu.conf.5.gz
+man/man8/userneu.8.gz
sbin/userneu.pl
sbin/smbrepair.pl
sbin/userquick