aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoreugen <eugen@FreeBSD.org>2018-11-07 03:15:39 +0800
committereugen <eugen@FreeBSD.org>2018-11-07 03:15:39 +0800
commit9f86d040c233f579a117324fe0ab95ec074bdacc (patch)
treef2800ccef38e9e546026ae6940311df6aadb06a3 /sysutils
parentd8b2d80dbfcfb54e607afd1df65643bdebdcd24e (diff)
downloadfreebsd-ports-gnome-9f86d040c233f579a117324fe0ab95ec074bdacc.tar.gz
freebsd-ports-gnome-9f86d040c233f579a117324fe0ab95ec074bdacc.tar.zst
freebsd-ports-gnome-9f86d040c233f579a117324fe0ab95ec074bdacc.zip
New port sysutils/jstest-gtk: simple joystick tester based on Gtk+.
PR: 231218 Submitted by: Ivan Rozhuk <rozhuk.im@gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/jstest-gtk/Makefile35
-rw-r--r--sysutils/jstest-gtk/distinfo3
-rw-r--r--sysutils/jstest-gtk/pkg-descr6
-rw-r--r--sysutils/jstest-gtk/pkg-message7
-rw-r--r--sysutils/jstest-gtk/pkg-plist10
6 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c2e831a66706..86a3929dba84 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -550,6 +550,7 @@
SUBDIR += jkill
SUBDIR += jobd
SUBDIR += jps
+ SUBDIR += jstest-gtk
SUBDIR += jtop
SUBDIR += jtopen
SUBDIR += jvmtop
diff --git a/sysutils/jstest-gtk/Makefile b/sysutils/jstest-gtk/Makefile
new file mode 100644
index 000000000000..18211fbe5658
--- /dev/null
+++ b/sysutils/jstest-gtk/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= jstest-gtk
+PORTVERSION= 20180710
+CATEGORIES= sysutils
+
+MAINTAINER= rozhuk.im@gmail.com
+COMMENT= Simple joystick tester based on Gtk+
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake pkgconfig libtool localbase:ldflags
+USE_GNOME= gtkmm30 libsigc++20
+
+INSTALLS_ICONS= yes
+
+# gitlab variables
+USE_GITLAB= yes
+GL_ACCOUNT= jstest-gtk
+GL_COMMIT= 62f6e2d7d44620e503149510c428df9e004c9f3b
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/src/linux/
+ @${CP} -f ${FILESDIR}/input.h ${WRKSRC}/src/linux/
+ @${CP} -f ${FILESDIR}/input-event-codes.h ${WRKSRC}/src/linux/
+ @${CP} -f ${FILESDIR}/joystick.h ${WRKSRC}/src/linux/
+ @${CP} -f ${FILESDIR}/types.h ${WRKSRC}/src/linux/
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|include_directories(SYSTEM|include_directories("$${CMAKE_CURRENT_SOURCE_DIR}/src" SYSTEM|g' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/sysutils/jstest-gtk/distinfo b/sysutils/jstest-gtk/distinfo
new file mode 100644
index 000000000000..b4031e495cf4
--- /dev/null
+++ b/sysutils/jstest-gtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536313445
+SHA256 (jstest-gtk-jstest-gtk-62f6e2d7d44620e503149510c428df9e004c9f3b_GL0.tar.gz) = 3e0b8b02b818582b6c532feaa35c51e59dee1e38399d861436ad8b7e043fd0fb
+SIZE (jstest-gtk-jstest-gtk-62f6e2d7d44620e503149510c428df9e004c9f3b_GL0.tar.gz) = 81302
diff --git a/sysutils/jstest-gtk/pkg-descr b/sysutils/jstest-gtk/pkg-descr
new file mode 100644
index 000000000000..49a437e9561a
--- /dev/null
+++ b/sysutils/jstest-gtk/pkg-descr
@@ -0,0 +1,6 @@
+jstest-gtk is a simple joystick tester based on Gtk+. It provides you
+with a list of attached joysticks, a way to display which buttons and
+axis are pressed, a way to remap axis and buttons and a way to
+calibrate your joystick.
+
+WWW: https://jstest-gtk.gitlab.io/
diff --git a/sysutils/jstest-gtk/pkg-message b/sysutils/jstest-gtk/pkg-message
new file mode 100644
index 000000000000..ed441254b284
--- /dev/null
+++ b/sysutils/jstest-gtk/pkg-message
@@ -0,0 +1,7 @@
+
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+
+Do not forget install webcamd with joystick support and run it,
+/dev/input/js* device is required.
+
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/sysutils/jstest-gtk/pkg-plist b/sysutils/jstest-gtk/pkg-plist
new file mode 100644
index 000000000000..f2f2dd102b49
--- /dev/null
+++ b/sysutils/jstest-gtk/pkg-plist
@@ -0,0 +1,10 @@
+bin/jstest-gtk
+libexec/jstest-gtk
+man/man1/jstest-gtk.1.gz
+share/applications/jstest-gtk.desktop
+share/icons/hicolor/scalable/apps/jstest-gtk.svg
+%%DATADIR%%/PS3.png
+%%DATADIR%%/generic.png
+%%DATADIR%%/xbox360.png
+%%DATADIR%%/xbox360_small.png
+share/metainfo/jstest-gtk.appdata.xml