aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-07-20 06:04:44 +0800
committerbapt <bapt@FreeBSD.org>2015-07-20 06:04:44 +0800
commitaa8eec71600875a323d98c0f3bce478e51762f05 (patch)
treed14494b07d89b3519c6c3cda6a5387365833c31d /sysutils
parent10d81b14c70a86c9f0ed611b70b63745ed8ed16e (diff)
downloadfreebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.tar.gz
freebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.tar.zst
freebsd-ports-gnome-aa8eec71600875a323d98c0f3bce478e51762f05.zip
Enforce libarchive from ports
This reduces the patching level on some ports and make it simpler to maintainer over all supported version of freebsd
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/archivemount/Makefile3
-rw-r--r--sysutils/rdup/Makefile7
-rw-r--r--sysutils/tracker/Makefile5
3 files changed, 6 insertions, 9 deletions
diff --git a/sysutils/archivemount/Makefile b/sysutils/archivemount/Makefile
index 1ed0853c413b..e23dfa3a12ae 100644
--- a/sysutils/archivemount/Makefile
+++ b/sysutils/archivemount/Makefile
@@ -3,6 +3,7 @@
PORTNAME= archivemount
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.cybernoia.de/software/archivemount/
@@ -10,7 +11,7 @@ MAINTAINER= jirnov@gmail.com
COMMENT= Mount archives with FUSE
GNU_CONFIGURE= yes
-USES= fuse pkgconfig iconv gmake
+USES= fuse pkgconfig iconv gmake libarchive
PLIST_FILES= bin/archivemount \
man/man1/archivemount.1.gz
diff --git a/sysutils/rdup/Makefile b/sysutils/rdup/Makefile
index f4f4c0904469..73616f3405ca 100644
--- a/sysutils/rdup/Makefile
+++ b/sysutils/rdup/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rdup
PORTVERSION= 1.1.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://archive.miek.nl/projects/rdup/
@@ -14,13 +14,10 @@ LICENSE= GPLv3
LIB_DEPENDS= libglib-2.0.so:${PORTSDIR}/devel/glib20 \
libpcre.so:${PORTSDIR}/devel/pcre \
- libarchive.so:${PORTSDIR}/archivers/libarchive \
libnettle.so:${PORTSDIR}/security/nettle
-USES= gmake pkgconfig tar:bzip2
+USES= gmake libarchive pkgconfig tar:bzip2
USE_AUTOTOOLS= autoconf
MAKEFILE= GNUmakefile
-LDFLAGS+= -L${LOCALBASE}/lib
-
.include <bsd.port.mk>
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index 8232e32e4fed..b589487c91dc 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -4,7 +4,7 @@
PORTNAME= tracker
PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
@@ -26,14 +26,13 @@ RUN_DEPENDS= xdg-desktop-icon:${PORTSDIR}/devel/xdg-utils \
PLIST_SUB= TRACKER_VER="1.0"
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libarchive libtool pathfix pkgconfig tar:xz
USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
USE_LDCONFIG= yes
USE_SQLITE= 3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/tracker
CONFIGURE_ARGS= --enable-video-extractor=gstreamer \
--with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \