aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2017-02-21 15:36:59 +0800
committeraraujo <araujo@FreeBSD.org>2017-02-21 15:36:59 +0800
commitac4cd28c8237bddd530d92fac1b7b1fc5edc569e (patch)
treec384deea77549f2ac2dc208539ffe016e6e4e388 /sysutils
parent39d9c54d8172f3d49f127fe15c8714b3ad7064b2 (diff)
downloadfreebsd-ports-gnome-ac4cd28c8237bddd530d92fac1b7b1fc5edc569e.tar.gz
freebsd-ports-gnome-ac4cd28c8237bddd530d92fac1b7b1fc5edc569e.tar.zst
freebsd-ports-gnome-ac4cd28c8237bddd530d92fac1b7b1fc5edc569e.zip
Python client for consul (WWW: http://www.consul.io)
WWW: https://github.com/cablehead/python-consul PR: ports/215396 Submitted by: John Hixson <jhixson@gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-consul/Makefile25
-rw-r--r--sysutils/py-consul/distinfo3
-rw-r--r--sysutils/py-consul/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 717be07301cd..fdc5efbf67e0 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -845,6 +845,7 @@
SUBDIR += py-analyzemft
SUBDIR += py-bcfg2
SUBDIR += py-cdmi
+ SUBDIR += py-consul
SUBDIR += py-croniter
SUBDIR += py-crontab
SUBDIR += py-danzfs
diff --git a/sysutils/py-consul/Makefile b/sysutils/py-consul/Makefile
new file mode 100644
index 000000000000..d341a83ec16e
--- /dev/null
+++ b/sysutils/py-consul/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= py-consul
+PORTVERSION= 0.7.0
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= jhixson@gmail.com
+COMMENT= Python client for consul
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py3-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py3-requests \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six
+
+USE_GITHUB= yes
+GH_ACCOUNT= cablehead
+GH_PROJECT= python-consul
+
+USES= python:3.3+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-consul/distinfo b/sysutils/py-consul/distinfo
new file mode 100644
index 000000000000..937ba1dcca94
--- /dev/null
+++ b/sysutils/py-consul/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1487185160
+SHA256 (cablehead-python-consul-v0.7.0_GH0.tar.gz) = 62f1a8d5d69b7fd3469b0a4fb1c37129efbc18a6bc0e0bc5ac0ff293e240eef9
+SIZE (cablehead-python-consul-v0.7.0_GH0.tar.gz) = 12957501
diff --git a/sysutils/py-consul/pkg-descr b/sysutils/py-consul/pkg-descr
new file mode 100644
index 000000000000..324d40156bc4
--- /dev/null
+++ b/sysutils/py-consul/pkg-descr
@@ -0,0 +1,3 @@
+Python client for consul (WWW: http://www.consul.io)
+
+WWW: https://github.com/cablehead/python-consul