aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2016-03-09 13:06:24 +0800
committerkevlo <kevlo@FreeBSD.org>2016-03-09 13:06:24 +0800
commitae9c48fbfe79f7580b513373e53006394e264dc7 (patch)
treea04f40d25fc32955aa63ec01777da394ae4d96f2 /sysutils
parent5851d08c46f18bf9363c321a1a7a160ebaec915a (diff)
downloadfreebsd-ports-gnome-ae9c48fbfe79f7580b513373e53006394e264dc7.tar.gz
freebsd-ports-gnome-ae9c48fbfe79f7580b513373e53006394e264dc7.tar.zst
freebsd-ports-gnome-ae9c48fbfe79f7580b513373e53006394e264dc7.zip
Cosmetic change.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/freefilesync/Makefile5
-rw-r--r--sysutils/freefilesync/files/patch-zen_file__access.cpp11
-rw-r--r--sysutils/freefilesync/files/patch-zen_shell__execute.h11
-rw-r--r--sysutils/freefilesync/files/patch-zen_tick__count.h11
4 files changed, 5 insertions, 33 deletions
diff --git a/sysutils/freefilesync/Makefile b/sysutils/freefilesync/Makefile
index a7d0d29f6399..dd9352934818 100644
--- a/sysutils/freefilesync/Makefile
+++ b/sysutils/freefilesync/Makefile
@@ -26,5 +26,10 @@ WX_UNICODE= yes
post-patch:
@${REINPLACE_CMD} -e 's/wx-config/${WX_CONFIG:T}/' \
-e 's,g++,${CXX},' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|<sys/vfs.h>|<sys/mount.h>|' \
+ ${WRKDIR}/zen/file_access.cpp
+ @${REINPLACE_CMD} -e 's|WEXITSTATUS||' ${WRKDIR}/zen/shell_execute.h
+ @${REINPLACE_CMD} -e 's|CLOCK_MONOTONIC_RAW|CLOCK_MONOTONIC|' \
+ ${WRKDIR}/zen/tick_count.h
.include <bsd.port.mk>
diff --git a/sysutils/freefilesync/files/patch-zen_file__access.cpp b/sysutils/freefilesync/files/patch-zen_file__access.cpp
deleted file mode 100644
index a5ca03672f80..000000000000
--- a/sysutils/freefilesync/files/patch-zen_file__access.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../zen/file_access.cpp.orig 2016-03-07 22:01:11.201619000 +0800
-+++ ../../zen/file_access.cpp 2016-03-07 22:01:27.906454000 +0800
-@@ -25,7 +25,7 @@
- #endif
-
- #elif defined ZEN_LINUX
-- #include <sys/vfs.h> //statfs
-+ #include <sys/mount.h> //statfs
- #include <sys/time.h> //lutimes
- #ifdef HAVE_SELINUX
- #include <selinux/selinux.h>
diff --git a/sysutils/freefilesync/files/patch-zen_shell__execute.h b/sysutils/freefilesync/files/patch-zen_shell__execute.h
deleted file mode 100644
index faaf0329e6e6..000000000000
--- a/sysutils/freefilesync/files/patch-zen_shell__execute.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../zen/shell_execute.h.orig 2016-03-08 10:01:14.347569000 +0800
-+++ ../../zen/shell_execute.h 2016-03-08 10:01:42.930783000 +0800
-@@ -120,7 +120,7 @@
- {
- //Posix::system - execute a shell command
- int rv = ::system(command.c_str()); //do NOT use std::system as its documentation says nothing about "WEXITSTATUS(rv)", ect...
-- if (rv == -1 || WEXITSTATUS(rv) == 127) //http://linux.die.net/man/3/system "In case /bin/sh could not be executed, the exit status will be that of a command that does exit(127)"
-+ if (rv == -1 ) //http://linux.die.net/man/3/system "In case /bin/sh could not be executed, the exit status will be that of a command that does exit(127)"
- throw FileError(_("Incorrect command line:") + L"\n" + utfCvrtTo<std::wstring>(command));
- }
- else
diff --git a/sysutils/freefilesync/files/patch-zen_tick__count.h b/sysutils/freefilesync/files/patch-zen_tick__count.h
deleted file mode 100644
index 8f601cd6d0a0..000000000000
--- a/sysutils/freefilesync/files/patch-zen_tick__count.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../../zen/tick_count.h.orig 2016-03-07 17:18:11.038986000 +0800
-+++ ../../zen/tick_count.h 2016-03-07 17:20:01.674266000 +0800
-@@ -128,7 +128,7 @@
- #elif defined ZEN_LINUX
- //gettimeofday() seems fine but is deprecated
- timespec now = {};
-- if (::clock_gettime(CLOCK_MONOTONIC_RAW, &now) != 0) //CLOCK_MONOTONIC measures time reliably across processors!
-+ if (::clock_gettime(CLOCK_MONOTONIC, &now) != 0) //CLOCK_MONOTONIC measures time reliably across processors!
- return TickVal();
-
- #elif defined ZEN_MAC