aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-03-05 04:01:38 +0800
committertijl <tijl@FreeBSD.org>2014-03-05 04:01:38 +0800
commitb45471739ad4d464afe950e6d46c8229292655bd (patch)
treebb09e45c468096f2c56339690f428629be98b933 /sysutils
parent6687369a60781490229bd51a870a14d51061146f (diff)
downloadfreebsd-ports-gnome-b45471739ad4d464afe950e6d46c8229292655bd.tar.gz
freebsd-ports-gnome-b45471739ad4d464afe950e6d46c8229292655bd.tar.zst
freebsd-ports-gnome-b45471739ad4d464afe950e6d46c8229292655bd.zip
- Add DOCS and EXAMPLES option.
- Staging. - Replace gcc with $(CC) to fix build on FreeBSD 10. - Add small patch to fix incorrect use of pthread_join (found by clang).
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-gstfs/Makefile22
-rw-r--r--sysutils/fusefs-gstfs/files/patch-xcode.c19
2 files changed, 30 insertions, 11 deletions
diff --git a/sysutils/fusefs-gstfs/Makefile b/sysutils/fusefs-gstfs/Makefile
index 7d9fdc865db9..edb3dc3e911a 100644
--- a/sysutils/fusefs-gstfs/Makefile
+++ b/sysutils/fusefs-gstfs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gstfs
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://bobcopeland.com/gstfs/releases/ \
http://mirror.mcx2.org/
@@ -11,6 +12,8 @@ PKGNAMEPREFIX= fusefs-
MAINTAINER= dhn@FreeBSD.org
COMMENT= On-demand, transcoding filesystem (using GStreamer pipeline)
+OPTIONS_DEFINE= DOCS EXAMPLES
+
USES= fuse pkgconfig
USE_GSTREAMER= yes
@@ -19,17 +22,14 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
PORTEXAMPLES= ogg2mp3.sh mp32wav.sh
-NO_STAGE= yes
+post-patch:
+ @${REINPLACE_CMD} 's/gcc/$$(CC)/' ${WRKSRC}/Makefile
+
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/,} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-gstfs/files/patch-xcode.c b/sysutils/fusefs-gstfs/files/patch-xcode.c
new file mode 100644
index 000000000000..7c90e3dbbb79
--- /dev/null
+++ b/sysutils/fusefs-gstfs/files/patch-xcode.c
@@ -0,0 +1,19 @@
+--- xcode.c.orig 2014-03-04 20:53:11.000000000 +0100
++++ xcode.c 2014-03-04 20:54:14.000000000 +0100
+@@ -41,7 +41,6 @@
+
+ struct pipe_params thread_params;
+ pthread_t thread;
+- void *thread_status;
+
+ pipeline = gst_parse_launch(pipeline_str, &error);
+ if (error)
+@@ -83,7 +82,7 @@
+
+ // close read-side so pipe will terminate
+ close(pipefds[1]);
+- pthread_join(thread, thread_status);
++ pthread_join(thread, NULL);
+
+ return 0;
+ }