aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2005-05-07 11:19:30 +0800
committerperky <perky@FreeBSD.org>2005-05-07 11:19:30 +0800
commitc1a27cae468685403d17f3941a597f38520e0cd7 (patch)
tree0bfa177f99d8ed80c68f63d241057b5ddef5afe7 /sysutils
parentc7017d6b49c7130c1a7f719b95c701539b3b645a (diff)
downloadfreebsd-ports-gnome-c1a27cae468685403d17f3941a597f38520e0cd7.tar.gz
freebsd-ports-gnome-c1a27cae468685403d17f3941a597f38520e0cd7.tar.zst
freebsd-ports-gnome-c1a27cae468685403d17f3941a597f38520e0cd7.zip
Add a patch that fixes a NameError on pkg_genplist.
Reported by: krion
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pkg_trackinst/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/pkg_trackinst/Makefile b/sysutils/pkg_trackinst/Makefile
index e30d3963f533..6e33365107a4 100644
--- a/sysutils/pkg_trackinst/Makefile
+++ b/sysutils/pkg_trackinst/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pkg_trackinst
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://people.freebsd.org/~perky/distfiles/
@@ -16,6 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/installwatch.so:${PORTSDIR}/sysutils/installwatch
USE_PYTHON= 2.4+
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -23,4 +25,8 @@ USE_PYDISTUTILS= yes
IGNORE= requires dynamically-linked base programs
.endif
+post-patch:
+ ${REINPLACE_CMD} 's/\(open_manlist_output()\)/self\.\1/g' \
+ ${WRKSRC}/PkgTrackInst/PlistWriter.py
+
.include <bsd.port.post.mk>