aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-11-06 02:56:10 +0800
committerscrappy <scrappy@FreeBSD.org>2006-11-06 02:56:10 +0800
commitcb25d3907604e2aa1bc27048996adf708bbf1801 (patch)
tree561063930b3888e1cc62e93abdd47b67d05619f9 /sysutils
parent39ab0d7eaa3c18233294f0c70407c39a0edb12f2 (diff)
downloadfreebsd-ports-gnome-cb25d3907604e2aa1bc27048996adf708bbf1801.tar.gz
freebsd-ports-gnome-cb25d3907604e2aa1bc27048996adf708bbf1801.tar.zst
freebsd-ports-gnome-cb25d3907604e2aa1bc27048996adf708bbf1801.zip
clean up pkg-install a bit to avoid generating an error when
/etc/periodic.conf doesn't exist ... Submitted by: Paul Dekkers <Paul.Dekkers@surfnet.nl>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bsdstats/Makefile2
-rw-r--r--sysutils/bsdstats/pkg-install14
2 files changed, 14 insertions, 2 deletions
diff --git a/sysutils/bsdstats/Makefile b/sysutils/bsdstats/Makefile
index 69114a8ea02d..4cc82582a508 100644
--- a/sysutils/bsdstats/Makefile
+++ b/sysutils/bsdstats/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bsdstats
PORTVERSION= 4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
DISTFILES=
diff --git a/sysutils/bsdstats/pkg-install b/sysutils/bsdstats/pkg-install
index f4e5450de907..3ab8de033995 100644
--- a/sysutils/bsdstats/pkg-install
+++ b/sysutils/bsdstats/pkg-install
@@ -33,7 +33,19 @@ yesno() {
}
if [ ":$2" = ":POST-INSTALL" ]; then
- if [ `grep monthly_statistics /etc/periodic.conf | wc -l` = 0 ]; then
+ if [ -f "/etc/periodic.conf" ]; then
+ if [ `grep monthly_statistics /etc/periodic.conf | wc -l` = 0 ]; then
+ if yesno "Would you like to activate monthly reporting in /etc/periodic.conf" n; then
+ echo "monthly_statistics_enable=\"YES\"" >> /etc/periodic.conf
+ if yesno "Would you like to send a list of installed hardware as well" n; then
+ echo "monthly_statistics_report_devices=\"YES\"" >> /etc/periodic.conf
+ fi
+ if yesno "Would you like to run it now" y; then
+ /usr/local/etc/periodic/monthly/300.statistics
+ fi
+ fi
+ fi
+ elif [ ! -f "/etc/periodic.conf" ]; then
if yesno "Would you like to activate monthly reporting in /etc/periodic.conf" n; then
echo "monthly_statistics_enable=\"YES\"" >> /etc/periodic.conf
if yesno "Would you like to send a list of installed hardware as well" n; then