aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-28 20:57:40 +0800
committermiwi <miwi@FreeBSD.org>2008-12-28 20:57:40 +0800
commitcec0c004babecf8d5f36e2a7d2d88d1a920e5c0b (patch)
tree558075e36f4091d3a0f5054790539e8fc8b07d6a /sysutils
parentf5d7aa77004fa7f3655a51d64351ffa936d37139 (diff)
downloadfreebsd-ports-gnome-cec0c004babecf8d5f36e2a7d2d88d1a920e5c0b.tar.gz
freebsd-ports-gnome-cec0c004babecf8d5f36e2a7d2d88d1a920e5c0b.tar.zst
freebsd-ports-gnome-cec0c004babecf8d5f36e2a7d2d88d1a920e5c0b.zip
GSTFS is a filesystem for on-demand transcoding of music files
between different formats. It utilizes the gstreamer library for conversion so any formats supported by gstreamer should also be supported by gstfs. The filesystem's only requirement is that the gstreamer pipeline begin with a filesrc with the name "_source" and end with an fdsink with the name "_dest". The filesystem will automatically substitute the filename and fd number in these pipelines. WWW: http://bobcopeland.com/gstfs/ PR: ports/129984 Submitted by: Dennis Herrmann <adox at mcx2.org>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-gstfs/Makefile41
-rw-r--r--sysutils/fusefs-gstfs/distinfo3
-rw-r--r--sysutils/fusefs-gstfs/pkg-descr10
4 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2a976cd11d80..1700d467d6b2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -236,6 +236,7 @@
SUBDIR += fusefs-encfs
SUBDIR += fusefs-funionfs
SUBDIR += fusefs-gnome-vfs
+ SUBDIR += fusefs-gstfs
SUBDIR += fusefs-gunzip
SUBDIR += fusefs-httpfs
SUBDIR += fusefs-kmod
diff --git a/sysutils/fusefs-gstfs/Makefile b/sysutils/fusefs-gstfs/Makefile
new file mode 100644
index 000000000000..5c831be6010a
--- /dev/null
+++ b/sysutils/fusefs-gstfs/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: fusefs-gstfs
+# Date created: 2008-12-26
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstfs
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://bobcopeland.com/gstfs/releases/ \
+ http://mirror.mcx2.org/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= adox@mcx2.org
+COMMENT= On-demand, transcoding filesystem (using GStreamer pipeline)
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+USE_GNOME= pkgconfig
+USE_GSTREAMER= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README
+PORTEXAMPLES= ogg2mp3.sh mp32wav.sh
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-gstfs/distinfo b/sysutils/fusefs-gstfs/distinfo
new file mode 100644
index 000000000000..e037fe41dd1a
--- /dev/null
+++ b/sysutils/fusefs-gstfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (gstfs-0.1.tar.gz) = 2cd1e2f6d29424baf761b9aa96e45a8a
+SHA256 (gstfs-0.1.tar.gz) = 5b159e537a87024fa76267f076784fe038a09809c53ad863ed6e52df7d32be35
+SIZE (gstfs-0.1.tar.gz) = 7689
diff --git a/sysutils/fusefs-gstfs/pkg-descr b/sysutils/fusefs-gstfs/pkg-descr
new file mode 100644
index 000000000000..147be24f002d
--- /dev/null
+++ b/sysutils/fusefs-gstfs/pkg-descr
@@ -0,0 +1,10 @@
+GSTFS is a filesystem for on-demand transcoding of music files
+between different formats. It utilizes the gstreamer library for
+conversion so any formats supported by gstreamer should also be
+supported by gstfs. The filesystem's only requirement is that the
+gstreamer pipeline begin with a filesrc with the name "_source"
+and end with an fdsink with the name "_dest". The filesystem will
+automatically substitute the filename and fd number in these
+pipelines.
+
+WWW: http://bobcopeland.com/gstfs/