aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-06-23 13:28:33 +0800
committerlinimon <linimon@FreeBSD.org>2006-06-23 13:28:33 +0800
commitd07f774404698461920aade685d87bb19fed0c89 (patch)
treefacc98f33f24c5498627d0563e2aef594bf8d3bd /sysutils
parent4ceb770b50d335a7b05bcee31aeed96ff18d5d73 (diff)
downloadfreebsd-ports-gnome-d07f774404698461920aade685d87bb19fed0c89.tar.gz
freebsd-ports-gnome-d07f774404698461920aade685d87bb19fed0c89.tar.zst
freebsd-ports-gnome-d07f774404698461920aade685d87bb19fed0c89.zip
Remove code remnants that test for 3.X and earlier releases of FreeBSD.
The bsd.*.mk architecture has not supported these antique releases for quite some time. Hat: portmgr
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cd-write/Makefile8
-rw-r--r--sysutils/gkrellm/Makefile4
-rw-r--r--sysutils/gkrellm2/Makefile4
-rw-r--r--sysutils/pkill/Makefile9
4 files changed, 1 insertions, 24 deletions
diff --git a/sysutils/cd-write/Makefile b/sysutils/cd-write/Makefile
index 9e0b133475bc..a1883de5fe9b 100644
--- a/sysutils/cd-write/Makefile
+++ b/sysutils/cd-write/Makefile
@@ -19,12 +19,6 @@ USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/cd-write
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300000
-IGNORE= "FreeBSD 3.X or greater is required to support this port"
-.endif
-
PLIST_FILES= bin/cd-write
pre-build:
@@ -39,4 +33,4 @@ pre-build:
post-install:
@PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/gkrellm/Makefile b/sysutils/gkrellm/Makefile
index 7273bf68bad2..d3531685665e 100644
--- a/sysutils/gkrellm/Makefile
+++ b/sysutils/gkrellm/Makefile
@@ -42,11 +42,7 @@ PORTDOCS= COPYRIGHT README Themes.html
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 300000
-ALL_TARGET= freebsd2
-.else
ALL_TARGET= freebsd
-.endif
BINGRP= kmem
.if defined(WITH_SENSOR)
diff --git a/sysutils/gkrellm2/Makefile b/sysutils/gkrellm2/Makefile
index ed5a1a181119..65d70dca6c31 100644
--- a/sysutils/gkrellm2/Makefile
+++ b/sysutils/gkrellm2/Makefile
@@ -81,11 +81,7 @@ MAN1PREFIX= ${X11BASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 300000
-ALL_TARGET= freebsd2
-.else
ALL_TARGET= freebsd
-.endif
INSTALL_TARGET= install_freebsd
MAKE_ENV+= INSTALLROOT=${X11BASE} INSTALLDIR=${X11BASE}/bin \
diff --git a/sysutils/pkill/Makefile b/sysutils/pkill/Makefile
index c7a11c9a8e26..5953fd5ff44d 100644
--- a/sysutils/pkill/Makefile
+++ b/sysutils/pkill/Makefile
@@ -31,17 +31,8 @@ IGNORE= "is included in the base system"
DISTNAME= ${PORTNAME}-current-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-current
.else
-. if ${OSVERSION} <= 300000
-MAKE_ENV+= NEED_KMEM=1
-. endif
DISTNAME= ${PORTNAME}-stable-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-stable
.endif
-post-install:
-.if ${OSVERSION} <= 300000
- @${CHGRP} kmem ${PREFIX}/bin/pkill
- @${CHMOD} 2555 ${PREFIX}/bin/pkill
-.endif
-
.include <bsd.port.post.mk>