aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2016-08-18 09:00:51 +0800
committerkevlo <kevlo@FreeBSD.org>2016-08-18 09:00:51 +0800
commitd41faf5b405ac380877d87c044d67bcdcdc31ef8 (patch)
treed371a398455e31c5a49c657356e1b9bc1de757fb /sysutils
parent52ca18bee11be08986104bdffc482cb4627c58cc (diff)
downloadfreebsd-ports-gnome-d41faf5b405ac380877d87c044d67bcdcdc31ef8.tar.gz
freebsd-ports-gnome-d41faf5b405ac380877d87c044d67bcdcdc31ef8.tar.zst
freebsd-ports-gnome-d41faf5b405ac380877d87c044d67bcdcdc31ef8.zip
Fix BROKEN for < 10.3. While here drop maintainership.
PR: 211943 Submitted by: amdmi3
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/freefilesync/Makefile13
-rw-r--r--sysutils/freefilesync/files/patch-zen_file__access.cpp26
2 files changed, 9 insertions, 30 deletions
diff --git a/sysutils/freefilesync/Makefile b/sysutils/freefilesync/Makefile
index da0618a43e54..ce84653e9d31 100644
--- a/sysutils/freefilesync/Makefile
+++ b/sysutils/freefilesync/Makefile
@@ -1,3 +1,4 @@
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
PORTNAME= freefilesync
@@ -7,14 +8,12 @@ MASTER_SITES= http://www.freefilesync.org/download/ \
http://www.freefilesync.org/archive/
DISTNAME= FreeFileSync_${PORTVERSION}_Source
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Backup software to synchronize files and folders
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
BUILD_DEPENDS= ${LOCALBASE}/include/zenxml/xml.h:textproc/zenxml
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libnotify.so:devel/libnotify
@@ -29,6 +28,12 @@ USES= compiler:c++14-lang dos2unix gmake pkgconfig zip
USE_LDCONFIG= yes
USE_WX= 3.0+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1003000
+BROKEN= does not build on FreeBSD < 10.3 (lack of futimens(2))
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/wx-config/$${WX_CONFIG:T}/' \
-e 's,g++,$${CXX},' ${WRKSRC}/Makefile
@@ -38,4 +43,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|CLOCK_MONOTONIC_RAW|CLOCK_MONOTONIC|' \
${WRKDIR}/zen/tick_count.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/freefilesync/files/patch-zen_file__access.cpp b/sysutils/freefilesync/files/patch-zen_file__access.cpp
deleted file mode 100644
index c642df738d24..000000000000
--- a/sysutils/freefilesync/files/patch-zen_file__access.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- ../../zen/file_access.cpp.orig 2016-01-11 12:13:10 UTC
-+++ ../../zen/file_access.cpp
-@@ -877,6 +877,15 @@ void setFileTimeRaw(const Zstring& fileP
- //https://sourceforge.net/p/freefilesync/discussion/open-discussion/thread/218564cf/
- newTimes[1] = modTime; //modification time
-
-+#if defined(__FreeBSD__)
-+// only defines __FreeBSD_version
-+#include <osreldate.h>
-+#endif
-+
-+#if (defined(__FreeBSD__) && (__FreeBSD_version < 1002506 || \
-+ (__FreeBSD_version >= 1100000 && __FreeBSD_version < 1100056)))
-+ throw ErrorLinuxFallbackToUtimes(L"");
-+#else
- //=> using open()/futimens() for regular files and utimensat(AT_SYMLINK_NOFOLLOW) for symlinks is consistent with "cp" and "touch"!
- if (procSl == ProcSymlink::FOLLOW)
- {
-@@ -898,6 +907,7 @@ void setFileTimeRaw(const Zstring& fileP
- if (::utimensat(AT_FDCWD, filePath.c_str(), newTimes, AT_SYMLINK_NOFOLLOW) != 0)
- THROW_LAST_FILE_ERROR(replaceCpy(_("Cannot write modification time of %x."), L"%x", fmtPath(filePath)), L"utimensat");
- }
-+#endif
- }
-
-