aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-24 00:33:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-24 00:33:46 +0800
commitd8ddaccc2f9bd98848eae7f233c646d1813fc40c (patch)
tree4089b4fde25254204b2307eb26945cab19667814 /sysutils
parent52fd6f9720a93a36ea5cde6ca55aefad9d6f6f37 (diff)
downloadfreebsd-ports-gnome-d8ddaccc2f9bd98848eae7f233c646d1813fc40c.tar.gz
freebsd-ports-gnome-d8ddaccc2f9bd98848eae7f233c646d1813fc40c.tar.zst
freebsd-ports-gnome-d8ddaccc2f9bd98848eae7f233c646d1813fc40c.zip
- Fix library installation
- Check OPSYS along with OSVERSION
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/hpacucli/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/hpacucli/Makefile b/sysutils/hpacucli/Makefile
index 80be0039c9d0..5cf191cabeeb 100644
--- a/sysutils/hpacucli/Makefile
+++ b/sysutils/hpacucli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hpacucli
PORTVERSION= 7.50
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= LOCAL/brooks
@@ -24,7 +24,7 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${APP_PREFIX}
- ${CP} -a ${WRKSRC}/lib* ${STAGEDIR}${APP_PREFIX}
+ ${INSTALL_LIB} ${WRKSRC}/lib*.so ${STAGEDIR}${APP_PREFIX}
${INSTALL_PROGRAM} ${WRKSRC}/.${PORTNAME} ${STAGEDIR}${PREFIX}/libexec
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
@@ -32,7 +32,7 @@ do-install:
.if ${ARCH} == amd64
USE_LDCONFIG32= ${APP_PREFIX}
-. if ${OSVERSION} < 1000019
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000019
BROKEN= currently does not work on amd64 (see PR ports/128288)
. endif
.else