aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-07-13 19:38:47 +0800
committerrakuco <rakuco@FreeBSD.org>2014-07-13 19:38:47 +0800
commitde90928063ef6634d927a3978748bb78bf6409cd (patch)
treeda9d658fb55fca35a9861867e7b5825b6c2a57fc /sysutils
parent21df2b416f9ccb72c5c5343d8ae92939602826c5 (diff)
downloadfreebsd-ports-gnome-de90928063ef6634d927a3978748bb78bf6409cd.tar.gz
freebsd-ports-gnome-de90928063ef6634d927a3978748bb78bf6409cd.tar.zst
freebsd-ports-gnome-de90928063ef6634d927a3978748bb78bf6409cd.zip
Update to 10.0.6.
Changes for 10.0.6: cbsd taskd: daemon for internal tasks bconstruct-tui: menubox for vm_os_type and get_vm_profiles bhyve: add support for install FreeBSD guest from ISO bhyve: implement other method for POPCNT checking repo: newjname as argument for alternative name of stored jail PR: 191844 Submitted by: olevole@olevole.ru (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cbsd/Makefile13
-rw-r--r--sysutils/cbsd/distinfo4
-rw-r--r--sysutils/cbsd/files/cbsdd.in45
-rw-r--r--sysutils/cbsd/pkg-plist-chunk8
4 files changed, 46 insertions, 24 deletions
diff --git a/sysutils/cbsd/Makefile b/sysutils/cbsd/Makefile
index 7702fb6a30b6..791fc66a5f7b 100644
--- a/sysutils/cbsd/Makefile
+++ b/sysutils/cbsd/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cbsd
-PORTVERSION= 10.0.5
-PORTREVISION= 2
+PORTVERSION= 10.0.6
CATEGORIES= sysutils
MAINTAINER= olevole@olevole.ru
@@ -18,7 +17,7 @@ LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2 \
USE_GITHUB= yes
GH_ACCOUNT= olevole
-GH_COMMIT= 01f481c
+GH_COMMIT= cac57bb
USE_RC_SUBR= cbsdd cbsdrsyncd
@@ -40,7 +39,15 @@ IGNORE= does not support FreeBSD versions < 9.1
RUN_DEPENDS+= sysrc:${PORTSDIR}/sysutils/sysrc
.endif
+do-install:
+ @${ECHO} "Installing in ${CBSD_HOME}"
+ ${MKDIR} ${STAGEDIR}${CBSD_HOME}
+ ${CP} -R ${WRKSRC}/* ${STAGEDIR}${CBSD_HOME}
+ @${INSTALL_MAN} ${WRKSRC}/man/cbsd.8 ${STAGEDIR}${PREFIX}/man/man8/cbsd.8
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/cbsdsh/cbsd ${STAGEDIR}${PREFIX}/bin
+
post-install:
+ ${CAT} ${PKGDIR}/pkg-plist-chunk > ${TMPPLIST} ;
@${FIND} -s ${STAGEDIR}${CBSD_HOME} -not -type d | ${SORT} | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
@${FIND} ${STAGEDIR}${CBSD_HOME} -type d | ${SORT} -r | \
diff --git a/sysutils/cbsd/distinfo b/sysutils/cbsd/distinfo
index fab268b4a16d..8b9a040e2183 100644
--- a/sysutils/cbsd/distinfo
+++ b/sysutils/cbsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cbsd-10.0.5.tar.gz) = d34b61ed9056ce8df6db6f283c6a78185f41ce25bde8d3f7321a12de9a041676
-SIZE (cbsd-10.0.5.tar.gz) = 358951
+SHA256 (cbsd-10.0.6.tar.gz) = 378a0f04abb562eb21b985034f4b74d0ff2e57161800b3c9e748e0ff4633736a
+SIZE (cbsd-10.0.6.tar.gz) = 383249
diff --git a/sysutils/cbsd/files/cbsdd.in b/sysutils/cbsd/files/cbsdd.in
index 25d71789c695..eeda220ad335 100644
--- a/sysutils/cbsd/files/cbsdd.in
+++ b/sysutils/cbsd/files/cbsdd.in
@@ -20,28 +20,28 @@ export NO_CBSD_HISTORY=yes
globalconf=${cbsd_globalconf:-"${workdir}/cbsd.conf"}
if [ ! -f ${globalconf} ]; then
- echo "cbsd: no such ${globalconf}";
- exit 1
+ echo "cbsd: no such ${globalconf}";
+ exit 1
fi
if [ ! -f ${inventory} ]; then
- echo "cbsd: no such ${inventory}";
- exit 1
+ echo "cbsd: no such ${inventory}";
+ exit 1
fi
if [ ! -f ${mdtools} ]; then
- echo "cbsd: no such ${mdtools}";
- exit 1
+ echo "cbsd: no such ${mdtools}";
+ exit 1
fi
if [ ! -f ${subr} ]; then
- echo "cbsd: no such ${subr}";
- exit 1
+ echo "cbsd: no such ${subr}";
+ exit 1
fi
if [ ! -f ${localcbsdconf} ]; then
- echo "cbsd: no such ${localcbsdconf}";
- exit 1
+ echo "cbsd: no such ${localcbsdconf}";
+ exit 1
fi
. ${globalconf}
@@ -53,25 +53,32 @@ fi
start_precmd=${name}_prestart
stop_precmd=${name}_prestop
+stop_cmd=${name}_stop
-command="${sbindir}/cbsdd"
+command="${toolsdir}/cbsdd"
pidfile="/var/run/$name.pid"
+command_args="&"
cbsdd_prestart() {
- find ${ftmpdir} -depth 1 -maxdepth 1 -type f -exec rm -f {} \;
- %%PREFIX%%/bin/cbsd sysinv mode=update
- %%PREFIX%%/bin/cbsd netinv
+ /usr/bin/find ${ftmpdir} -depth 1 -maxdepth 1 -type f -exec rm -f {} \;
+ %%PREFIX%%/bin/cbsd sysinv mode=update
+ %%PREFIX%%/bin/cbsd netinv
- . ${inventory}
+ . ${inventory}
- [ -n "$nat_enable" ] && %%PREFIX%%/bin/cbsd naton
- /usr/sbin/daemon ${rcddir}/jails-astart start
+ [ -n "$nat_enable" ] && %%PREFIX%%/bin/cbsd naton
+ /usr/sbin/daemon ${rcddir}/jails-astart start
}
cbsdd_prestop()
{
- ${rcddir}/jails-astart stop
- [ -n "${nat_enable}" ] && %%PREFIX%%/bin/cbsd natoff
+ ${rcddir}/jails-astart stop
+ [ -n "${nat_enable}" ] && %%PREFIX%%/bin/cbsd natoff
+}
+
+cbsdd_stop()
+{
+ [ -f "${pidfile}" ] && kill -9 $( cat ${pidfile} )
}
run_rc_command "$1"
diff --git a/sysutils/cbsd/pkg-plist-chunk b/sysutils/cbsd/pkg-plist-chunk
new file mode 100644
index 000000000000..5eb329e8740a
--- /dev/null
+++ b/sysutils/cbsd/pkg-plist-chunk
@@ -0,0 +1,8 @@
+@mode 500
+@group cbsd
+@owner cbsd
+bin/cbsd
+@owner
+@group
+@mode
+man/man8/cbsd.8.gz