aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2015-02-07 21:04:38 +0800
committerbofh <bofh@FreeBSD.org>2015-02-07 21:04:38 +0800
commite30de8203744398208670f01e83e66b62d5de1be (patch)
tree15143c9add5265659fb88e7abdc7b33b8ba7e15c /sysutils
parentb42098205d6b651cdcb6e579ddae5f76d1542d1e (diff)
downloadfreebsd-ports-gnome-e30de8203744398208670f01e83e66b62d5de1be.tar.gz
freebsd-ports-gnome-e30de8203744398208670f01e83e66b62d5de1be.tar.zst
freebsd-ports-gnome-e30de8203744398208670f01e83e66b62d5de1be.zip
sysutils/avfs: Revive and update version 0.9.9=>1.0.2
- Unbreak - Pass maintainership to submitter - Add LICENSE(LGPL20 GPLv2) - Remove OPTIONS LIBRARY to make default as most of the dependent ports require the library - Make proper use of OPTIONSNG to declutter ${PORT_OPTIONS:M*} PR: 196942 Differential Revision: https://reviews.freebsd.org/D1795 Submitted by: mp39590@gmail.com Approved by: marino(mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/avfs/Makefile35
-rw-r--r--sysutils/avfs/distinfo2
-rw-r--r--sysutils/avfs/files/patch-scripts_mountavs11
-rw-r--r--sysutils/avfs/files/patch-scripts_umountavs16
-rw-r--r--sysutils/avfs/files/patch-src_Makefile.in11
-rw-r--r--sysutils/avfs/pkg-descr10
-rw-r--r--sysutils/avfs/pkg-plist50
8 files changed, 136 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index d67477b6a3e7..8ace7fbe2bc4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -48,6 +48,7 @@
SUBDIR += automount
SUBDIR += automounter
SUBDIR += autopsy
+ SUBDIR += avfs
SUBDIR += azure-agent
SUBDIR += b43-fwcutter
SUBDIR += backuppc
diff --git a/sysutils/avfs/Makefile b/sysutils/avfs/Makefile
new file mode 100644
index 000000000000..a534e91d3d85
--- /dev/null
+++ b/sysutils/avfs/Makefile
@@ -0,0 +1,35 @@
+# Created by: Evgeny Zhirnov <jirnov@gmail.com>
+# $FreeBSD$
+
+PORTNAME= avfs
+PORTVERSION= 1.0.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/avf/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= mp39590@gmail.com
+COMMENT= Virtual File System library
+
+# FUSE daemon is licensed as GPLv2, shared library is LGPLv2
+LICENSE= LGPL20 GPLv2
+LICENSE_COMB= multi
+
+USES= libtool pkgconfig tar:bz2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DEBUG FUSE
+OPTIONS_SUB= yes
+DEBUG_CONFIGURE_ENABLE= debug
+FUSE_CONFIGURE_ENABLE= fuse
+FUSE_USES= fuse shebangfix
+FUSE_RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFUSE}
+SHEBANG_FILES= scripts/umountavfs scripts/mountavfs
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/avfs/distinfo b/sysutils/avfs/distinfo
new file mode 100644
index 000000000000..72d4bab6ad42
--- /dev/null
+++ b/sysutils/avfs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (avfs-1.0.2.tar.bz2) = 52693953e8290281d441a898040c5ac2989f11bc1fcb83ca5063c37a125a1c9a
+SIZE (avfs-1.0.2.tar.bz2) = 723051
diff --git a/sysutils/avfs/files/patch-scripts_mountavs b/sysutils/avfs/files/patch-scripts_mountavs
new file mode 100644
index 000000000000..978bb80acb65
--- /dev/null
+++ b/sysutils/avfs/files/patch-scripts_mountavs
@@ -0,0 +1,11 @@
+--- scripts/mountavfs.orig 2015-02-07 16:14:05.773404035 +0600
++++ scripts/mountavfs 2015-02-07 16:14:56.488399333 +0600
+@@ -14,7 +14,7 @@
+ MntDir=${HOME}/.avfs
+ fi
+
+-grep -qE "avfsd ${MntDir}" /proc/mounts || {
++mount -p | grep -qE "${MntDir}.*fusefs" || {
+ if [ ! -e "$MntDir" ]; then
+ mkdir -p "$MntDir"
+ fi
diff --git a/sysutils/avfs/files/patch-scripts_umountavs b/sysutils/avfs/files/patch-scripts_umountavs
new file mode 100644
index 000000000000..821db7514ee2
--- /dev/null
+++ b/sysutils/avfs/files/patch-scripts_umountavs
@@ -0,0 +1,16 @@
+--- scripts/umountavfs.orig 2015-02-07 16:14:17.372402564 +0600
++++ scripts/umountavfs 2015-02-07 16:15:29.270400346 +0600
+@@ -14,11 +14,11 @@
+ MntDir="${HOME}/.avfs"
+ fi
+
+-grep -qE "${MntDir}.*avfsd" /proc/mounts && {
++mount -p | grep -qE "${MntDir}.*fusefs" && {
+ echo unMounting AVFS on $MntDir...
+ if type -p fusermount > /dev/null 2>&1 ; then
+ fusermount -u -z "$MntDir"
+ else
+- umount -l "$MntDir"
++ umount "$MntDir"
+ fi
+ }
diff --git a/sysutils/avfs/files/patch-src_Makefile.in b/sysutils/avfs/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..be9de093fdfc
--- /dev/null
+++ b/sysutils/avfs/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2015-02-06 18:18:35.275843385 +0600
++++ src/Makefile.in 2015-02-06 18:19:48.038837253 +0600
+@@ -680,7 +680,7 @@
+ tags tags-am uninstall uninstall-am
+
+
+-$(srcdir)/utils.c: info.h
++utils.c: info.h
+
+ info.h:
+ rm -f info.h
diff --git a/sysutils/avfs/pkg-descr b/sysutils/avfs/pkg-descr
new file mode 100644
index 000000000000..19639f4a868c
--- /dev/null
+++ b/sysutils/avfs/pkg-descr
@@ -0,0 +1,10 @@
+AVFS is a system, which enables all programs to look inside gzip, tar,
+zip, etc. files or view remote (ftp, http, dav, etc.) files, without
+recompiling the programs.
+
+Shared library and FUSE daemon are provided.
+
+AVFS is (C) under the GNU GPL. The shared library supporting AVFS with
+LD_PRELOAD is (C) under the GNU LGPL.
+
+WWW: http://avf.sourceforge.net/
diff --git a/sysutils/avfs/pkg-plist b/sysutils/avfs/pkg-plist
new file mode 100644
index 000000000000..1871bc77ff28
--- /dev/null
+++ b/sysutils/avfs/pkg-plist
@@ -0,0 +1,50 @@
+bin/avfs-config
+%%FUSE%%bin/avfsd
+bin/davpass
+bin/ftppass
+%%FUSE%%bin/mountavfs
+%%FUSE%%bin/umountavfs
+include/avfs.h
+include/virtual.h
+lib/avfs/extfs/README
+lib/avfs/extfs/a
+lib/avfs/extfs/apt
+lib/avfs/extfs/audio
+lib/avfs/extfs/bpp
+lib/avfs/extfs/deb
+lib/avfs/extfs/deba
+lib/avfs/extfs/debd
+lib/avfs/extfs/dpkg
+lib/avfs/extfs/extfs.ini
+lib/avfs/extfs/ftplist
+lib/avfs/extfs/hp48
+lib/avfs/extfs/iso9660
+lib/avfs/extfs/lslR
+lib/avfs/extfs/mailfs
+lib/avfs/extfs/patchfs
+lib/avfs/extfs/rpm
+lib/avfs/extfs/rpms
+lib/avfs/extfs/trpm
+lib/avfs/extfs/u7z
+lib/avfs/extfs/uace
+lib/avfs/extfs/uadf
+lib/avfs/extfs/uar
+lib/avfs/extfs/uarc
+lib/avfs/extfs/uarj
+lib/avfs/extfs/uc1541
+lib/avfs/extfs/ucab
+lib/avfs/extfs/ucpio
+lib/avfs/extfs/udar
+lib/avfs/extfs/uha
+lib/avfs/extfs/uimg
+lib/avfs/extfs/ulha
+lib/avfs/extfs/upp
+lib/avfs/extfs/urar
+lib/avfs/extfs/uxdms
+lib/avfs/extfs/uxpk
+lib/avfs/extfs/uzip
+lib/avfs/extfs/uzoo
+lib/libavfs.a
+lib/libavfs.so
+lib/libavfs.so.0
+lib/libavfs.so.0.0.2