aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-26 23:49:55 +0800
committermiwi <miwi@FreeBSD.org>2007-02-26 23:49:55 +0800
commite587d49a0124eee08372ef4449ca5515fb3aac25 (patch)
tree31b07e0f8cd2367949b6295acca27ecac88a7d33 /sysutils
parentae6aca349018971cfcfa96c5d1387be947b65cb3 (diff)
downloadfreebsd-ports-gnome-e587d49a0124eee08372ef4449ca5515fb3aac25.tar.gz
freebsd-ports-gnome-e587d49a0124eee08372ef4449ca5515fb3aac25.tar.zst
freebsd-ports-gnome-e587d49a0124eee08372ef4449ca5515fb3aac25.zip
This will act on any cronfile it is pointed at. For it to run the command,
the last or next time it will be will have to be within a minute and 15 seconds. For most usages, you will want to have the hour and minute set to *. This allows a user to do something how ever many times they want any time during the period it is active. After running through every entry in the crontab, it then exits. Why not cron? You can have cron open opera or the like on a specific display by either switch or enviromental options, but it will always open it. This allows you to open it any time along the point it is active. PR: ports/109120 Submitted by: Zane C. Bowers
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/comiccron/Makefile47
-rw-r--r--sysutils/comiccron/distinfo3
-rw-r--r--sysutils/comiccron/pkg-descr13
4 files changed, 64 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 695e8305cede..28d6c2519492 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -90,6 +90,7 @@
SUBDIR += cog
SUBDIR += colorize
SUBDIR += comconsole
+ SUBDIR += comiccron
SUBDIR += conky
SUBDIR += consolehm
SUBDIR += contool
diff --git a/sysutils/comiccron/Makefile b/sysutils/comiccron/Makefile
new file mode 100644
index 000000000000..481019874e68
--- /dev/null
+++ b/sysutils/comiccron/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: comiccron
+# Date created: 12 February 2007
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= comiccron
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils deskutils
+DISTNAME= comiccron-${PORTVERSION}.pl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A cron like tool that performs a single pass on a cronfile
+
+RUN_DEPENDS= ${SITE_PERL}/DateTime/Event/Cron.pm:${PORTSDIR}/devel/p5-DateTime-Event-Cron \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime/Duration.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+
+MASTER_SITES= http://cpan.org/authors/id/V/VV/VVELOX/
+
+MAN1= comiccron.1
+
+PLIST_FILES= bin/comiccron
+
+post-extract:
+ @${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+#nothing to configure
+do-configure:
+ @${ECHO} -n
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=comiccron --center="comiccron user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${CP} -v ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/comiccron
+ @${CP} -v ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/${PORTNAME}.1
+ @${CHMOD} +x ${PREFIX}/bin/comiccron
+
+.include <bsd.port.mk>
diff --git a/sysutils/comiccron/distinfo b/sysutils/comiccron/distinfo
new file mode 100644
index 000000000000..cb451aa39d42
--- /dev/null
+++ b/sysutils/comiccron/distinfo
@@ -0,0 +1,3 @@
+MD5 (comiccron-1.0.0.pl) = f4d21cbfe3c6788a613d14a414df2656
+SHA256 (comiccron-1.0.0.pl) = bd98c9ed814296f7b2e8bd5c05b18400f72c405eedf97d32a9a93e5f0fd46a56
+SIZE (comiccron-1.0.0.pl) = 6969
diff --git a/sysutils/comiccron/pkg-descr b/sysutils/comiccron/pkg-descr
new file mode 100644
index 000000000000..3abacfd4fa36
--- /dev/null
+++ b/sysutils/comiccron/pkg-descr
@@ -0,0 +1,13 @@
+This will act on any cronfile it is pointed at. For it to run the command,
+the last or next time it will be will have to be within a minute and 15
+seconds. For most usages, you will want to have the hour and minute set
+to *. This allows a user to do something how ever many times they want any
+time during the period it is active.
+
+After running through every entry in the crontab, it then exits.
+
+Why not cron?
+
+You can have cron open opera or the like on a specific display by either
+switch or enviromental options, but it will always open it. This allows
+you to open it any time along the point it is active.