aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-08-14 16:30:58 +0800
committersobomax <sobomax@FreeBSD.org>2001-08-14 16:30:58 +0800
commit0411f7ca042b303c127b865b73540360aa094673 (patch)
tree568b5498ca53350b88367a6fa58d5872f5fa1d0c /sysutils
parentdeba1820c8e99032d1e1c0c6093f5b5e78a9d5c1 (diff)
downloadfreebsd-ports-gnome-0411f7ca042b303c127b865b73540360aa094673.tar.gz
freebsd-ports-gnome-0411f7ca042b303c127b865b73540360aa094673.tar.zst
freebsd-ports-gnome-0411f7ca042b303c127b865b73540360aa094673.zip
Unbroke with threaded Mesa.
Submitted by: bento
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/glload/Makefile2
-rw-r--r--sysutils/glload/files/patch-Makefile.FreeBSD15
2 files changed, 17 insertions, 0 deletions
diff --git a/sysutils/glload/Makefile b/sysutils/glload/Makefile
index 36cca0d7d070..99f448b22e7d 100644
--- a/sysutils/glload/Makefile
+++ b/sysutils/glload/Makefile
@@ -18,6 +18,8 @@ USE_X_PREFIX= yes
USE_MESA= yes
MAKEFILE= Makefile.FreeBSD
ALL_TARGET= glload
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/glload ${PREFIX}/bin
diff --git a/sysutils/glload/files/patch-Makefile.FreeBSD b/sysutils/glload/files/patch-Makefile.FreeBSD
new file mode 100644
index 000000000000..0cd6fd0c4c13
--- /dev/null
+++ b/sysutils/glload/files/patch-Makefile.FreeBSD
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- Makefile.FreeBSD 2001/08/14 08:27:41 1.1
++++ Makefile.FreeBSD 2001/08/14 08:28:05
+@@ -1,7 +1,7 @@
+ OBJS = get_load.o trackball.o glload.o texture.o
+-CFLAGS += -I/usr/X11R6/include -DFreeBSD
++CFLAGS += -I/usr/X11R6/include -DFreeBSD $(PTHREAD_CFLAGS)
+ # i need this
+-LDFLAGS = -L/usr/X11R6/lib
++LDFLAGS = -L/usr/X11R6/lib $(PTHREAD_LIBS)
+ # the libs librpcsvc me only be needed on IRIX
+ LLDLIBS = -lglut -lGLU -lGL -lXmu -lXext -lXi -lXt -lICE -lSM -lX11 -lm
+ # your C-compiler