aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-05-13 23:08:04 +0800
committergahr <gahr@FreeBSD.org>2013-05-13 23:08:04 +0800
commit091f0747723a0b050e93f1873b4dd3da51931cd4 (patch)
treec5bcafbcb630f4a3bfe5ed4020a3a8ed4fc61fc9 /sysutils
parent1ce2b1c6e5e4853b8c9ee343e000dbf1a8714325 (diff)
downloadfreebsd-ports-gnome-091f0747723a0b050e93f1873b4dd3da51931cd4.tar.gz
freebsd-ports-gnome-091f0747723a0b050e93f1873b4dd3da51931cd4.tar.zst
freebsd-ports-gnome-091f0747723a0b050e93f1873b4dd3da51931cd4.zip
- Fix build with Tcl 8.6 [1]
- Trim Makefile header - Assign to tcltk@FreeBSD.org Reported by: miwi (Tcl/Tk 86 exp-run)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dirdiff/Makefile10
-rw-r--r--sysutils/dirdiff/files/patch-filecmp.c46
2 files changed, 49 insertions, 7 deletions
diff --git a/sysutils/dirdiff/Makefile b/sysutils/dirdiff/Makefile
index 92786ee3d6d0..cdbbae98f51a 100644
--- a/sysutils/dirdiff/Makefile
+++ b/sysutils/dirdiff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dirdiff
-# Whom: grog
-# Date created: 7 May 2001
-#
+# Created by: grog
# $FreeBSD$
-#
PORTNAME= dirdiff
PORTVERSION= 2.1
@@ -11,8 +7,8 @@ PORTREVISION= 3
CATEGORIES= sysutils tcl tk
MASTER_SITES= ftp://ftp.samba.org/pub/paulus/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A graphical diff tool
+MAINTAINER= tcltk@FreeBSD.org
+COMMENT= Graphical diff tool
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/sysutils/dirdiff/files/patch-filecmp.c b/sysutils/dirdiff/files/patch-filecmp.c
new file mode 100644
index 000000000000..4cb5a5df183d
--- /dev/null
+++ b/sysutils/dirdiff/files/patch-filecmp.c
@@ -0,0 +1,46 @@
+--- filecmp.c.orig 2005-04-19 12:22:01.000000000 +0200
++++ filecmp.c 2013-05-13 17:00:44.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <unistd.h>
+ #include <tcl.h>
+ #include <sys/fcntl.h>
+
+@@ -125,7 +126,7 @@
+ p2 += i;
+ k2 -= i;
+ /* 4 == strlen("<dollar>Id<dollar>") */
+- if (k1 < 4 && !e1 || k2 < 4 && !e2)
++ if ((k1 < 4 && !e1) || (k2 < 4 && !e2))
+ break;
+ if (k1 < 4 || k2 < 4) {
+ /* near the end of one or both files */
+@@ -195,7 +196,7 @@
+ k2 -= i;
+ if (match < BKTAGLEN) {
+ /* we have run out of one or other buffer */
+- if (k1 == 0 && e1 || k2 == 0 && e2) {
++ if ((k1 == 0 && e1) ||( k2 == 0 && e2)) {
+ if (k1 == k2)
+ break;
+ return 0;
+@@ -219,7 +220,7 @@
+ continue;
+ }
+ /* ran out before eol on one or both files */
+- if (t1 == k1 && e1 || t2 == k2 && e2) {
++ if ((t1 == k1 && e1) || (t2 == k2 && e2)) {
+ k1 -= t1;
+ k2 -= t2;
+ if (k1 == k2)
+@@ -341,7 +342,7 @@
+ if (n1 < 0 || n2 < 0)
+ return TCL_ERROR;
+
+- sprintf(interp->result, "%d", same);
++ Tcl_SetObjResult(interp, Tcl_NewIntObj(same));
+ return TCL_OK;
+ }
+