aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-19 04:20:46 +0800
committermarcus <marcus@FreeBSD.org>2004-02-19 04:20:46 +0800
commit0dbdd05fa722b3181f595347b6e7fb38ae04c207 (patch)
tree98076f6d4c09ffe92d5ea55ecbd2e2a0150ce7e3 /sysutils
parentf732a13449179213990825e80c6739e4e69be358 (diff)
downloadfreebsd-ports-gnome-0dbdd05fa722b3181f595347b6e7fb38ae04c207.tar.gz
freebsd-ports-gnome-0dbdd05fa722b3181f595347b6e7fb38ae04c207.tar.zst
freebsd-ports-gnome-0dbdd05fa722b3181f595347b6e7fb38ae04c207.zip
Respect PTHREAD_{CFLAGS,LIBS}.
PR: 62988 Submitted by: maintainer
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/linneighborhood/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/linneighborhood/Makefile b/sysutils/linneighborhood/Makefile
index 54a2b1015a66..2b8c14ac2511 100644
--- a/sysutils/linneighborhood/Makefile
+++ b/sysutils/linneighborhood/Makefile
@@ -1,5 +1,4 @@
# New ports collection makefile for: LinNeighborhood
-# Please read files/porters-note!
# Date created: 2003/04/06
# Whom: Heiner <h.eichmann@gmx.de>
#
@@ -21,15 +20,14 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"\
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"\
+ CC="${CC} -I${LOCALBASE}/include"
+# ^
+# this was done intentionaly in order to make `configure' pick up libintl.h
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
-.endif
-
post-patch:
${CP} ${FILESDIR}/mntent* ${WRKSRC}/src
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure