aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-07-22 16:41:28 +0800
committermarkp <markp@FreeBSD.org>2001-07-22 16:41:28 +0800
commit12145eb3738abf84f6a0493a99876d4710470faf (patch)
tree028e5f2923742dc681c7aebdc45e764c4208c19d /sysutils
parent2a4cf8c8a36c135000644c9c1ecfe97993e5918d (diff)
downloadfreebsd-ports-gnome-12145eb3738abf84f6a0493a99876d4710470faf.tar.gz
freebsd-ports-gnome-12145eb3738abf84f6a0493a99876d4710470faf.tar.zst
freebsd-ports-gnome-12145eb3738abf84f6a0493a99876d4710470faf.zip
Add ndir 0.8.5, a featureful directory lister.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ndir/Makefile32
-rw-r--r--sysutils/ndir/distinfo1
-rw-r--r--sysutils/ndir/pkg-comment1
-rw-r--r--sysutils/ndir/pkg-descr9
-rw-r--r--sysutils/ndir/pkg-plist3
6 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5bb4745e11a6..53b1495e40f0 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -90,6 +90,7 @@
SUBDIR += monitord
SUBDIR += msyslog
SUBDIR += muse
+ SUBDIR += ndir
SUBDIR += no-login
SUBDIR += npadmin
SUBDIR += nut
diff --git a/sysutils/ndir/Makefile b/sysutils/ndir/Makefile
new file mode 100644
index 000000000000..448a111b97b8
--- /dev/null
+++ b/sysutils/ndir/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ndir
+# Date created: Jun 16, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ndir
+PORTVERSION= 0.8.5
+CATEGORIES= sysutils
+MASTER_SITES= http://www.Informatik.Uni-Oldenburg.DE/~mw/software/
+DISTNAME= NDir-${PORTVERSION}
+EXTRACT_SUFX= -1.tar.gz
+
+MAINTAINER= markp@FreeBSD.org
+
+USE_GMAKE= yes
+ALL_TARGET= compile
+CFLAGS+= -DNO_THOUSANDS_GROUPING
+MAN1= ndir.1
+MLINKS= ndir.1 lv.1 ndir.1 lw.1
+
+post-patch:
+ @${PERL} -pi -e "s/^export GLOBAL.+//g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ndir ${PREFIX}/bin
+ ${LN} -sf ndir ${PREFIX}/bin/lw
+ ${LN} -sf ndir ${PREFIX}/bin/lv
+ ${INSTALL_MAN} ${WRKSRC}/ndir.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/ndir/distinfo b/sysutils/ndir/distinfo
new file mode 100644
index 000000000000..13219cf75dfc
--- /dev/null
+++ b/sysutils/ndir/distinfo
@@ -0,0 +1 @@
+MD5 (NDir-0.8.5-1.tar.gz) = b07264dbb8d3b31da23ce9a8792d4de4
diff --git a/sysutils/ndir/pkg-comment b/sysutils/ndir/pkg-comment
new file mode 100644
index 000000000000..2e69219ed830
--- /dev/null
+++ b/sysutils/ndir/pkg-comment
@@ -0,0 +1 @@
+A featureful directory lister
diff --git a/sysutils/ndir/pkg-descr b/sysutils/ndir/pkg-descr
new file mode 100644
index 000000000000..00b78910dd03
--- /dev/null
+++ b/sysutils/ndir/pkg-descr
@@ -0,0 +1,9 @@
+NDir is a console-based utility to display the contents of
+directories, just like 'ls' or 'dir'.
+
+NDir is designed to present its output in a more informative way to
+the user. This includes a summary line with some directory statistics,
+different levels of verbosity, colourized output and intelligent
+handling of very long file names.
+
+WWW: http://www.Informatik.Uni-Oldenburg.DE/~mw/software/ndir.html
diff --git a/sysutils/ndir/pkg-plist b/sysutils/ndir/pkg-plist
new file mode 100644
index 000000000000..504e05a2ca20
--- /dev/null
+++ b/sysutils/ndir/pkg-plist
@@ -0,0 +1,3 @@
+bin/ndir
+bin/lv
+bin/lw