aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-07 07:43:15 +0800
committermarino <marino@FreeBSD.org>2013-10-07 07:43:15 +0800
commit1b9f1e3b34392bdd9348a47cd985901feb9c185e (patch)
tree65db8f23f6f2e2a4f1c8f5b2997516f22f3b8239 /sysutils
parent5d8b585a100782d78c6e2364c2cccd0e5239edc0 (diff)
downloadfreebsd-ports-gnome-1b9f1e3b34392bdd9348a47cd985901feb9c185e.tar.gz
freebsd-ports-gnome-1b9f1e3b34392bdd9348a47cd985901feb9c185e.tar.zst
freebsd-ports-gnome-1b9f1e3b34392bdd9348a47cd985901feb9c185e.zip
sysutils/libutempter: Improve IGNORE condition for DragonFly
Qualify the OSVERSION check with an OPSYS check for FreeBSD so that the check doesn't break the port on DragonFly. Also import a local patch from dports for DragonFly.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/libutempter/Makefile4
-rw-r--r--sysutils/libutempter/files/patch-utempter.c20
2 files changed, 22 insertions, 2 deletions
diff --git a/sysutils/libutempter/Makefile b/sysutils/libutempter/Makefile
index df6657803082..8469457f8aed 100644
--- a/sysutils/libutempter/Makefile
+++ b/sysutils/libutempter/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= ftp://ftp.altlinux.org/pub/people/ldv/utempter/
MAINTAINER= ports@FreeBSD.org
COMMENT= Interface to record user sessions to utmp and wtmp files
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900004
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 900004
IGNORE= is now contained in the base system
.endif
diff --git a/sysutils/libutempter/files/patch-utempter.c b/sysutils/libutempter/files/patch-utempter.c
new file mode 100644
index 000000000000..4de9d2f14a25
--- /dev/null
+++ b/sysutils/libutempter/files/patch-utempter.c
@@ -0,0 +1,20 @@
+--- utempter.c.orig 2007-02-19 12:14:08.000000000 +0000
++++ utempter.c
+@@ -36,7 +36,7 @@
+
+ #ifdef __GLIBC__
+ # include <pty.h>
+-#elif defined(__FreeBSD__)
++#elif defined(__FreeBSD__) || defined(__DragonFly__)
+ # include <libutil.h>
+ #else
+ # error Unsupported platform
+@@ -157,7 +157,7 @@ write_uwtmp_record(const char *user, con
+
+ (void) updwtmp(_PATH_WTMP, &ut);
+
+-#elif defined(__FreeBSD__)
++#elif defined(__FreeBSD__) || defined(__DragonFly__)
+
+ ut.ut_time = tv.tv_sec;
+