aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-28 20:04:08 +0800
committerbapt <bapt@FreeBSD.org>2014-05-28 20:04:08 +0800
commit1c54183f8718fbcf9c96893c6a5c012138cdfe91 (patch)
treee39c5807da81a6caddbf783d369024c1d52bcc94 /sysutils
parent3a01aa316069bbf3db4dca92d8dfc3601e9fdccc (diff)
downloadfreebsd-ports-gnome-1c54183f8718fbcf9c96893c6a5c012138cdfe91.tar.gz
freebsd-ports-gnome-1c54183f8718fbcf9c96893c6a5c012138cdfe91.tar.zst
freebsd-ports-gnome-1c54183f8718fbcf9c96893c6a5c012138cdfe91.zip
Fix a forgotten port using old perl framework
While here remove check for non supported version of freebsd
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/procenv/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/sysutils/procenv/Makefile b/sysutils/procenv/Makefile
index e92b3289539a..fbdbbce21214 100644
--- a/sysutils/procenv/Makefile
+++ b/sysutils/procenv/Makefile
@@ -16,19 +16,13 @@ LICENSE= GPLv3
BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake perl5
USE_AUTOTOOLS= aclocal automake
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PLIST_FILES= bin/procenv \
man/man1/procenv.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800505
-BROKEN= does not build on old ${OPSYS} versions
-.endif
-
# Test to ensure procenv will actually run.
#
# This has the attractive side-effect of displaying the environment
@@ -42,4 +36,4 @@ test: regression-test
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/procenv
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>