aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-11-28 00:49:49 +0800
committeroliver <oliver@FreeBSD.org>2006-11-28 00:49:49 +0800
commit2a3efea81f92831c9cd763b2611dd0908098c4eb (patch)
treedbe4643ad394febfd21b944b960323f5bac3a795 /sysutils
parente4d6955ce2e301d28a6358794e16b4f19b900acb (diff)
downloadfreebsd-ports-gnome-2a3efea81f92831c9cd763b2611dd0908098c4eb.tar.gz
freebsd-ports-gnome-2a3efea81f92831c9cd763b2611dd0908098c4eb.tar.zst
freebsd-ports-gnome-2a3efea81f92831c9cd763b2611dd0908098c4eb.zip
fix build with non-standard X11BASE
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-mcs-plugins/Makefile4
-rw-r--r--sysutils/xfce4-utils/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/sysutils/xfce4-mcs-plugins/Makefile b/sysutils/xfce4-mcs-plugins/Makefile
index cf22c1383bc4..d50718280974 100644
--- a/sysutils/xfce4-mcs-plugins/Makefile
+++ b/sysutils/xfce4-mcs-plugins/Makefile
@@ -28,8 +28,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/sysutils/xfce4-utils/Makefile b/sysutils/xfce4-utils/Makefile
index 729365eddd81..a86a82d1ede8 100644
--- a/sysutils/xfce4-utils/Makefile
+++ b/sysutils/xfce4-utils/Makefile
@@ -29,8 +29,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
- CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${X11BASE}/lib" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>