aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgjb <gjb@FreeBSD.org>2013-01-08 12:33:08 +0800
committergjb <gjb@FreeBSD.org>2013-01-08 12:33:08 +0800
commit2eaa7c999b21fa4a36c8573df1059206f6d5dec5 (patch)
treec589768e4a719cb65c52f4cbc87f6f57949d943f /sysutils
parentda9d04bc89c529e0219d4c358271c6ef1a594e49 (diff)
downloadfreebsd-ports-gnome-2eaa7c999b21fa4a36c8573df1059206f6d5dec5.tar.gz
freebsd-ports-gnome-2eaa7c999b21fa4a36c8573df1059206f6d5dec5.tar.zst
freebsd-ports-gnome-2eaa7c999b21fa4a36c8573df1059206f6d5dec5.zip
Implement the concept of a "master" port for the set of
sysutils/cfengine* ports. The idea here is two-fold: 1.) Users should not need to ever change port origins for a default software version bump; 2.) Users should expect to exist an unversioned port directory to reflect the latest major version (and they should be correct in this expectation). With this change, users can install the sysutils/cfengine port, and by default track the latest major version of the software. Subsequent version releases, for example the 3.5 branch, will not require any interaction from user side. Additionally, users can stay on a certain branch release by adding, in this case, CFENGINE_VERSION version to make.conf or specifying the branch during build time with: # make CFENGINE_VERSION=NN The list of available CFENGINE_VERSION values are listed with: # make -V VERSIONS Discussed with: cy
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/sysutils/cfengine/Makefile b/sysutils/cfengine/Makefile
new file mode 100644
index 000000000000..4365820bb54f
--- /dev/null
+++ b/sysutils/cfengine/Makefile
@@ -0,0 +1,8 @@
+# $FreeBSD$
+
+VERSIONS= 22 32 33 34 -devel
+CFENGINE_VERSION?= 34
+
+MASTERDIR= ${.CURDIR}/../cfengine${CFENGINE_VERSION}
+
+.include "${MASTERDIR}/Makefile"