aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-19 09:38:38 +0800
committerwxs <wxs@FreeBSD.org>2009-07-19 09:38:38 +0800
commit36fbe4554d00c52fba0602ef7c7fa87da666829e (patch)
treef92476c8629ed32bc6864251ced251a56de93fb8 /sysutils
parent397f234ce7cb1cb32ea043bc6bb9cd171b281553 (diff)
downloadfreebsd-ports-gnome-36fbe4554d00c52fba0602ef7c7fa87da666829e.tar.gz
freebsd-ports-gnome-36fbe4554d00c52fba0602ef7c7fa87da666829e.tar.zst
freebsd-ports-gnome-36fbe4554d00c52fba0602ef7c7fa87da666829e.zip
- Update to 7
PR: ports/136788 Submitted by: Jochen Neumeister <jochen@daten-chaos.de> Approved by: Baptiste Grenier <gwarf@gwarf.org> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pydf/Makefile2
-rw-r--r--sysutils/pydf/distinfo6
-rw-r--r--sysutils/pydf/files/patch-pydf34
3 files changed, 22 insertions, 20 deletions
diff --git a/sysutils/pydf/Makefile b/sysutils/pydf/Makefile
index b530e0b44a6f..0e59b64ef094 100644
--- a/sysutils/pydf/Makefile
+++ b/sysutils/pydf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pydf
-PORTVERSION= 6
+PORTVERSION= 7
CATEGORIES= sysutils
MASTER_SITES= http://kassiopeia.juls.savba.sk/~garabik/software/pydf/
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/sysutils/pydf/distinfo b/sysutils/pydf/distinfo
index 57f002080065..0991191fb44b 100644
--- a/sysutils/pydf/distinfo
+++ b/sysutils/pydf/distinfo
@@ -1,3 +1,3 @@
-MD5 (pydf_6.tar.gz) = b71572cc111a8f68edc876351b0f7733
-SHA256 (pydf_6.tar.gz) = 4202b4cbbd631b40f6e2fbd73bf0a6397899e6acf148e84864731a92cfa5cb80
-SIZE (pydf_6.tar.gz) = 12140
+MD5 (pydf_7.tar.gz) = 54c631b1bf8d00111d49567b2e83d718
+SHA256 (pydf_7.tar.gz) = ce09e48bf6d03d4128c3dfbbe4cdd093ac533006440cc6aa239592e0af223c23
+SIZE (pydf_7.tar.gz) = 12487
diff --git a/sysutils/pydf/files/patch-pydf b/sysutils/pydf/files/patch-pydf
index 0a216915da50..00e15673f7ab 100644
--- a/sysutils/pydf/files/patch-pydf
+++ b/sysutils/pydf/files/patch-pydf
@@ -1,21 +1,23 @@
---- pydf.original Tue Dec 4 23:02:26 2007
-+++ pydf Tue Dec 4 23:02:14 2007
+--- pydf.orig 2009-04-10 13:00:07.000000000 +0000
++++ pydf 2009-07-15 12:54:08.000000000 +0000
@@ -1,4 +1,4 @@
-#! /usr/bin/python
+#! %%PYTHON_CMD%%
import sys, os, string, types, commands, struct
from optparse import OptionParser
-@@ -166,7 +166,7 @@
+@@ -169,8 +169,8 @@
#end of default definitions
# read configuration file
-for i in ["/etc/pydfrc", os.environ['HOME']+"/.pydfrc"]:
+- if os.path.isfile(i):
+for i in ["%%PREFIX%%/etc/pydfrc", os.environ['HOME']+"/.pydfrc"]:
- if os.path.isfile(i):
++ if os.path.isfile(i):
execfile(i)
-@@ -336,9 +336,9 @@
+
+@@ -344,9 +344,9 @@
except OSError, IOError:
status = 10*[0]
@@ -25,18 +27,18 @@
- fs_blocksize = status[F_FRSIZE]
+ fs_blocksize = status[F_BSIZE]
free = status[F_BFREE]
- used = long(status[F_BLOCKS]-free)
size = status[F_BLOCKS]
-@@ -351,7 +351,7 @@
- avail_f = myformat(avail, sizeformat, fs_blocksize)
-
- try:
-- perc = round(100.*used/size, 1)
-+ perc = round(100.*used/(avail+used), 1)
- except ZeroDivisionError:
- perc = 0
- perc_f = str(perc)
-@@ -419,7 +419,7 @@
+ avail = status[F_BAVAIL]
+@@ -375,7 +375,7 @@
+ used_f = myformat(used, sizeformat, fs_blocksize)
+ avail_f = myformat(avail, sizeformat, fs_blocksize)
+ try:
+- perc = round(100.*used/size, 1)
++ perc = round(100.*used/(avail+used), 1)
+ perc_f = str(perc)
+ except ZeroDivisionError:
+ perc = 0
+@@ -444,7 +444,7 @@
"test if fs (as type) is a special one"
"in addition, a filesystem is special if it has number of blocks equal to 0"
fs = fs.lower()