aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcperciva <cperciva@FreeBSD.org>2006-03-18 08:32:05 +0800
committercperciva <cperciva@FreeBSD.org>2006-03-18 08:32:05 +0800
commit3ca9119a8467b3ff14bb82d664edd4921595880c (patch)
tree58cf5b0d6779061bc80856454f3f0539ff1053f7 /sysutils
parent8b912df11d7d27b1234cb50088968e8228e23048 (diff)
downloadfreebsd-ports-gnome-3ca9119a8467b3ff14bb82d664edd4921595880c.tar.gz
freebsd-ports-gnome-3ca9119a8467b3ff14bb82d664edd4921595880c.tar.zst
freebsd-ports-gnome-3ca9119a8467b3ff14bb82d664edd4921595880c.zip
A much-needed cleanup of the portification of this code:
Remove PREFIX/modules directory if it doesn't contain other modules; use static plist (new file: pkg-plist). Switch to a modern USE_RC_SUBR (moved file: files/est.sh --> files/est.in). Silence install here and there. Fix IGNORE message. IGNORE if no kernel sources installed. Bump PORTREVISION for plist change. PR: ports/93985 Submitted by: itetcu (who really needs to get a commit bit soon...)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/est/Makefile21
-rw-r--r--sysutils/est/files/est.in (renamed from sysutils/est/files/est.sh)2
-rw-r--r--sysutils/est/pkg-message2
-rw-r--r--sysutils/est/pkg-plist3
4 files changed, 14 insertions, 14 deletions
diff --git a/sysutils/est/Makefile b/sysutils/est/Makefile
index e95b920d7185..fec868900ed6 100644
--- a/sysutils/est/Makefile
+++ b/sysutils/est/Makefile
@@ -7,7 +7,7 @@
PORTNAME= est
PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.daemonology.net/freebsd-est/
@@ -18,27 +18,22 @@ ONLY_FOR_ARCHS= i386
KMODDIR= ${PREFIX}/modules
MAKE_ARGS= KMODDIR="${KMODDIR}"
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
-
-PLIST_FILES= modules/est.ko \
- etc/rc.d/est.sh
+USE_RC_SUBR= ${PORTNAME}
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 600015
-IGNORE= est now contained in the base system (see cpufreq(4))
+IGNORE= is now contained in the base system (see cpufreq(4))
.endif
-post-extract:
- ${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/est.sh > ${WRKDIR}/est.sh
+.if !exists(${SRC_BASE}/sys/Makefile)
+IGNORE= needs kernel source files
+.endif
pre-install:
- ${MKDIR} ${KMODDIR}
+ @${MKDIR} ${KMODDIR}
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/est.sh ${PREFIX}/etc/rc.d/est.sh
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/sysutils/est/files/est.sh b/sysutils/est/files/est.in
index 9cb494916803..5db37e38eb9f 100644
--- a/sysutils/est/files/est.sh
+++ b/sysutils/est/files/est.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/sysutils/est/files/Attic/est.in,v 1.1 2006-03-18 00:32:05 cperciva Exp $
#
# PROVIDE: est
diff --git a/sysutils/est/pkg-message b/sysutils/est/pkg-message
index e13e87d9aad1..d70b50af0f2d 100644
--- a/sysutils/est/pkg-message
+++ b/sysutils/est/pkg-message
@@ -1,5 +1,7 @@
+===============================================================================
To load the Enhanced Speedstep kernel module at boot:
echo 'est_enable="YES"' >> /etc/rc.conf
To log every change of CPU frequency:
echo 'est_verbose="YES"' >> /etc/rc.conf
+===============================================================================
diff --git a/sysutils/est/pkg-plist b/sysutils/est/pkg-plist
new file mode 100644
index 000000000000..85c1d54beda3
--- /dev/null
+++ b/sysutils/est/pkg-plist
@@ -0,0 +1,3 @@
+modules/est.ko
+@unexec MOD_FNR=`ls -1 %D/modules |wc -l`; MOD_L=`ls -1 %D/modules |grep linker.hints|wc -l`; if [ "${MOD_FNR}" -eq "${MOD_L}" ]; then rm -rf %D/modules; fi
+@dirrmtry modules