aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-05-11 04:15:53 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-05-11 04:15:53 +0800
commit42dc2fe4a4a40125fc7022908361695566ed2872 (patch)
tree81d78006a25c689fbf29ac435d1b35bfe8a78bdc /sysutils
parent3d517c9521f74e476b41367880624c044b6a0c91 (diff)
downloadfreebsd-ports-gnome-42dc2fe4a4a40125fc7022908361695566ed2872.tar.gz
freebsd-ports-gnome-42dc2fe4a4a40125fc7022908361695566ed2872.tar.zst
freebsd-ports-gnome-42dc2fe4a4a40125fc7022908361695566ed2872.zip
- Update to 0.55
Changes: http://joeyh.name/code/moreutils/news/version_0.55/ http://joeyh.name/code/moreutils/news/version_0.54/ PR: 200104 Submitted by: olgeni
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/moreutils/Makefile13
-rw-r--r--sysutils/moreutils/distinfo4
-rw-r--r--sysutils/moreutils/files/patch-moreutils-parallel.c20
3 files changed, 22 insertions, 15 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index 5659ebbd67c4..417321a3c0e3 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= moreutils
-PORTVERSION= 0.53
-PORTREVISION= 1
+PORTVERSION= 0.55
CATEGORIES= sysutils
MASTER_SITES= DEBIAN_POOL
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Additional Unix utilities
@@ -21,7 +20,7 @@ OPTIONS_SUB= yes
ALL_TARGET= errnos.h ${CANNED_MANPAGES:R}
USES= perl5 shebangfix
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CANNED_MANPAGES=errno.1 \
ifdata.1 \
@@ -42,14 +41,14 @@ PERL_MANPAGES= chronic.1 \
SHEBANG_FILES= ${PERL_MANPAGES:R}
post-extract:
- @${MV} ${WRKSRC}/ts ${WRKSRC}/moreutils-ts
+.for file in parallel.c parallel.docbook ts
+ @${MV} ${WRKSRC}/${file} ${WRKSRC}/moreutils-${file}
+.endfor
post-patch:
@${REINPLACE_CMD} -e 's|parallel|moreutils-&|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|__APPLE__|__${OPSYS}__|' ${WRKSRC}/ifdata.c
@cd ${FILESDIR}/ && ${CP} ${CANNED_MANPAGES} ${WRKSRC}/
- @${MV} ${WRKSRC}/parallel.c ${WRKSRC}/moreutils-parallel.c
- @${MV} ${WRKSRC}/parallel.docbook ${WRKSRC}/moreutils-parallel.docbook
post-build:
.for man in ${PERL_MANPAGES:R}
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index c8b9b02bbc9c..1e274015d521 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moreutils_0.53.tar.gz) = 4f1842467759b6747f28a624c317a315f0b54a44440d2c8e2eec4d10144696fc
-SIZE (moreutils_0.53.tar.gz) = 47613
+SHA256 (moreutils_0.55.orig.tar.gz) = da9d5cd145ceea967a65dd50031d168d66199c3eb41b9390b57f35d4a5808ab5
+SIZE (moreutils_0.55.orig.tar.gz) = 46500
diff --git a/sysutils/moreutils/files/patch-moreutils-parallel.c b/sysutils/moreutils/files/patch-moreutils-parallel.c
index 5e096a506693..411932268578 100644
--- a/sysutils/moreutils/files/patch-moreutils-parallel.c
+++ b/sysutils/moreutils/files/patch-moreutils-parallel.c
@@ -1,6 +1,14 @@
---- ./parallel.c.orig 2010-07-06 12:06:47.000000000 -0700
-+++ ./parallel.c 2010-11-17 15:49:57.000000000 -0800
-@@ -87,6 +87,7 @@
+--- moreutils-parallel.c.orig 2015-01-19 18:03:51 UTC
++++ moreutils-parallel.c
+@@ -31,6 +31,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
++#include <signal.h>
+
+ #ifdef __sun
+ # include <sys/loadavg.h> /* getloadavg() */
+@@ -112,6 +113,7 @@ void exec_child(char **command, char **a
return;
}
@@ -8,7 +16,7 @@
int wait_for_child(int options) {
id_t id_ignored = 0;
siginfo_t infop;
-@@ -101,6 +102,18 @@
+@@ -126,6 +128,18 @@ int wait_for_child(int options) {
}
return 1;
}
@@ -25,5 +33,5 @@
+#endif
+
- int main(int argc, char **argv) {
- int maxjobs = -1;
+ static int pipe_child(int fd, int orig_fd)
+ {