aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-02 14:39:56 +0800
committerclsung <clsung@FreeBSD.org>2006-11-02 14:39:56 +0800
commit4afcd48a8abe6933161828ec6ed08b587181399f (patch)
tree638d323640f67b21661516106ff5b2e62c925f1b /sysutils
parent05baa3939b988354aafc4d1af5c781ce65f1e810 (diff)
downloadfreebsd-ports-gnome-4afcd48a8abe6933161828ec6ed08b587181399f.tar.gz
freebsd-ports-gnome-4afcd48a8abe6933161828ec6ed08b587181399f.tar.zst
freebsd-ports-gnome-4afcd48a8abe6933161828ec6ed08b587181399f.zip
- Update to 2.4.0
PR: ports/105003 Submitted by: maintainer (Nicolas Jombart)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/sec/Makefile18
-rw-r--r--sysutils/sec/distinfo6
-rw-r--r--sysutils/sec/files/sec.in22
3 files changed, 27 insertions, 19 deletions
diff --git a/sysutils/sec/Makefile b/sysutils/sec/Makefile
index 66dfb8eb44b3..8c195f9d8034 100644
--- a/sysutils/sec/Makefile
+++ b/sysutils/sec/Makefile
@@ -1,13 +1,13 @@
-# New ports collection Makefile for: sec
-# Date created: 25, February 2003
-# Whom: Nicolas Jombart <ecu@ipv42.net>
+# ex:ts=8
+# New ports collection Makefile for: sec
+# Date created: 25, February 2003
+# Whom: Nicolas Jombart <ecu@ipv42.net>
#
# $FreeBSD$
#
PORTNAME= sec
-PORTVERSION= 2.3.3
-PORTREVISION= 1
+PORTVERSION= 2.4.0
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= simple-evcorr
@@ -22,8 +22,12 @@ USE_RC_SUBR= sec
SUB_LIST= PERL=${PERL}
MAN8= sec.8
-PORTDOCS= ChangeLog README convert.pl itostream.c
+PORTDOCS= ChangeLog README
PLIST_FILES= bin/sec
+DATADIR= share/sec
+PORTCONTRIB= convert.pl itostream.c swatch2sec.pl
+PLIST_FILES+= ${PORTCONTRIB:S|^|%%DATADIR%%/|}
+PLIST_DIRS+= ${DATADIR}
post-patch:
@${REINPLACE_CMD} -e \
@@ -36,5 +40,7 @@ do-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+ @${MKDIR} ${PREFIX}/${DATADIR}
+ cd ${WRKSRC}/contrib && ${INSTALL_DATA} ${PORTCONTRIB} ${PREFIX}/${DATADIR}
.include <bsd.port.mk>
diff --git a/sysutils/sec/distinfo b/sysutils/sec/distinfo
index adcbe2d3b5a9..a34391ebc54c 100644
--- a/sysutils/sec/distinfo
+++ b/sysutils/sec/distinfo
@@ -1,3 +1,3 @@
-MD5 (sec-2.3.3.tar.gz) = 1b714a7dbb71e165327886a329f6d1e0
-SHA256 (sec-2.3.3.tar.gz) = 13d2ffa82905f55f82c6bf6c7ff356956e430a475b280989f5805d86df341d09
-SIZE (sec-2.3.3.tar.gz) = 77785
+MD5 (sec-2.4.0.tar.gz) = 3697bdab0664d5392c8e1e66edd3291c
+SHA256 (sec-2.4.0.tar.gz) = f73462d5a003ae82e0e31c68d55898d1d3b039016ecd3707a48d5e07deef2a82
+SIZE (sec-2.4.0.tar.gz) = 80011
diff --git a/sysutils/sec/files/sec.in b/sysutils/sec/files/sec.in
index b8e0f84090a2..63c94d6ef5ca 100644
--- a/sysutils/sec/files/sec.in
+++ b/sysutils/sec/files/sec.in
@@ -1,10 +1,12 @@
#!/bin/sh
#
+# Sample SEC startup script for FreeBSD (contributed by Jo Rhett)
+#
# Add the following lines to /etc/rc.conf to enable sec:
-# sec_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable sec.
+# sec_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable sec.
#
-# These flags control the first (or only) instance of sec.
+# These parameters control the first (or only) instance of sec
# sec_flags (str): Set to "" by default.
# sec_configfile (str): Set to "%%PREFIX%%/etc/sec.conf" by default.
#
@@ -42,9 +44,9 @@ load_rc_config "${name}"
sec_checkconfig() {
if [ -z $instance ]
then
- echo -n "Performing sanity check of sec configuration: "
+ echo -n "Performing sanity check of sec configuration: "
else
- echo -n "Performing sanity check of sec_${instance} configuration: "
+ echo -n "Performing sanity check of sec_${instance} configuration: "
fi
${command} -debug=1 -testonly -conf=${sec_configfile} 2>&1 >/dev/null
if [ $? != 0 ]; then
@@ -61,17 +63,17 @@ sec_flags="-conf=${sec_configfile} -pid=${pidfile} ${sec_flags}"
run_rc_command "$1"
-# Are we handling multiple instance mode?
+# Are we handling multiple instances?
if [ ! -z "${sec_instances}" ]
then
- for instance in $sec_instances
- do
+ for instance in $sec_instances
+ do
# Iterate through all instances
name="sec_${instance}"
pidfile="/var/run/sec_${instance}.pid"
eval required_files=\$sec_${instance}_configfile
eval sec_${instance}_flags="\"-conf=\$sec_${instance}_configfile -pid=\$pidfile \$sec_${instance}_flags\""
- run_rc_command "$1"
- done
+ run_rc_command "$1"
+ done
fi