aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 20:25:46 +0800
committeraz <az@FreeBSD.org>2013-07-26 20:25:46 +0800
commit4c92ac629811ebdb6cc6b8f28b2a85a1b506d870 (patch)
treeb435d6f78aad5f535f16b879583ccc2c1f8aa552 /sysutils
parent1857023b2e679011848b928dff94a27333cb5b93 (diff)
downloadfreebsd-ports-gnome-4c92ac629811ebdb6cc6b8f28b2a85a1b506d870.tar.gz
freebsd-ports-gnome-4c92ac629811ebdb6cc6b8f28b2a85a1b506d870.tar.zst
freebsd-ports-gnome-4c92ac629811ebdb6cc6b8f28b2a85a1b506d870.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gupsc/Makefile12
-rw-r--r--sysutils/ucspi-ssl/Makefile9
-rw-r--r--sysutils/usermin/Makefile2
3 files changed, 7 insertions, 16 deletions
diff --git a/sysutils/gupsc/Makefile b/sysutils/gupsc/Makefile
index fba2bd9215f5..858ab0c0d4fc 100644
--- a/sysutils/gupsc/Makefile
+++ b/sysutils/gupsc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gupsc
-# Date created: 13 March 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gupsc
PORTVERSION= 0.3.1
@@ -23,8 +19,8 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
pre-patch:
- @${PERL} -pi -e 's|/usr/local|${PREFIX}|; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure \
- ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -i '' -e 's|/usr/local|${PREFIX}|' \
+ -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
+ ${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/sysutils/ucspi-ssl/Makefile b/sysutils/ucspi-ssl/Makefile
index 62eee7d25b34..646b326532f7 100644
--- a/sysutils/ucspi-ssl/Makefile
+++ b/sysutils/ucspi-ssl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ucspi-ssl
-# Date created: 2003-07-09
-# Whom: David Thiel <lx@redundancy.redundancy.org>
-#
+# Created by: David Thiel <lx@redundancy.redundancy.org>
# $FreeBSD$
-#
PORTNAME= ucspi-ssl
PORTVERSION?= 0.70
@@ -35,8 +31,7 @@ SCRIPTS_TO_INSTALL= https@ sslcat sslconnect
post-patch:
.for x in ${SCRIPTS_TO_INSTALL}
- @${PERL} -pi.orig \
- -e 's|HOME/command/|${PREFIX}/bin/|' \
+ @${REINPLACE_CMD} -i '' -e 's|HOME/command/|${PREFIX}/bin/|' \
${WRKSRC}/src/${x}.sh
.endfor
diff --git a/sysutils/usermin/Makefile b/sysutils/usermin/Makefile
index bc39584900f7..8a59cdc074e1 100644
--- a/sysutils/usermin/Makefile
+++ b/sysutils/usermin/Makefile
@@ -37,7 +37,7 @@ post-patch:
@${REINPLACE_CMD} -e "s=%%PREFIX%%=${PREFIX}=" ${WRKSRC}/setup.sh
.for file in filter/config commands/config htaccess/config
- @${PERL} -pi -e "s|=/etc/webmin|=${PREFIX}/etc/webmin|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -i '' -e 's|=/etc/webmin|=${PREFIX}/etc/webmin|' ${WRKSRC}/${file}
.endfor
@${FIND} ${WRKSRC} -name config-freebsd\* \