aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcem <cem@FreeBSD.org>2015-11-21 02:44:53 +0800
committercem <cem@FreeBSD.org>2015-11-21 02:44:53 +0800
commit5bed7aae2855404061ef7212002682c418c84ef4 (patch)
treefd9b4e585adf4db60327a9f85be8f31345ff738c /sysutils
parentd33047a9cc7da9f290a9897bd98d75aa15af27d9 (diff)
downloadfreebsd-ports-gnome-5bed7aae2855404061ef7212002682c418c84ef4.tar.gz
freebsd-ports-gnome-5bed7aae2855404061ef7212002682c418c84ef4.tar.zst
freebsd-ports-gnome-5bed7aae2855404061ef7212002682c418c84ef4.zip
sysutils/fusefs-lkl: Add lklfuse, a Linux implementation for FUSE
liblkl.a provides the Linux kernel (in nommu mode) as a library. The lklfuse binary can be used to mount filesystems that Linux supports (btrfs, ext4 and earlier, and xfs) read/write under FUSE. Reviewed by: bdrewery Sponsored by: EMC / Isilon Storage Division Differential Revision: https://reviews.freebsd.org/D4199
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-lkl/Makefile40
-rw-r--r--sysutils/fusefs-lkl/distinfo2
-rw-r--r--sysutils/fusefs-lkl/files/patch-tools-lkl-Makefile13
-rw-r--r--sysutils/fusefs-lkl/pkg-descr3
5 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f9b46a6707e2..bf6965b916d7 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -310,6 +310,7 @@
SUBDIR += fusefs-ifuse
SUBDIR += fusefs-kmod
SUBDIR += fusefs-libs
+ SUBDIR += fusefs-lkl
SUBDIR += fusefs-mhddfs
SUBDIR += fusefs-mp3fs
SUBDIR += fusefs-ntfs
diff --git a/sysutils/fusefs-lkl/Makefile b/sysutils/fusefs-lkl/Makefile
new file mode 100644
index 000000000000..198d4a5f1caf
--- /dev/null
+++ b/sysutils/fusefs-lkl/Makefile
@@ -0,0 +1,40 @@
+# Created by: Conrad Meyer <cem@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lkl
+PORTVERSION= 4.3.0
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= cem@FreeBSD.org
+COMMENT= Full-featured Linux BTRFS, Ext4, XFS as a FUSE module
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS+= gnubc>0:${PORTSDIR}/math/gnubc
+LIB_DEPENDS+= libfuse.so:${PORTSDIR}/sysutils/fusefs-libs
+
+USES= fuse gmake
+USE_BINUTILS= yes
+USE_GCC= yes
+USE_GITHUB= yes
+GH_ACCOUNT= lkl
+GH_PROJECT= linux
+GH_TAGNAME= 64a367f522c6ec4fbed0193589d7733b06ab7968
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON=No one has added other architecture ld formats yet
+
+WRKSRC_SUBDIR= tools/lkl
+ALL_TARGET= lklfuse
+MAKE_JOBS_UNSAFE=yes
+MAKE_ARGS+= V=1
+
+PLIST_FILES= bin/lklfuse lib/liblkl.a
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lklfuse ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/lib/liblkl.a ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-lkl/distinfo b/sysutils/fusefs-lkl/distinfo
new file mode 100644
index 000000000000..152c0752a68f
--- /dev/null
+++ b/sysutils/fusefs-lkl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lkl-linux-4.3.0-64a367f522c6ec4fbed0193589d7733b06ab7968_GH0.tar.gz) = a0d45aadd13df116ea7496c8107395ae504972bb7c8436bb099b9fd43817b8f5
+SIZE (lkl-linux-4.3.0-64a367f522c6ec4fbed0193589d7733b06ab7968_GH0.tar.gz) = 133474279
diff --git a/sysutils/fusefs-lkl/files/patch-tools-lkl-Makefile b/sysutils/fusefs-lkl/files/patch-tools-lkl-Makefile
new file mode 100644
index 000000000000..8dd003c478b6
--- /dev/null
+++ b/sysutils/fusefs-lkl/files/patch-tools-lkl-Makefile
@@ -0,0 +1,13 @@
+--- Makefile 2015-11-17 14:22:24.000000000 -0800
++++ Makefile 2015-11-17 17:23:27.478293000 -0800
+@@ -40,8 +40,8 @@
+ $(AR) -rc $@ $^
+
+ lib/lkl.o:
+- $(MAKE) -C ../.. ARCH=lkl defconfig
+- $(MAKE) -C ../.. ARCH=lkl $(KOPT) install INSTALL_PATH=$(PWD)
++ $(MAKE) -C ../.. ARCH=lkl LDFLAGS= defconfig
++ $(MAKE) -C ../.. ARCH=lkl LDFLAGS= $(KOPT) install INSTALL_PATH=$(PWD)
+
+ %: %.o
+ $(CC) -o $@ $^ $(LDFLAGS)
diff --git a/sysutils/fusefs-lkl/pkg-descr b/sysutils/fusefs-lkl/pkg-descr
new file mode 100644
index 000000000000..441271363c1f
--- /dev/null
+++ b/sysutils/fusefs-lkl/pkg-descr
@@ -0,0 +1,3 @@
+Linux as a library; and BTRFS, Ext4, and XFS for FUSE.
+
+WWW: https://github.com/lkl/linux/