aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-09-28 02:25:17 +0800
committerjbeich <jbeich@FreeBSD.org>2016-09-28 02:25:17 +0800
commit65e5f08e428b22f40a49df3cd740714c8b6264e9 (patch)
treef087a592e5c1673bb1690aaf1b7a4a41b384e9e0 /sysutils
parentce5f17d74c6fd4f4f32947453dc961d698b386a1 (diff)
downloadfreebsd-ports-gnome-65e5f08e428b22f40a49df3cd740714c8b6264e9.tar.gz
freebsd-ports-gnome-65e5f08e428b22f40a49df3cd740714c8b6264e9.tar.zst
freebsd-ports-gnome-65e5f08e428b22f40a49df3cd740714c8b6264e9.zip
sysutils/android-file-transfer: enslave GUI and expose CLI option
Catering package-only users that want Qt4 flavor or just non-GUI parts. COMMENT and pkg-descr (both plural) can be improved in future.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/android-file-transfer-qt4/Makefile16
-rw-r--r--sysutils/android-file-transfer-qt5/Makefile16
-rw-r--r--sysutils/android-file-transfer/Makefile19
4 files changed, 49 insertions, 4 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ac07864b453a..a31affbb9070 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -32,6 +32,8 @@
SUBDIR += anacron
SUBDIR += and
SUBDIR += android-file-transfer
+ SUBDIR += android-file-transfer-qt4
+ SUBDIR += android-file-transfer-qt5
SUBDIR += ansible
SUBDIR += ansible1
SUBDIR += apachetop
diff --git a/sysutils/android-file-transfer-qt4/Makefile b/sysutils/android-file-transfer-qt4/Makefile
new file mode 100644
index 000000000000..a1873a15eeee
--- /dev/null
+++ b/sysutils/android-file-transfer-qt4/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt4
+
+MASTERDIR= ${.CURDIR}/../android-file-transfer
+
+CONFLICTS_INSTALL= ${PORTNAME}-qt5
+
+OPTIONS_SLAVE= QT4
+OPTIONS_EXCLUDE=${OPTIONS_MULTI_COMP} ${OPTIONS_RADIO_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+post-patch-QT4-on: post-patch-CLI-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/android-file-transfer-qt5/Makefile b/sysutils/android-file-transfer-qt5/Makefile
new file mode 100644
index 000000000000..77cb22c54602
--- /dev/null
+++ b/sysutils/android-file-transfer-qt5/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt5
+
+MASTERDIR= ${.CURDIR}/../android-file-transfer
+
+CONFLICTS_INSTALL= ${PORTNAME}-qt4
+
+OPTIONS_SLAVE= QT5
+OPTIONS_EXCLUDE=${OPTIONS_MULTI_COMP} ${OPTIONS_RADIO_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+post-patch-QT5-on: post-patch-CLI-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/android-file-transfer/Makefile b/sysutils/android-file-transfer/Makefile
index 987e52fda202..18bad2aeb914 100644
--- a/sysutils/android-file-transfer/Makefile
+++ b/sysutils/android-file-transfer/Makefile
@@ -4,6 +4,7 @@ PORTNAME= android-file-transfer
DISTVERSIONPREFIX= v
DISTVERSION= 3.0-10
DISTVERSIONSUFFIX= -g40640fb
+PORTREVISION?= 1
CATEGORIES= sysutils
MAINTAINER= jbeich@FreeBSD.org
@@ -15,17 +16,24 @@ USE_GITHUB= yes
GH_ACCOUNT= whoozle
GH_PROJECT= ${PORTNAME}-linux
-USES= cmake compiler:c++11-lib localbase pkgconfig readline
+USES= cmake compiler:c++11-lib localbase pkgconfig
CMAKE_ARGS= -DUSB_BACKEND_LIBUSB=on -DBUILD_QT_UI=off
-PLIST_FILES= bin/aft-mtp-cli
-OPTIONS_DEFINE= FUSE
-OPTIONS_DEFAULT=FUSE QT5
+OPTIONS_DEFAULT=CLI FUSE
+OPTIONS_MULTI= COMP
+OPTIONS_MULTI_COMP= CLI FUSE
OPTIONS_RADIO= GUI
OPTIONS_RADIO_GUI= QT4 QT5
+OPTIONS_EXCLUDE?=${OPTIONS_RADIO_GUI}
# XXX http://lists.dragonflybsd.org/pipermail/users/2016-September/313064.html
OPTIONS_EXCLUDE_DragonFly= FUSE
+COMP_DESC= Components
+
+CLI_DESC= CLI (Command-Line Interface) support
+CLI_USES= readline
+CLI_PLIST_FILES=bin/aft-mtp-cli
+
FUSE_USES= fuse
FUSE_CMAKE_BOOL=BUILD_FUSE
FUSE_PLIST_FILES=bin/aft-mtp-mount
@@ -44,4 +52,7 @@ QT5_PLIST_FILES=bin/android-file-transfer \
CONFIGURE_ENV+= PKG_CONFIG_PATH="${FILESDIR}"
.endif
+post-patch-CLI-off:
+ @${REINPLACE_CMD} '/subdirectory(cli)/d' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>