aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /sysutils
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/battstat-applet/Makefile2
-rw-r--r--sysutils/gcombust/Makefile2
-rw-r--r--sysutils/gnome-control-center/Makefile2
-rw-r--r--sysutils/gnome-control-center1/Makefile2
-rw-r--r--sysutils/gnome-system-monitor/Makefile2
-rw-r--r--sysutils/gnomecontrolcenter/Makefile2
-rw-r--r--sysutils/gnomecontrolcenter2/Makefile2
-rw-r--r--sysutils/gnomefind/Makefile2
-rw-r--r--sysutils/gnomesystemmonitor/Makefile2
-rw-r--r--sysutils/gtop/Makefile2
-rw-r--r--sysutils/gupsc/Makefile2
-rw-r--r--sysutils/medusa/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/sysutils/battstat-applet/Makefile b/sysutils/battstat-applet/Makefile
index af41b483d4cb..7bac1b51ff34 100644
--- a/sysutils/battstat-applet/Makefile
+++ b/sysutils/battstat-applet/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
diff --git a/sysutils/gcombust/Makefile b/sysutils/gcombust/Makefile
index 97d755491aa9..3a6f9ae9654b 100644
--- a/sysutils/gcombust/Makefile
+++ b/sysutils/gcombust/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${PERL} -pi -e 's|==|=|g' ${WRKSRC}/po/Makefile.in.in
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index b3d1cb727822..a6e1f48cdbbf 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnome-control-center1/Makefile b/sysutils/gnome-control-center1/Makefile
index b3d1cb727822..a6e1f48cdbbf 100644
--- a/sysutils/gnome-control-center1/Makefile
+++ b/sysutils/gnome-control-center1/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 4b39bca005d2..4dbf9a588bf3 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnomecontrolcenter/Makefile b/sysutils/gnomecontrolcenter/Makefile
index b3d1cb727822..a6e1f48cdbbf 100644
--- a/sysutils/gnomecontrolcenter/Makefile
+++ b/sysutils/gnomecontrolcenter/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnomecontrolcenter2/Makefile b/sysutils/gnomecontrolcenter2/Makefile
index b3d1cb727822..a6e1f48cdbbf 100644
--- a/sysutils/gnomecontrolcenter2/Makefile
+++ b/sysutils/gnomecontrolcenter2/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnomefind/Makefile b/sysutils/gnomefind/Makefile
index cb3399c4bf3d..3d9df3d28fd4 100644
--- a/sysutils/gnomefind/Makefile
+++ b/sysutils/gnomefind/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnome-find.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
index 4b39bca005d2..4dbf9a588bf3 100644
--- a/sysutils/gnomesystemmonitor/Makefile
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gtop/Makefile b/sysutils/gtop/Makefile
index 4b39bca005d2..4dbf9a588bf3 100644
--- a/sysutils/gtop/Makefile
+++ b/sysutils/gtop/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/sysutils/gupsc/Makefile b/sysutils/gupsc/Makefile
index f40f382b05eb..3ea93d7bd8a9 100644
--- a/sysutils/gupsc/Makefile
+++ b/sysutils/gupsc/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure \
${WRKSRC}/src/Makefile.in
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
diff --git a/sysutils/medusa/Makefile b/sysutils/medusa/Makefile
index 415adf7c8591..a09ddce7fa3e 100644
--- a/sysutils/medusa/Makefile
+++ b/sysutils/medusa/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \