aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-09-08 20:35:45 +0800
committerrafan <rafan@FreeBSD.org>2006-09-08 20:35:45 +0800
commit90bbd2d06974b2f22bf96c1d09e685684a00e215 (patch)
treefb35955f1c7e988f98dd046ddb2e3999e1898b2b /sysutils
parent4d05810cf88f629fedeb9265cadc928762dd0b5b (diff)
downloadfreebsd-ports-gnome-90bbd2d06974b2f22bf96c1d09e685684a00e215.tar.gz
freebsd-ports-gnome-90bbd2d06974b2f22bf96c1d09e685684a00e215.tar.zst
freebsd-ports-gnome-90bbd2d06974b2f22bf96c1d09e685684a00e215.zip
Add p5-File-Next 0.28, file-finding iterator. This is required by
textproc/p5-ack 1.26 update. PR: ports/102988 Submitted by: chinsan <chinsan.tw at gmail.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-File-Next/Makefile28
-rw-r--r--sysutils/p5-File-Next/distinfo3
-rw-r--r--sysutils/p5-File-Next/pkg-descr4
-rw-r--r--sysutils/p5-File-Next/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 01dbc29d9753..53020a78f564 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -391,6 +391,7 @@
SUBDIR += p5-BSD-Jail-Object
SUBDIR += p5-BSD-Sysctl
SUBDIR += p5-Dir-Purge
+ SUBDIR += p5-File-Next
SUBDIR += p5-File-Stat-Bits
SUBDIR += p5-File-Which
SUBDIR += p5-Filesys-Df
diff --git a/sysutils/p5-File-Next/Makefile b/sysutils/p5-File-Next/Makefile
new file mode 100644
index 000000000000..2997c41ed8b3
--- /dev/null
+++ b/sysutils/p5-File-Next/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-File-Next
+# Date created: 2006/09/08
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Next
+PORTVERSION= 0.28
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= File-finding iterator
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Next.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-File-Next/distinfo b/sysutils/p5-File-Next/distinfo
new file mode 100644
index 000000000000..cfb40b6e038a
--- /dev/null
+++ b/sysutils/p5-File-Next/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Next-0.28.tar.gz) = a636a101c48295ef11f40fad39876d8c
+SHA256 (File-Next-0.28.tar.gz) = 988b98c4bc4e4740fb282decab461c9166236fa9abf0b1a72cafc4facc7ed8d8
+SIZE (File-Next-0.28.tar.gz) = 8356
diff --git a/sysutils/p5-File-Next/pkg-descr b/sysutils/p5-File-Next/pkg-descr
new file mode 100644
index 000000000000..62654fa4533c
--- /dev/null
+++ b/sysutils/p5-File-Next/pkg-descr
@@ -0,0 +1,4 @@
+File::Next is a lightweight, taint-safe file-finding module. It's
+lightweight and has no non-core prerequisites.
+
+WWW: http://search.cpan.org/dist/File-Next/
diff --git a/sysutils/p5-File-Next/pkg-plist b/sysutils/p5-File-Next/pkg-plist
new file mode 100644
index 000000000000..fe1c956e238a
--- /dev/null
+++ b/sysutils/p5-File-Next/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Next.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Next/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Next
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File