aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-14 02:49:27 +0800
committerswills <swills@FreeBSD.org>2014-03-14 02:49:27 +0800
commit95a648782fe4f19bc15d969ee20784bfb765908f (patch)
tree30955ba83c85730fe5ec8016b05a8e390ee299bc /sysutils
parent9f104d60f32547fc7a8292a3f639c33f98873764 (diff)
downloadfreebsd-ports-gnome-95a648782fe4f19bc15d969ee20784bfb765908f.tar.gz
freebsd-ports-gnome-95a648782fe4f19bc15d969ee20784bfb765908f.tar.zst
freebsd-ports-gnome-95a648782fe4f19bc15d969ee20784bfb765908f.zip
This Hammer CLI plugin contains set of commands for Foreman.
WWW: https://github.com/theforeman/hammer-cli-foreman PR: ports/187483 Submitted by: Michael Moll <kvedulv@kvedulv.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rubygem-hammer_cli_foreman/Makefile21
-rw-r--r--sysutils/rubygem-hammer_cli_foreman/distinfo2
-rw-r--r--sysutils/rubygem-hammer_cli_foreman/files/patch-lib__hammer_cli_foreman__commands.rb28
-rw-r--r--sysutils/rubygem-hammer_cli_foreman/pkg-descr3
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0e6c69754864..76ab57293560 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -806,6 +806,7 @@
SUBDIR += rubygem-guard-minitest
SUBDIR += rubygem-guard-rspec
SUBDIR += rubygem-hammer_cli
+ SUBDIR += rubygem-hammer_cli_foreman
SUBDIR += rubygem-hiera
SUBDIR += rubygem-hiera-json
SUBDIR += rubygem-hiera-puppet
diff --git a/sysutils/rubygem-hammer_cli_foreman/Makefile b/sysutils/rubygem-hammer_cli_foreman/Makefile
new file mode 100644
index 000000000000..8a4df8ddd5f7
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman/Makefile
@@ -0,0 +1,21 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= hammer_cli_foreman
+PORTVERSION= 0.0.18
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Foreman commands for Hammer CLI
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rubygem-foreman_api>=0.1.11:${PORTSDIR}/devel/rubygem-foreman_api \
+ rubygem-hammer_cli>=0.0.18:${PORTSDIR}/sysutils/rubygem-hammer_cli
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-hammer_cli_foreman/distinfo b/sysutils/rubygem-hammer_cli_foreman/distinfo
new file mode 100644
index 000000000000..6cc076387e13
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hammer_cli_foreman-0.0.18.gem) = 97a7310e001726bf8bc0004bb9f08c87650e224fac351b1e3f8b2dc593e05337
+SIZE (rubygem/hammer_cli_foreman-0.0.18.gem) = 48640
diff --git a/sysutils/rubygem-hammer_cli_foreman/files/patch-lib__hammer_cli_foreman__commands.rb b/sysutils/rubygem-hammer_cli_foreman/files/patch-lib__hammer_cli_foreman__commands.rb
new file mode 100644
index 000000000000..6701e8e6304d
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman/files/patch-lib__hammer_cli_foreman__commands.rb
@@ -0,0 +1,28 @@
+--- lib/hammer_cli_foreman/commands.rb.orig 2014-03-12 11:03:33.000000000 +0100
++++ lib/hammer_cli_foreman/commands.rb 2014-03-12 11:03:49.000000000 +0100
+@@ -60,9 +60,9 @@
+ end
+
+ def execute
+- if respond_to?(:page) && respond_to?(:per_page)
+- self.page ||= 1
+- self.per_page ||= HammerCLI::Settings.get(:ui, :per_page) || DEFAULT_PER_PAGE
++ if respond_to?(:option_page) && respond_to?(:option_per_page)
++ self.option_page ||= 1
++ self.option_per_page ||= HammerCLI::Settings.get(:ui, :per_page) || DEFAULT_PER_PAGE
+ browse_collection
+ else
+ retrieve_and_print
+@@ -79,10 +79,10 @@
+ while list_next do
+ d = retrieve_and_print
+
+- if (d.size >= self.per_page.to_i) && interactive?
++ if (d.size >= self.option_per_page.to_i) && interactive?
+ answer = ask("List next page? (Y/n): ").downcase
+ list_next = (answer == 'y' || answer == '')
+- self.page += 1
++ self.option_page += 1
+ else
+ list_next = false
+ end
diff --git a/sysutils/rubygem-hammer_cli_foreman/pkg-descr b/sysutils/rubygem-hammer_cli_foreman/pkg-descr
new file mode 100644
index 000000000000..ecf77cef81a4
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman/pkg-descr
@@ -0,0 +1,3 @@
+This Hammer CLI plugin contains set of commands for Foreman.
+
+WWW: https://github.com/theforeman/hammer-cli-foreman