aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-12-28 10:51:31 +0800
committerpav <pav@FreeBSD.org>2004-12-28 10:51:31 +0800
commit98904191a0583ebab1d1d80dafb837083dd6a09f (patch)
tree33dc45acf8cb3200314b5fc3a5c4314567c9960a /sysutils
parentd93e6b7b73ef2961acf9c6f5058c4ca7be782b8d (diff)
downloadfreebsd-ports-gnome-98904191a0583ebab1d1d80dafb837083dd6a09f.tar.gz
freebsd-ports-gnome-98904191a0583ebab1d1d80dafb837083dd6a09f.tar.zst
freebsd-ports-gnome-98904191a0583ebab1d1d80dafb837083dd6a09f.zip
pkg_rmleaves finds packages that are not requested by any other installed
package and lets you decide (in a beauty dialog interface) for each one if you want to keep it or delete it. This is similar to pkg_cutleaves, but it does not require any dependencies and is done in visual, dialog(1) interface instead of command line. PR: ports/75517 Submitted by: Timothy Redaelli <drizzt@gufi.org>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pkg_rmleaves/Makefile25
-rw-r--r--sysutils/pkg_rmleaves/distinfo2
-rw-r--r--sysutils/pkg_rmleaves/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 647d02b8f930..211496ac43c0 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -335,6 +335,7 @@
SUBDIR += pkg_install
SUBDIR += pkg_install-devel
SUBDIR += pkg_remove
+ SUBDIR += pkg_rmleaves
SUBDIR += pkg_tree
SUBDIR += pkill
SUBDIR += plconfig
diff --git a/sysutils/pkg_rmleaves/Makefile b/sysutils/pkg_rmleaves/Makefile
new file mode 100644
index 000000000000..a2a87b67b138
--- /dev/null
+++ b/sysutils/pkg_rmleaves/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pkg_rmleaves
+# Date created: 26 December 2004
+# Whom: Timothy Redaelli <drizzt@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkg_rmleaves
+PORTVERSION= 20041223
+CATEGORIES= sysutils
+MASTER_SITES= http://utenti.gufi.org/~drizzt/${PORTNAME}/
+
+MAINTAINER= drizzt@gufi.org
+COMMENT= Interactive script for deinstalling 'leaf' packages
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= sbin/pkg_rmleaves
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg_rmleaves ${PREFIX}/sbin/pkg_rmleaves
+
+.include <bsd.port.mk>
diff --git a/sysutils/pkg_rmleaves/distinfo b/sysutils/pkg_rmleaves/distinfo
new file mode 100644
index 000000000000..f8d9da8a5767
--- /dev/null
+++ b/sysutils/pkg_rmleaves/distinfo
@@ -0,0 +1,2 @@
+MD5 (pkg_rmleaves-20041223.tar.gz) = 9eaa0b99ccebdaf08a4a9eef07695218
+SIZE (pkg_rmleaves-20041223.tar.gz) = 1034
diff --git a/sysutils/pkg_rmleaves/pkg-descr b/sysutils/pkg_rmleaves/pkg-descr
new file mode 100644
index 000000000000..18db9a6e3cec
--- /dev/null
+++ b/sysutils/pkg_rmleaves/pkg-descr
@@ -0,0 +1,3 @@
+pkg_rmleaves finds packages that are not requested by any other installed
+package and lets you decide (in a beauty dialog interface) for each one
+if you want to keep it or delete it.